Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Shrink tab width

  • 9 replies
  • 0 have this problem
  • 228 views
  • Last reply by WFiske

more options

I need to shrink the size of my tabs, which remains constant no matter how many are open. If I have four open, I get the "+" for a new tab at the end of the tab bar. If there are five open, the tabs consume the entire width of the browser window and the "+" sign disappears. It is not found in the "customize toolbar" menu. I have tried restoring tool bar defaults and changing the uidensity to 1, but neither change shrinks the size of the tabs or gives me the "+" option.

What do I need to do to get back to the way it used to work?

I need to shrink the size of my tabs, which remains constant no matter how many are open. If I have four open, I get the "+" for a new tab at the end of the tab bar. If there are five open, the tabs consume the entire width of the browser window and the "+" sign disappears. It is not found in the "customize toolbar" menu. I have tried restoring tool bar defaults and changing the uidensity to 1, but neither change shrinks the size of the tabs or gives me the "+" option. What do I need to do to get back to the way it used to work?

Chosen solution

This is possibly a case of broken CSS code in userChrome.css. See this thread:

Read this answer in context 👍 0

All Replies (9)

more options

Helpful?

more options

Doesn't help. That tabbrowser rule does not appear in the userChrome.css file.  :-(

Helpful?

more options

You can set the tab width to 50 (no less) using the following preference in about:config. The default is 76. browser.tabs.tabMinWidth

You could try the code in the thread below (remove the blank space).

https://www.reddit. com/r/firefox/comments/b9vjbw/wanting_my_tab_sizes_even_smaller_any_way_to/

Helpful?

more options

Thanks for the suggestion. I had tried that, but it didn't change the width of the tabs. If I set it larger (to say 250), the tabs will grow larger and run off the edge of the browser window (rather than adapting to that limit).

I have attached a screenshot of my window. As you can see, there are 5 very wide tabs (even though mintabswidth is set to 50), and no plus sign. I am very confused.

Helpful?

more options

If you only have 5 tabs, they will exceed the minimum size. Is the open tab icon in the Customize page? Evidently, it looks different there. If it's there, you can drag it to the toolbar. If it isn't there, try the button bottom right labelled Restore Defaults.

Helpful?

more options

Chosen Solution

This is possibly a case of broken CSS code in userChrome.css. See this thread:

Helpful?

more options

Thanks cor-el for the suggestion. zeroknight also suggested this in the first reply, but I checked and I did not have the #tabbrowser-tabs line in my userChrome.css. I remain baffled.

Helpful?

more options

Can you post the content of your userChrome.css as it is likely a problem with this file if you are using it ?

Helpful?

more options

I went to snag a copy of my userChrome.css to post and looked at it again. This time the problematic line was in it. I deleted it, and it seems to be fixed. I don't know how I missed it before (even doing a search in the text). I can't thank everyone enough for the help!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.