Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox blocks pop-ups from a website that has an exception for pop-ups.

  • 7 replies
  • 1 has this problem
  • 149 views
  • Last reply by mail1729

more options

I have a website that open pop-ups automatically using javascript. That is the expected behaviour of it. So I went into Firefox options and made an exception for that site. If I go to the site and wait so it can do its thing, it opens about a few of them, and then Firefox decides that the rule I have set up is garbage, and firefox decides to ignore it and block the pop-ups from the site.

Why?

Why on Earth does Firefox decides that he must do something against the rule that the user has set up. Why does it have this completely disrespect to the user settings?

I am honestly really mad at whoever decided that ignoring an exception from the user was the default behaviour.

Now, if someone knows enough what is going on they will tell me, go to about:config, go to this obscure command and change its value, value which I can't know without coming here and ask. If I create an exception, then I am in my right to expect that the browser should do exactly as the exception has been configured.

By the way I have tried with the troubleshooting mode and still happens.

I have a website that open pop-ups automatically using javascript. That is the expected behaviour of it. So I went into Firefox options and made an exception for that site. If I go to the site and wait so it can do its thing, it opens about a few of them, and then Firefox decides that the rule I have set up is garbage, and firefox decides to ignore it and block the pop-ups from the site. Why? Why on Earth does Firefox decides that he must do something against the rule that the user has set up. Why does it have this completely disrespect to the user settings? I am honestly really mad at whoever decided that ignoring an exception from the user was the default behaviour. Now, if someone knows enough what is going on they will tell me, go to about:config, go to this obscure command and change its value, value which I can't know without coming here and ask. If I create an exception, then I am in my right to expect that the browser should do exactly as the exception has been configured. By the way I have tried with the troubleshooting mode and still happens.
Attached screenshots

Chosen solution

Aha, mentioning 20 reminded me of a setting. Try this change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste dom.popup_maximum and pause while the list is filtered

(3) Double-click the preference (or click the pencil button) to display an editing field, and change the value to 30 or whatever you think is needed, then press Enter or click the blue check mark button to save the change.

If you prefer no limit at all, change the value to -1 and then press Enter or click the blue check mark button.

Read this answer in context 👍 3

All Replies (7)

more options

Site? Steps to replicate please.

more options

Does the bar about the window being blocked have a button on the right side? If so, that button's drop-down menu should show the address of the popup window. Is it on the same site (the one that has permission) or a different site?

more options

There is a button, and when clicked on it, the only option given is to block, because well, there is an exception already allowing them...

By the way the exact number that opens is 19. At the 20th, it decides it doesn't give a hoot about the rule anymore.

more options

Chosen Solution

Aha, mentioning 20 reminded me of a setting. Try this change:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste dom.popup_maximum and pause while the list is filtered

(3) Double-click the preference (or click the pencil button) to display an editing field, and change the value to 30 or whatever you think is needed, then press Enter or click the blue check mark button to save the change.

If you prefer no limit at all, change the value to -1 and then press Enter or click the blue check mark button.

more options

That made the trick. Thank you.

Still I don't get who got the brilliant idea of making an invisible (internal) rule to work over a visible (user-configured) exception rule. I imagine that it is something that devs are not going to change, isn't it?

more options

The main purpose of the hard cap is to block abuse of JavaScript dialogs such as window.alert(), while the popup blocker feature is meant to control new windows launched with window.open().

It's truly weird that you use a page that needs to launch more than 20 new windows without a triggering user action. You could file a bug for an exception to the hard cap for sites with popup permission (or maybe there already is one on file that you could vote for):

https://bugzilla.mozilla.org/

Or post an Idea on Mozilla Connect to build community support:

https://connect.mozilla.org/ (Use the "Ideas" section of the site)

more options

It is an idea similar to this: https://trackthis.link/