Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can not access web interface with router

  • 15 replies
  • 1 has this problem
  • 33 views
  • Last reply by focuspuller

more options

Up until the last update of Firefox I was able to access my router, 192.168.1.1, enter password and check it.

Now I get an error message "connection not secure" "Your connection to this site is not private. Information you submit could be viewed by others (like passwords, messages, credit cards, etc.)

None of this is part of looking at my router, Asus GT-AX11000.

Up until the last update of Firefox I was able to access my router, 192.168.1.1, enter password and check it. Now I get an error message "connection not secure" "Your connection to this site is not private. Information you submit could be viewed by others (like passwords, messages, credit cards, etc.) None of this is part of looking at my router, Asus GT-AX11000.

Chosen solution

Found the fix for https:// on ASUS Routers

[Wireless Router] How to enable HTTPS and create a certification on ASUS router? https://www.asus.com/support/faq/1034294

Read this answer in context 👍 1

All Replies (15)

more options

If all the connections to the router are active at the same time it will not allow you to connect to the router set-up interface. Since you don't have access to the physical router try turning off other network devices and see if you can connect.

This may help you, Rachel Gomez

Helpful?

more options

only using two ethernet ports on router. Was able to get UI in my browser by using "Private Window".

The real solve is for Asus to have a valid secure certificate.

Helpful?

more options

Did you follow the router login instructions. You can connect wifi or ethernet.

@Rachel stop giving bad info they can login to the router regardless whom connected.

Helpful?

more options

If you can get there in a private window, corrupt cookies may be the problem. Try clearing cookies.

https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox

Helpful?

more options

does not solve issue removed all cookies and still could not access router web interface

Firefox has to allow a router and not consider it a security threat

Helpful?

more options

Does the error page give an error code? Usually it is ALL_CAPS_SEPARATED_BY_UNDERSCORES.

Helpful?

more options

There is no error message...just an info box stating that this is a non secure website.

It is not a website...it's the user interface of the router.

Firefox needs to see that 192.168.1.1 ( or any IP address to a router or non website) is not a website.

Helpful?

more options

focuspuller said

There is no error message...just an info box stating that this is a non secure website.

Oh... is this on the login form?

If the address starts with http:// instead of https:// then that is a completely normal and true bit of information. If the device supports an https:// connection you could use that instead.

It is not a website...it's the user interface of the router. Firefox needs to see that 192.168.1.1 ( or any IP address to a router or non website) is not a website.

Well... if your browser accesses the UI using http:// or https://, instead of file://, then the router has a built-in web server and Firefox see is it as a website.

Helpful?

more options

As a footnote to that screenshot, I'm using a hidden option to show the http:// which is normally hidden. If it would be helpful to have that showing on your Firefox, here's how to set it up.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we have had this setting for a long time and I use it myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste browser.urlbar.trimURLs and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

Helpful?

more options

Yes I get the http://

But in the past before the last update Firefox was able to access my router user interface.

Why did it have to stop?

Helpful?

more options

The warning message shouldn't be blocking, but since it is sizes to the field width, its height depends on the arrangement of the login form. Tap the Esc key to dismiss it if it doesn't let you click into the field, or tap the Tab key to move to the next field.

Helpful?

more options

Further thought:

It's possible that Firefox was previously auto-upgrading from http to https, and therefore the warning wouldn't be displayed. Why would Firefox stop doing that? Some routers with older firmware do not support the TLS 1.2 protocol, only the older TLS 1.0 and 1.1 protocols. Attempting an https connection with such routers causes a secure connection error. In that case, Firefox can't (successfully) auto-upgrade the connection. You could check whether that is a factor by manually trying to make an https connection and seeing whether you get a protocol error code.

Helpful?

more options

Tried the https:// ... failed also.

At this time I have a work around by using the "private window" in Firefox.

Also found the same issue with Chrome.

Opera does not have this issue.

Helpful?

more options

focuspuller said

Tried the https:// ... failed also. At this time I have a work around by using the "private window" in Firefox.

The HTTPS page showed the same warning on the login form, or it wouldn't connect at all?

I wonder why a private window page works differently. That can indicate that a long-saved cookie or something in the cache -- re-used in regular windows but ignored in private windows -- could be the culprit. Also, some add-ons may be disabled in private windows (if you haven't enabled them to run in private windows). Doesn't sound urgent to explore further, but we can describe how to clear some things for testing if desired.

Helpful?

more options

Chosen Solution

Found the fix for https:// on ASUS Routers

[Wireless Router] How to enable HTTPS and create a certification on ASUS router? https://www.asus.com/support/faq/1034294

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.