Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unable to select download action for file type

  • 6 replies
  • 1 has this problem
  • 50 views
  • Last reply by nathanb418

more options

When I go to download a ZIP file, it will always attempt to download the file directly rather than letting me open it with WinRAR. When I go into the browser settings I see that some other file types have options to choose how they're handled, but there's no entry for ZIP files. I've tried refreshing my Firefox install and yet the issue still persists.

I used to have this option before I reinstalled Windows a while back (where I kept my files but not programs). I don't know for sure that that's what caused this to start, but the timing would line up.

When I go to download a ZIP file, it will always attempt to download the file directly rather than letting me open it with WinRAR. When I go into the browser settings I see that some other file types have options to choose how they're handled, but there's no entry for ZIP files. I've tried refreshing my Firefox install and yet the issue still persists. I used to have this option before I reinstalled Windows a while back (where I kept my files but not programs). I don't know for sure that that's what caused this to start, but the timing would line up.
Attached screenshots

All Replies (6)

more options

https://www.mozilla.org/en-US/firefox/98.0/releasenotes/ Firefox has a new optimized download flow . . . .

https://support.mozilla.org/en-US/kb/manage-downloads-preferences-using-downloads-menu Changes to how file downloads are handled in Firefox version 98

  • Firefox no longer asks what to do for each file by default
  • Downloads panel automatically opens
  • Downloaded files are saved to disk
  • Set a default app to open a file type
  • "Always Open Similar Files" option from the Downloads panel
  • Frequently asked questions


You can set this pref to false on the about:config page to prevent opening the download panel on each download.

  • browser.download.alwaysOpenPanel = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Chosen Solution

more options

Note that this usually means that the server sends the file as a generic content-type like "application/octet-stream" or as"content-disposition:attachment".

See also the Content-Type Fixer extension:

more options

I see what you all mean about the new download process. Setting it to always open ZIP files put the file type entry back in the list in settings where you pick how each file type is handled, where I can then change it to always ask again. (I did change the option that was mentioned in about:config, but that didn't seem to solve my problem)

My problem now is that it always seems to throw the files into the default Downloads folder, which I'd rather it not do. I understand this is a case that really only exists for ZIP files and similar, but once I extract the files that I need from the archive I don't need it any more which is why I liked the old behavior where files would be saved to a temp folder where they would be automatically deleted (I assume) at a later date. Is there any way to restore this behavior other than to just change the default download directory?

more options

Try this this thread I created and since FF98 the new change saves rather then ask you what you want to do.


FF99.xx and Some tips to make it work. https://support.mozilla.org/en-US/questions/1374212

more options

That did it, thank you!