Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't open bank statements on websites

  • 5 replies
  • 1 has this problem
  • 393 views
  • Last reply by FredMcD

more options

I've just started using Firefox as my browser and really like it, but I am unable to open various items (bank statements, etc) when I go to some of my websites. No problem when I use Chrome or others. Can't find anything to change in Firefox settings. Very annoying. How to fix this?

I've just started using Firefox as my browser and really like it, but I am unable to open various items (bank statements, etc) when I go to some of my websites. No problem when I use Chrome or others. Can't find anything to change in Firefox settings. Very annoying. How to fix this?

Chosen solution

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.

Read this answer in context 👍 0

All Replies (5)

more options

What happens when you try to open the statement? Is there an error message?

Two thoughts come to mind:

(1) Many statements open in a popup window

Usually Firefox allows popups that directly follow clicking a link or button, but some popups are blocked. Do you see any messages in the toolbar area related to a blocked popup?

(2) Many statements are in PDF format

Usually Firefox will display PDFs in a new tab. If you get a blank tab, it could indicate that the built-in PDF viewer is disabled.

more options

No I don't get any error message. It tries to open the requested statement but only for a second, then nothing happens. This is happening on all websites where I try to open a pdf I don't get any indication that a popup has been blocked and no new tab opens

Modified by JDBJ

more options

Could you check your Downloads list to see whether Firefox is auto-saving the files instead of opening them? It should be accessible from the Downloads button on the toolbar.

If you need to override that behavior, you can select Open in Firefox on the Settings page: View PDF files in Firefox or choose another viewer.

more options

I think I fixed it. I opened up my list of downloads (CTRL-J) and went to one of my previously downloaded PDFs, then right clicked on it and selected "Always open in system viewer". Now I'm able to open all PDFs on sites. Thanks so much for your assistance but I guess I accidentally stumbled on the solution!

more options

Chosen Solution

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.