Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Appearance of Gmail in Firefox

more options

HI After using Chrom for num of years I have now reverted (upgarded!?) for Firefox. However what's casuing me to regret my decision is the layout og Gmail in the browswer. Most of the labels and text are surround by a white Highlight or box which looks ugly. I have exhauste dverything I know to get the text to look like Gmail in Chrome with no success. See attached screen shot of comparison. Could you please give some idea so That I can stay with Firefox Kind regards Chris

HI After using Chrom for num of years I have now reverted (upgarded!?) for Firefox. However what's casuing me to regret my decision is the layout og Gmail in the browswer. Most of the labels and text are surround by a white Highlight or box which looks ugly. I have exhauste dverything I know to get the text to look like Gmail in Chrome with no success. See attached screen shot of comparison. Could you please give some idea so That I can stay with Firefox Kind regards Chris
Attached screenshots

All Replies (8)

more options

It's possible what happen is the web page was clicked on and the text was highlighted.

Or this is more likely a font issue.

[v56+] Type about:preferences#general<enter> in the address box. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

Modified by FredMcD

more options

Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem,

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

While you are in Troubleshoot(Safe) mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

more options

I have tried both of the suggestions given to no avail. Still as posted image. I apprecaite the time you have given. I would have replied sooner if not for the "silly season"! Chris Any other thoughts. This is such a nuisance and spoils my move to Firfox.

more options
more options

I see this happen if I choose to "Override the colors specified by the page with your selections above" always, make sure you do not do this.

  • Settings -> General: Fonts & Colors -> Colors: "Override the colors specified by the page with your selections above"

Try "Never" if the default "Only with High Contrast themes" isn't working.

Modified by cor-el

more options

Thank Cor-el, I too have identied this as a problem and it works for Gmail. BUT, I am color blind and need to change visited site to say red. This seems impossible with this set up. I had tried third party add-ons and extensions and none of them work! I am about to give up on Firefox ... all too difficult for something which is simple in Chrome. I have a screen shot of my set up at the moment, Gmail works but Google search doesn't. Can you help ...please! Chris

more options

Hi Chris, how did you set link color to red in Chrome?

The issue with the Firefox setting is that it is only used if the page does NOT set its own color, so an add-on is needed to override that.

One reason it might not work well on Google Search results page is when you "mouse down" on a result link it typically changes from the actual site link to a tracking link (you can see this if you watch the lower left corner while right-clicking a link). If you remove the tracking changes, perhaps that would help with the coloration? One option is:

https://addons.mozilla.org/firefox/addon/dont-track-me-google1/

more options

Hi fella's Thanks for all your replies, unfortunately none of these work! What I want should be simple, I believe. Change colour of visited sites. Not have this change view of Gmail. Why is this so difficult? Sorely disappointed with Firefox with this issue, may stay with Chrome where it's not an issue. Kind regards Chris