Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT

more options

Did Not Connect: Potential Security Issue

Firefox detected a potential security threat and did not continue to www.nextechclassifieds.com because this website requires a secure connection. www.nextechclassifieds.com has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site. www.nextechclassifieds.com uses an invalid security certificate.

The certificate is not trusted because it is self-signed.
Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT

This is a trusted website, been using it for years without issue. Used it a few hours ago to check my account. Only problem is on my pc, all other devices including people I've asked, do not have this issue. Seems to be a problem with the firefox browser only.

Attached screenshots

Chosen solution

No problems here with this website. I get a certificate issued by DigiCert Inc.

Can you post the base64 encoded certificate data or show a screenshot that shows the certificate details ?

Read this answer in context 👍 0

All Replies (3)

more options

Chosen Solution

No problems here with this website. I get a certificate issued by DigiCert Inc.

Can you post the base64 encoded certificate data or show a screenshot that shows the certificate details ?

Helpful?

more options

Try to rename the cert9.db file (cert9OLD.db) and remove the previously used cert8.db file in the Firefox profile folder with Firefox closed to remove intermediate certificates and exceptions that Firefox has cached.

If this has helped to solve the problem then you can remove the renamed cert9OLD.db file. Otherwise you can undo the rename and restore cert9.db.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page (Root directory).

Helpful?

more options

It now works, but I didn't even do anything. I have no idea why.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.