Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Getting rid of Duckduckgo

  • 6 replies
  • 1 has this problem
  • 26 views
  • Last reply by philmguy

more options

I installed the Duckduckgo extension and decided after a week that I didn't want to use it any longer. I disabled the extension and in Preferences/Search selected Google to once again be my default search engine. But, when I do a search, Duckduckgo comes up as the default, and when I look in Preferences/Search it again shows as the default. I went back into extensions and totally removed Duckduckgo, reset Google again as the default but it reverts to Duckduckgo. I went into One-Click Search Engines and removed Duckduckgo, but then when I try to select my default search engine there are no search engines from which to choose. I clicked on Restore Default Search Engines but then I'm back to Duckduckgo being the default search engine. I've spent hours searching online with no success. How do I get rid of it and get Google back as my default? I'm using Firefox 82.0 on an iMac running Catalina. I updated to 82.0 hoping that might solve the issue, but no luck.

Chosen solution

Hi, I know there shouldn't be an organization, but it's one of the flags that can indicate an external settings file is controlling your Firefox. So you probably haven't seen that on your Preferences page anywhere.

Perhaps the file that stores search engine preferences has become corrupted or is locked. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default-release, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Quit.

Pause while Firefox finishes its cleanup, then rename search.json.mozlz4 to something like searchOLD.json.mozlz4.

Start Firefox back up again and check Search preferences. Those should be back at the defaults.

Any improvement?

Read this answer in context 👍 1

All Replies (6)

more options

Hi, Firefox comes with a DuckDuckGo search engine extension, so that is normal, but it is not the default when you set up Firefox, that is usually Google around these parts.

philmguy said

I clicked on Restore Default Search Engines but then I'm back to Duckduckgo being the default search engine.

When you use that Restore button, you should have gotten all the preinstalled search engines back in the box, including Google. Is Google there now?

You also should get all of them in the drop-down list for choosing your default search engine. If it's still missing there, try a regular Quit and restart of Firefox to make sure the Preferences page is reading the current data. Any luck?

Helpful?

more options

Thanks, but that doesn't solve the issue. I've selected Google multiple times as the default search engine, quit Firefox, restarted it and Duckduckgo still shows up as the default.

Helpful?

more options

Hmm, Firefox should not have a problem remembering your preference.

Does your Preferences page say anywhere that your organization is managing some of your settings?

After you change your default search engine setting to Google, does that stick until the next quit/restart or is it ignored/changed immediately?

Helpful?

more options

I agree it shouldn't have a problem. This is my home computer, so there's no organization involved. I can change the default to Google and stay on the same page, click in the search bar as if I was going to launch a search and it says I'm going to be searching using Duckduckgo.

Helpful?

more options

Chosen Solution

Hi, I know there shouldn't be an organization, but it's one of the flags that can indicate an external settings file is controlling your Firefox. So you probably haven't seen that on your Preferences page anywhere.

Perhaps the file that stores search engine preferences has become corrupted or is locked. You can rename the file and have Firefox rebuild it. Here's how:

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the "Show in Finder" button. If Finder highlights an icon with a semi-random name like a1b2c3d4.default-release, double-click it to display the contents of that profile folder.

Leaving that window open, switch back to Firefox and Quit.

Pause while Firefox finishes its cleanup, then rename search.json.mozlz4 to something like searchOLD.json.mozlz4.

Start Firefox back up again and check Search preferences. Those should be back at the defaults.

Any improvement?

Helpful?

more options

That solved it! Thanks so much. I'm filing away your solution in Evernote in case I ever run into the problem again.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.