Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Virtual keyboard immediately closes after prompted

more options

Hi everyone, sorry but I couldn't find this question answered anywhere else.

I am using a Surface Book 2, and when I am using it in tablet mode and I click a text field in firefox, the virtual keyboard pops up, but then is immediately pushed away, except for very rare occasions, where the firefox window gets stuck in the aspect ratio as shown in the attached photo, "making room" for the keyboard ^^

All Replies (10)

more options

Screenshot, when the keyboard can appear

Helpful?

more options

hii

Please follow through.

Click on the Windows icon bottom left of your screen near to where it says search Windows. Go to settings. Then click Ease of Access. Now click on keyboard.

Slide the Turns on On-Screen keyboard slider to off.

Hope this helps. Get back to us if you still face issues with On- screen keyboard. We are happy to help!

Helpful?

more options

That does not appear to do it, no, that just pops up a different virtual keyboard than the one I am normally using, one that is supposed to stick around permanently, I'd much rather be able to use the built-in touch keyboard that appears automatically when I select a text-field. After some trial and error(lots of error) it seems that the conflict is only appearing when my pc is in tablet mode. If I put it into desktop mode, it works fine, but then it does not appear automatically, I have to press the taskbar button for virtual keyboard every time I want to type.

Helpful?

more options

There are some preferences for the on-screen keyboard, but I'm not sure whether any of them do exactly what you want. if you want to give that a try:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste osk and pause while the list is filtered

(3) Double-click the ui.osk.enabled preference to switch it to true.

Does that restore the earlier behavior?

Thank You.

Helpful?

more options

Thank you for your suggestion, Shekhar, that seems to make it more consistent in not removing the keyboard immediately, however when I toggle the keyboard off, the browser window is still stuck only showing on half the screen, as shown in the picture below :(

Helpful?

more options

I am running a windows insider build version 10.0.19041 Build 19041, if that changes anything

Helpful?

more options

Hello...


What version of Firefox is it? There have been a lot of fixes this year.

Could you check and/or experiment with these settings -- I guess you'll need to attach your keyboard cover or use a bluetooth keyboard:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste osk and pause while the list is filtered

(3) Try variations on these preferences:

  • ui.osk.enabled -- this obviously needs to be set to true
  • ui.osk.detect_physical_keyboard -- defaults to true, which I think disables the on-screen keyboard if a keyboard is detected -- Firefox might not notice if the physical keyboard is detached/disabled after it does its initial hardware detection
  • ui.osk.require_win10 -- defaults to true, which I think disables the on-screen keyboard on Windows 8.1 and earlier but in theory should not affect you since you run Windows 10


thank you...

Helpful?

more options

Hi Ankit

I am using firefox version 77.0.1 (64-bit)

None of the combinations of osk settings seems to bring the desired behaviour :(

Helpful?

more options

Hello jakobpoulsen93, τry Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

   Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled. 

If Firefox is not running, you can start Firefox in Safe Mode as follows:

   On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
   On Mac: Hold the option key while starting Firefox.
   On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
   (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) 

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

Helpful?

more options

Thank you for your suggestion Aman, but unfortunately the problem still persists in safe mode :/

Modified by jakobpoulsen93

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.