Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

pdf prints incorrectly

  • 7 replies
  • 1 has this problem
  • 16 views
  • Last reply by WestEnd

more options

Basically, if a PDF file has italics, they print out bold. If I print to a file and reopen it in firefox, it also appears bold and not italic on the screen.

I read a similar post where a user had the same issue, but their solution seemed to be "open in Adobe Reader," which seems like a lame solution.. Their complaint was that the extra step is annoying, and I agree. When I download a PDF file or open one from Firefox, I should be able to do so within the browser. I can do it chrome, but I prefer not to use chrome.

I tried to attach screen shots of the page as it is supposed to be and how it actually prints, but the "Uploaded images:" box just keeps spinning. If anyone can help and would like to see what my issue actually looks like, I can sent you a picture somehow, I'm sure.

All Replies (7)

more options

Ha! Here it is, I was able to upload the screenshots as a response to my issue. The first image is as the PDF should be and the second is how the PDF actually prints. Thanks in advance for any help!

more options

Sounds like the software if not firefox that read the pdf is having issue opening the file. So what software do you have to open pdf?

more options

Hi seansean, as you can see the from the all the other text in the PDF, Firefox is using completely the wrong font for printing that document. This could be a bug in the viewer.

Do you override website fonts? You can check that setting here:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type font and Firefox should filter to the "Fonts & Colors" button, where you can click the "Advanced" button.

Make sure you have a check mark for "Allow pages to choose their own fonts, instead of your selections above"

If you changed that, does it affect the PDF viewer?


For best results printing PDFs, the advice remains to use a stand-alone PDF viewer application. Firefox is doing a conversion from PDF to HTML to display in the browser, and that creates some compromises and incompatibilities.

more options

jscher2000 said

...Firefox is doing a conversion from PDF to HTML to display in the browser, and that creates some compromises and incompatibilities.

Isn't there a 'Page Setup' option before printing that'd help?

~Pj

more options

Hi Pj, I don't know whether Print Preview would help, or would tell the same sad story...

more options

jscher2000 said

Make sure you have a check mark for "Allow pages to choose their own fonts, instead of your selections above"

I checked, and yes, that box is checked. Unchecked, all of the font is different.

Pj said

Isn't there a 'Page Setup' option before printing that'd help? ~Pj

Nothing in the page setup area seems applicable to this. I understand that a standalone viewer would accomplish this, but it's 2018, eh? As a student, I access and print PDF files on a regular basis.

Thanks for all of the suggestions. Any other thoughts?

more options

You can get Adobe Acrobat Reader and try that out and see what if it does anything different on the print.