Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Was working ok, now, last 2 days, it wont search for anything !!!!!

  • 6 replies
  • 2 have this problem
  • 7 views
  • Last reply by Happy112

more options

after multiple restarts....it still won't search for anything. My other search engines are working normally. I have updated with the latest version about 1 month ago and there were multiple problems so I had to use system restore just to get any functionality back....this worked fine and for the last month all was well in the world of Firefox. Firefox will not search for anything but it still brings up bookmarked site and sites from my history.....it appears to be redirecting itself into a loop which results with a blank screen....no error message at all. Can you help or do I need to get rid of it ?

Chosen solution

I spent some time playing with my firefox and found that it was my home page causing the problem, switched it back to the default and all is well !!! Thank you all for your ideas and input, as that's what got me into a "tech state of mind" Haven't been able to access my mail service, which is also the same company as my old home page (incredimail) so it took me awhile to get my mail and reply....but again, thanx ! Now i have to figure out how to get my mail service up !chosen solution

CHOSEN SOLUTION

Read this answer in context 👍 1

All Replies (6)

more options

Hi ,

There may be a little confusion here:   Firefox is   not   a search engine,   but a browser.
When you say:   other search engines are working normally,   are you talking about   e.g.   Bing   or   Google   ?
Or are you talking about other browsers,   like   e.g.   Edge   or
Internet Explorer   ?

Modified by Happy112

more options

My Chrome and Internet Explorer are working fine.

more options

100timesunsearchable said

My Chrome and Internet Explorer are working fine.

I made a dumb mistake earlier by mentioning   'Chrome',   when that should of course have been   'Google'. I apologize for that   !!!

more options

Which method are you using for searching, or more specifically, which ones work and which ones do not work:

(1) Type into Firefox's address bar and press Enter or click the right-pointing arrow button

(2) Type into Firefox's search bar and press Enter or click the right-pointing arrow button or click the icon of the search engine you want to use

(3) Opening your preferred search engine's home page (for example, https://www.google.com/ https://www.bing.com/ https://www.yahoo.com/ ) and searching from the search box in its page

(4) A different method

more options

Chosen Solution

I spent some time playing with my firefox and found that it was my home page causing the problem, switched it back to the default and all is well !!! Thank you all for your ideas and input, as that's what got me into a "tech state of mind" Haven't been able to access my mail service, which is also the same company as my old home page (incredimail) so it took me awhile to get my mail and reply....but again, thanx ! Now i have to figure out how to get my mail service up !chosen solution

CHOSEN SOLUTION

Modified by 100timesunsearchable

more options

Good for you,   figuring out what caused the problem   !
Would you be so kind as to mark   your   last post as   Chosen Solution,   so others will know and maybe even benefit from it   ?
Thank you   !