Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bing "We've set SafeSearch to strict because your browser communicated your preference for a safe web browsing experience."

  • 3 replies
  • 1 has this problem
  • 1 view
  • Last reply by philipp

more options

Hello, I just updated my Mozilla firefox today and with this update has come this problem. Bing Safesearch settings are now set to strict and i get this message. "SafeSearch We've set SafeSearch to strict because your browser communicated your preference for a safe web browsing experience." Here is a picture of what I am seeing. Additionally, Bing only does this with this browser, Google Chrome, Microsoft Edge work fine.

Hello, I just updated my Mozilla firefox today and with this update has come this problem. Bing Safesearch settings are now set to strict and i get this message. "SafeSearch We've set SafeSearch to strict because your browser communicated your preference for a safe web browsing experience." Here is a picture of what I am seeing. Additionally, Bing only does this with this browser, Google Chrome, Microsoft Edge work fine.
Attached screenshots

Modified by MaDmaxwell311

All Replies (3)

more options

As a starting point... When you have a problem with one particular site that previously worked normally, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes. If you do not see the number going down on the page, you can reload it using Ctrl+r to check progress.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click (on Mac Ctrl+click) a blank area of the page and choose View Page Info > Security > "View Cookies"
  • (menu bar) Tools > Page Info > Security > "View Cookies"
  • click the padlock or "i" icon in the address bar, then the ">" button, then More Information, and finally the "View Cookies" button

In the dialog that opens, the current site should be pre-filled in the search box at the top of the dialog so you can remove that site's cookies individually.

Then try reloading the page. Does that help?


If no luck, could you test in Firefox's Safe Mode? In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the Shift key when starting Firefox.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

more options

Sorry for the late response, ISP decided to "upgrade" the internet lines. As for what you said, it did not help, I have also tried Not being logged into accounts, looking for settings in the OS, and any software on the network that could be causing and all my results turned up nothing

more options

hi, are you in a windows account with parental controls enabled? https://blog.mozilla.org/netpolicy/2014/07/22/prefersafe-making-online-safety-simpler-in-firefox/