Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

ImageBlock not working properly since 38 update

  • 8 replies
  • 1 has this problem
  • 69 views
  • Last reply by jscher2000

more options

ever since updating the the latest version of FireFox, the add-on ImageBlock does not work properly. It will block images sometimes and other times it wont. It was working fine before it updating and there hasn't been an update for the add-on either, so it seems like something FireFox broke.

Am considering downgrading to 37 because of this, blocking images is really needed since do not like seeing images while browse the web.

All Replies (8)

more options

Is it set to block images by default and only show them if you click its button, or the other way around?

I don't see any problem reviews so far on the extensions page (Image Block @ AMO), so I don't know whether this is affecting all Firefox 38.0/38.0.1 users or might be related to particular settings/extensions.

more options

By the way, the built-in setting to block images is as follows -- this is global:

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste perm and pause while the list is filtered

(3) Double-click the permissions.default.image preference and enter your preferred value:

  • 1 => Load ALL images
  • 2 => Block ALL images
  • 3 => Load same-origin ("first party") images only

Firefox has a mechanism to make site-specific exception using the Permissions panel of the Page Info dialog. You can display that using either:

  • right-click the page > View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address > More Information > Permissions

However, this is not convenient for a page-by-page or tab-by-tab unblocking, so if you need that, an add-on is still going to be the best tool.

more options

jscher2000

If you use this to block images, can you still reveal the image if you want?

more options

FredMcD said

jscher2000
If you use this to block images, can you still reveal the image if you want?

Can I reply "sort of"? If you set your default to Block All and then on a specific site you change the permission to Allow, the images hosted on that specific host name will be displayed. However, if the site uses a second host for images, which is not uncommon for larger sites, you would also need to unblock those servers, which could become very annoying. I have attached an image from Pinterest: right-clicking a missing image and Ctrl+clicking "View Image" shows the image in a new tab, and then you can modify the permission for whether images from that host are loaded in web pages.

more options

jscher2000 said

By the way, the built-in setting to block images is as follows -- this is global: (1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful. (2) In the search box above the list, type or paste perm and pause while the list is filtered (3) Double-click the permissions.default.image preference and enter your preferred value:
  • 1 => Load ALL images
  • 2 => Block ALL images
  • 3 => Load same-origin ("first party") images only
Firefox has a mechanism to make site-specific exception using the Permissions panel of the Page Info dialog. You can display that using either:
  • right-click the page > View Page Info > Permissions
  • (menu bar) Tools menu > Page Info > Permissions
  • click the padlock or globe icon to the left of the site address > More Information > Permissions
However, this is not convenient for a page-by-page or tab-by-tab unblocking, so if you need that, an add-on is still going to be the best tool.

using this in-browser method, it still doesn't work properly. images are still showing through. it seems to not matter what type of image it is, either, as all types are showing through and sometimes not all of them do (for example, one page was filled with .png images, some of them where blocked properly, while others weren't.)

so.... it seems like this is a problem with firefox, they broke something in 38.... was working properly in previous versions....

more options

Are there particular sites you can link to that behave strangely? I tested on my site:

Note: I do not use ImageBlock, so I don't know whether it could be causing the inconsistent results.

more options

jscher2000 said

Are there particular sites you can link to that behave strangely? I tested on my site: Note: I do not use ImageBlock, so I don't know whether it could be causing the inconsistent results.

I notice it is mostly wiki sites that are not working properly. (but not exclusive to those type of sites).

humblebundle.com, is an example, the images of the games' box art still show.

ImageBlock just got an update and so did some of my other add-ons (noscript, adblock), but it still didn't fix the issue.

Your sites work properly and I do not see any images.

(and, as far as I am aware, the ImageBlock add-on just toggles the inbrowser about:config method to 1/2 when clicked, so it seems like a general firefox issue, or certain sites getting past the browser's "defenses").

more options

Humble Bundle is a special case because the images are background images encoded as "data URIs" directly into the style sheet, and not pulled in separately as individual image files. (See attached screen shots from the Inspector and Page Info > Media.) I'm not sure why they do it that way, but since the encoded image is already in the HTML/CSS code, it's not blockable using the feature to turn off image retrievals.