Cerca nel supporto

Attenzione alle mail truffa. Mozilla non chiederà mai di chiamare o mandare messaggi a un numero di telefono o di inviare dati personali. Segnalare qualsiasi attività sospetta utilizzando l'opzione “Segnala abuso”.

Learn More

Firefox spellchecker won't work, dispite having the dictionary installed.

  • 5 risposte
  • 1 ha questo problema
  • 27 visualizzazioni
  • Ultima risposta di FredMcD

more options

Okay. I've got an issue with the spellchecker that seems to be a bug. I installed the dictionary, and made sure it was on. However it won't detect even things like gfhjrjdjd as being misspelled. It's really annoying. It doesn't seem to be able to detect text boxes - even this one. There is no option to enable it with right click.

Immagini allegate

Tutte le risposte (5)

more options

Type about:config<enter> in the address bar. If a warning screen comes up, press the I Accept the Risk button. At the top of the screen is a search bar.

Type: layout.spellcheckDefault Its values are; 0 Spell Checker Off 1 Check Only Multi-Line Input Boxes. 2 Check Multi And Single Line Input Boxes.

Also, check the spellchecker.dictionary entry.

https://support.mozilla.org/en-US/kb/how-do-i-use-firefox-spell-checker

È stato utile?

more options

I checked it. It's all true, and was set to one. I set it to two, and it still won't work in here. Same as before in every way. Thanks for your help so far!

Modificato da pjblackmoore il

È stato utile?

more options

Hi

It is possible that you confused dictionary with a language pack and that you actually do not have a dictionary installed.

You can look here for dictionaries, so make sure to look in the right column:

Note that for spell check you need a dictionary. A language pack provides string translations for the user interface.


You can see which dictionary is selected if you right-click in a text area and open the Languages sub menu. At least one dictionary should be installed and have a check mark to indicate that it is selected.

  • open the "Add Dictionaries" link to install a dictionary if you do not have one.

The spelling checker is enabled if [X] "Check Spelling" in the right-click context menu has a checkmark.

You can enable or disable spell checking globally:

You can check on the about:config page that layout.spellcheckDefault is set to 1 (multi-line) or 2 (single-line).

È stato utile?

more options

It is possible that you confused dictionary with a language pack and that you actually do not have a dictionary installed.

As you may see, I'm following up spell-checker problems following my own. I made this mistake of 'confusing' language packs with dictionary, but it's a fault of Firefox's menus and how they describe things. There are settings for language packs alongside check spelling. These everyone would assume are related. But the dictionaries are a separate entity to language packs hidden away in the Extensions which aren't included as part of the default options. See the 'puzzle piece' icon at the bottom of the options menu.

FF needs to address this. 'Dictionaries' need to be linked to from the Options next to the Check Spelling checkbox with a 'select dictionary' link.

È stato utile?

more options

If you want to leave feedback for Firefox developers, you can go to the Firefox Help menu and select Submit Feedback... or use this link. Your feedback gets collected by a team of people who read it and gather data about the most common issues.

You can also file a bug report or feature request for Firefox and other Mozilla products. See File a bug report or feature request for Mozilla products for details.

È stato utile?

Richiedi supporto

Bisogna accedere al proprio account per rispondere nelle discussioni. Se non si possiede ancora un account, inserire una nuova richiesta.