Hardware non più supportato

Informazioni sulla versione
  • ID versione: 141432
  • Data di creazione:
  • Autore: Underpass
  • Commento: qa miki
  • Revisionata:
  • Revisionata:
  • Revisionata da: underpass
  • Approvata?
  • Versione corrente?
  • Pronta per la localizzazione: No
Sorgente della versione
Contenuto della versione

Se il computer in uso ha un processore precedente al Pentium 4, non sarà possibile installare Firefox 49 e le versioni successive.

Se Firefox è già installato, sarà possibile continuare a utilizzarlo ma non si riceveranno aggiornamenti a partire dalla versione 48. Se si scarica e si prova a installare la versione 49 di Firefox o una versione successiva, si riceverà il messaggio "Non è possibile installare Firefox. Questa versione richiede un processore con supporto SSE2".

Al pari di molti programmi, Firefox richiederà un processore che supporta Streaming SIMD Extensions 2 (SSE2) per ottenere maggior sicurezza e migliori prestazioni. Mozilla raccomanda l'utilizzo di un computer dotato di processore Pentium 4 o più recente con supporto a SSE2 in modo da poter eseguire la versione più recente di Firefox, che presenta migliori caratteristiche in termini di stabilità e sicurezza.

La versione Extended Support Release (ESR) di Firefox continuerà a funzionare con i processori più vecchi ma non riceverà ulteriori aggiornamenti successivi alla versione 52. La versione 59 di Firefox ESR, di cui è prevista l'uscita in marzo 2018, non supporterà questo tipo di processori.

Se il computer in uso ha un processore precedente al Pentium 4, non sarà possibile installare Firefox 53 e le versioni successive.

Se Firefox è già installato, sarà possibile continuare a utilizzarlo ma non si riceveranno aggiornamenti a partire dalla versione 52. Se si scarica e si prova a installare la versione 53 di Firefox o una versione successiva, nello stderr (standard error, il canale preposto alla registrazione degli errori) comparirà il messaggio "This browser version requires a processor with the SSE2 instruction set extension. You may be able to obtain a version that does not require SSE2 from your Linux distribution" (tradotto: "Questa versione del browser richiede un processore con supporto SSE2. Potrebbe essere possibile installare una versione che non richiede SSE2 dalla distribuzione Linux in uso").

Al pari di molti programmi, Firefox richiederà un processore che supporta Streaming SIMD Extensions 2 (SSE2) per ottenere maggior sicurezza e migliori prestazioni. Mozilla raccomanda l'utilizzo di un computer dotato di processore Pentium 4 o più recente con supporto a SSE2 in modo da poter eseguire la versione più recente di Firefox, che presenta migliori caratteristiche in termini di stabilità e sicurezza.

La versione Extended Support Release (ESR) di Firefox continuerà a funzionare con i processori più vecchi ma non riceverà ulteriori aggiornamenti successivi alla versione 52. La versione 59 di Firefox ESR, di cui è prevista l'uscita in marzo 2018, non supporterà questo tipo di processori.

La versione di Firefox presente in alcune distribuzioni Linux potrebbe avere dei requisiti hardware di sistema diversi da quella scaricabile da Mozilla: in questo modo si potrebbero ottenere versioni aggiornate di Firefox che non richiedono SSE2 installandole dagli archivi dei pacchetti per la distribuzione Linux utilizzata.

Nota: per sapere quale versione di Firefox si sta utilizzando, leggere l'articolo Individuare la versione di Firefox utilizzata.