Pomoc přepytać

Hladajće so wobšudstwa pomocy. Njenamołwimy was ženje, telefonowe čisło zawołać, SMS pósłać abo wosobinske informacije přeradźić. Prošu zdźělće podhladnu aktiwitu z pomocu nastajenja „Znjewužiwanje zdźělić“.

Learn More

Is there any way to keep websites from automatically scrolling?

  • 8 wotmołwy
  • 1 ma tutón problem
  • 10 napohladow
  • Poslednja wotmołwa wot jscher2000

more options

Some websites automatically scroll up or down the page as they load. For example, https://addons.mozilla.org/ autoscrolls as I try to find tools to block autopain, uh, autoscroll.

I have sensory processing issues, and flashing and animation can be incredibly painful, can trigger migraines, and can very disorienting.

So it hurts.

I have disabled autoscrolling, of course. I suppose this could be another Javascript punch-the-users-feature.

I can't use Safe Mode or Refresh Firefox because I need a number of accessibility fixes to block animation, and these disable and destroy extensions and user scripts.

Wšě wotmołwy (8)

more options

If I know the page will scroll, wearing sunglasses and/or closing my eyes while clicking can help.

more options

In case of the Add-ons website there is extra 'promos' content loaded via a XHR request (XMLHttpRequest) as you can see in the Network Monitor when you only have XHR selected. This forces the other content to be moved down if that is what you are referring to.

As you probably know by now such content is loaded via JavaScript, so you can block this JavaScript or hide the containing element.

Add code to the userContent.css file or use Stylish.


@-moz-document domain(addons.mozilla.org){#promos{display:none!important}}

The customization files userChrome.css (user interface) and userContent.css (websites) are located in the chrome folder in the Firefox profile folder.

more options

I created a Stylish script with the above. This didn't solve my problem. The add-ons page still scrolls on its own.

Wot MarjaE změnjeny

more options

I added a namespace line, but it's still scrolling on its own.

more options

Do you still see this promo content about the games with the code or is this about some other content?

Can you attach a screenshot?

  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB

Note that for website content you need to use this @namespace line:


You can right-click and select "Inspect Element" to open the Inspector ("3-bar" menu button or Tools -> Web Developer) with this element selected to check what content this is about.

more options

Could you describe the steps that cause auto-scrolling. Break it down for me: first open what link, then what do I do next or what do I look for next?

more options

Right now, it animates with the second page.

If I search add-ons for "block animation," I get to https://addons.mozilla.org/en-US/firefox/search/?q=block%20animation&platform=Darwin&appver=47.0

First page currently loads without animation, but second page loads at the bottom of the page, then scrolls to the top.

I can't do screen shots of animation.

more options

Yes, a script in the page intercepts the click and does something strange. That page is full of scripts like this and I don't see an easy way to disable them. I suggest requesting a change or way to opt-out on the forum of the Add-ons site:

https://discourse.mozilla-community.org/c/add-ons/addons-mozilla-org

Meanwhile, the only obvious workaround is to drag and drop the button on the address bar. In that case, Firefox extracts the link from the button and load it as a new page instead of running the script.