Pretraži podršku

Izbjegni prevare podrške. Nikad te nećemo tražiti da nas nazoveš, da nam pošalješ telefonski broj ili da podijeliš osobne podatke. Prijavi sumnjive radnje pomoću opcije „Prijavi zlouporabu”.

Learn More

Location bar not respecting privacy suggestion setting

  • 1 odgovor
  • 10 ima ovaj problem
  • 37 prikaza
  • Posljednji odgovor od guigs

more options

I'm running into a strange issue where the location/awesome bar still autocompletes domain names for items in my bookmarks despite clearing all history and setting the privacy setting to only suggest history.

Initial settings: Privacy > Location Bar > When using the location bar, suggest: History

Steps to replicate: 1. Bookmark something, for example, a youtube video. 2. Clear History (Everything, all options) 3. Close firefox completely and re-open 4. Visit the bookmark and for good measure, click a few other links on the site 5. Repeat steps 2 and 3 6. If your bookmark was a youtube video, simply typing 'y' into the location bar should suggest/autocomplete the domain 'youtube.com'

I've tested this with multiple sites and multiple version of FF on different operating systems. The only way to remove these autocomplete entries is to delete places.sqlite.

I understand that I can change the Location Bar to suggest nothing in the Privacy settings, but I actually do want it to suggest history. I just want to disable what is causing the permanent, undeletable, error entries.

Svi odgovori (1)

more options

Reference http://kb.mozillazine.org/Location_Bar_search If you # In the Location bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear.

  1. Click I'll be careful, I promise!, to continue to the about:config page.
  2. search browser.urlbar.restrict.bookmark ? thought the default in the new version is "*"