Pretraži podršku

Izbjegni prevare podrške. Nikad te nećemo tražiti da nas nazoveš, da nam pošalješ telefonski broj ili da podijeliš osobne podatke. Prijavi sumnjive radnje pomoću opcije „Prijavi zlouporabu”.

Learn More

Artifacts with HW compositing enabled on Intel HD 4000

  • 5 odgovora
  • 2 imaju ovaj problem
  • 1 prikaz
  • Posljednji odgovor od Nelson

more options

Hi, I seem to have an issue with Firefox rendering pages with artifacts. I use Linux Mint 21.2 Cinnamon, video adapter is Intel HD 4000. Currently running 6.2 kernel, tried to fall back to 5.15 which didn't change anything. Attached the examples, the first 2 are screenshots of the about:support page, the issue appear there consistently but not necessarily at the same place. I've tried to open Firefox in the Troubleshooting mode, and the artifact appeared right in the dialog asking for restart! (see pic. 3) Enabling software WebRender (gfx.webrender.software=true) fixes the issue.

about:support page:

 when HW compositing is on: https://termbin.com/7ith
 when SW compositing is on: https://termbin.com/rlme

I have tested memory with memtest86+ overnight with no errors, CPU has been tested by Prime95 for 3-4 hours, the iGPU seems to be working fine either in Unigine Heaven, GpuTest and glmark tests. Is there a way to fix the issue other than disabling HW compositing?

Hi, I seem to have an issue with Firefox rendering pages with artifacts. I use Linux Mint 21.2 Cinnamon, video adapter is Intel HD 4000. Currently running 6.2 kernel, tried to fall back to 5.15 which didn't change anything. Attached the examples, the first 2 are screenshots of the about:support page, the issue appear there consistently but not necessarily at the same place. I've tried to open Firefox in the Troubleshooting mode, and the artifact appeared right in the dialog asking for restart! (see pic. 3) Enabling software WebRender (gfx.webrender.software=true) fixes the issue. about:support page: when HW compositing is on: https://termbin.com/7ith when SW compositing is on: https://termbin.com/rlme I have tested memory with memtest86+ overnight with no errors, CPU has been tested by Prime95 for 3-4 hours, the iGPU seems to be working fine either in Unigine Heaven, GpuTest and glmark tests. Is there a way to fix the issue other than disabling HW compositing?
Priložene slike ekrana

Izabrano rješenje

The Mesa version in Thunderbird could be different if you are using a flatpak or snap package.

You can try disabling various Intel optimizations:

INTEL_DEBUG=no8,no16,no32,no-oaconfig,nocompact,nodualobj,nofc,noccs firefox
Pročitaj ovaj odgovor u kontekstu 👍 0

Svi odgovori (5)

more options
Driver Vendor: mesa/crocus Driver Version: 23.0.4.0

Try newer Mesa versions (kisak and oibaf).

Use mozregression to test older versions of Firefox and see if it ever worked in the past and find when it stopped working.

Experiment with Mesa environment variables like INTEL_DEBUG.

more options

Thank you for the suggestions! I've tried mozregression with versions 85, 87, 88, 93, 95, 111, 119, 120 (all a1), all the versions behave the same way as currently installed 118.0.2. Also installed Mesa from kisak repo (Firefox was showing driver version 23.2.1.0) with no positive result. Will try Mesa from oibaf and use the Mesa variables (seems to be hard). Also, Thunderbird 115 displays it's troubleshooting page without any issues with HW compositing. Strange.

more options

Odabrano rješenje

The Mesa version in Thunderbird could be different if you are using a flatpak or snap package.

You can try disabling various Intel optimizations:

INTEL_DEBUG=no8,no16,no32,no-oaconfig,nocompact,nodualobj,nofc,noccs firefox
more options

No, Thunderbird had been installed from the same Ubuntu repo as FF, it uses the same Mesa driver version. First, I've tested FF on another system, a laptop, which happens to have Intel HD 4000 graphics, and the artifacts are present there, so it's not a problem with a particular computer. I've also tested FF under Ubuntu 22.04, it uses older i965 Mesa driver for the Intel HD 4000 GPU, and still FF shows the same artifacts. Also, no artifacts under Win8.1. Now tests with the INTEL_DEBUG flags. nofc seems to eliminate the issue absolutely most of the time, but I still saw the artifacts with the flag once. Without nofc it's a matter of seconds to see the artifacts: just scroll about:support a bit, then click Help->"Troubleshoot Mode...", and often the grey artifact will be there. What is also disturbing me is that now I started noticing artifacts in the main Cinnamon menu regularly, even with FF running with nofc. But it's not FF related. Also, seems like someone experienced somewhat similar issue with PrusaSlicer app and had already reported it to Mesa devs: https://github.com/prusa3d/PrusaSlicer/issues/10968 https://gitlab.freedesktop.org/mesa/mesa/-/issues/9392 So, thank you so much for your help! Seems like I have to wait until (and if) Mesa devs fix the bug.

more options

@butterpilz, i was having the same problem with artifacts in an Intel HD4000 (IVB GT2) using Firefox DEB with Mint 21.2 (Mesa 23.0.4) mostly in the Google search box when opening a private page and the about:support pages. Tried the Firefox Flatpak with newer Mesa (23.1.9) and the artifacts continued to appear. After reading your post, indeed using the Mesa INTEL_DEBUG=nofc fixes the problem, but i've found that setting the option gfx.webrender.scissored-cache-clears.enabled to false in about:config also fixes the problem without needing to use Mesa debug option. I'm still testing but found that this problem occurs only on IVB. Tested on an Intel HD2000 (SNB GT1) and the artifacts don't appear.

Izmjenjeno od Nelson