Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox no longers asks to save tabs on exit

  • 3 replies
  • 94 have this problem
  • 46 views
  • Last reply by John99

more options

When closing last session of Firefox it no longer asks if I want to save all tabs on exit.

The box under Tools -> Options -> Tabs -> Warn me when closing multiple tabs is checked

Firefox will warn me when I'm closing a session containing multiple tabs, however for the last session open it will not ask if I want to save all tabs on exit. During one of my shutdowns I accidentally checked the box "Don't ask this again" when I closed the last session. Now it only warns me of closing multiple tabs if it is not the last session.

I do not always want Firefox to open all the tabs from the very last session and can't seem to find a way to bring back the "ask to save all tabs on exit" again for the last session.

When closing last session of Firefox it no longer asks if I want to save all tabs on exit. The box under Tools -> Options -> Tabs -> Warn me when closing multiple tabs is checked Firefox will warn me when I'm closing a session containing multiple tabs, however for the last session open it will not ask if I want to save all tabs on exit. During one of my shutdowns I accidentally checked the box "Don't ask this again" when I closed the last session. Now it only warns me of closing multiple tabs if it is not the last session. I do not always want Firefox to open all the tabs from the very last session and can't seem to find a way to bring back the "ask to save all tabs on exit" again for the last session.

Chosen solution

Have you set:

  • Tools -> Options -> General [Tab] -> Startup "Use current pages"

Although it may not apply in your case also not some extensions may change or overide some settings, in which case check by using Diagnose Firefox issues using Troubleshoot Mode. It may also be worth looking in

Read this answer in context 👍 8

All Replies (3)

more options

Chosen Solution

Have you set:

  • Tools -> Options -> General [Tab] -> Startup "Use current pages"

Although it may not apply in your case also not some extensions may change or overide some settings, in which case check by using Diagnose Firefox issues using Troubleshoot Mode. It may also be worth looking in

more options

Fixed the problem right away under the "General Tab" described above. Just for fun, tried locating the identifiers in regedit without success but since the problem was fixed I didn't pursue it long.

more options

Glad the problem is fixed.

You mention regedit, be very careful if using that, the about:config option only really affects firefox, the worst problem if you make an editing mistake would be firefox not working.

If you use regedit you are making changes that affect the OS, ie the whole of how the computer works when using Windows. Editing with regedit could easily prevent you from booting the computer if you make serious mistakes.