Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Enable pop-ups

  • 2 replies
  • 1 has this problem
  • 21 views
  • Last reply by cor-el

more options

In Firefox 42, I have pop-up blocker activated. I have pop-up windows that I do not want blocked, but cannot determine a way to unblock them. When a pop-up is blocked, there isn't a message like there normally is giving me the opportunity to allow pop-ups for the site. I've also gone into Preferences and attempted to add a site manually to the pop-ups exception list, but pop-ups are still not allowed on the site that I've added.

All Replies (2)

more options

https://support.mozilla.org/en-US/kb/pop-blocker-settings-exceptions-troubleshooting#w_pop-up-blocker-settings Add an Exception for sites where you don't want popups blocked - IOW, Allowed Sites.

more options

Does Firefox show an icon at the right end of the location/address bar?

Does it work if you enable all pop-ups temporarily?

You can inspect and manage permissions for the domain in the currently selected tab via these steps:

  • click the "Site Identity Button" (globe/padlock) on the location/address bar
  • click the arrow to expand the security message
  • click "More Information" to open "Tools > Page Info"
  • click "Permissions" to inspect and modify permissions
  • click "Security" to inspect and modify cookies and passwords in a standalone window

You can inspect and manage some permissions (not plugins) on the about:permissions page.