Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Arrow keys not working like normal

more options

Twice in the past 2-3 weeks I have had to restart the computer, Linux Mint 21.2 Firefox 124(when updated in the past couple of days), due to the mouse freezing up and not being able to move the mouse on the screen. That's not the current problem, but it might help direct things to the final solution.

After the most recent reboot last night now I'm having a rather problem. The up/down arrow keys are no longer scroll me up and down a webpage like they always have in the past. Instead of doing smooth scrolling like they always use to, now they are scrolling me up and down the links on a web page. For example, if I were to be on youtube it would first want to scroll me down the left side links before taking me through each and every video link, when the page goes to load in more videos than it wants to go back and scroll me down the left side links again. It acts like it is taking me through the html code, line by line, instead of scrolling me smoothly down the webpage. The only way I can scroll smoothly down the webpage is to use the mouse on the scrollbar on the right side. It does this both in normal mode and in Troubleshooting Mode.

I have checked and beret scrolling is false as well as beret_shortcut. Use autoscrolling, use smooth scrolling, show scrollbars and always underline links are all clicked on. Always use the cursor keys to navigate within pages is unclicked. I have tried different changes between clicking on and unclicking those options with no change being noticed.

How can I get this back to the way it used to run?

Twice in the past 2-3 weeks I have had to restart the computer, Linux Mint 21.2 Firefox 124(when updated in the past couple of days), due to the mouse freezing up and not being able to move the mouse on the screen. That's not the current problem, but it might help direct things to the final solution. After the most recent reboot last night now I'm having a rather problem. The up/down arrow keys are no longer scroll me up and down a webpage like they always have in the past. Instead of doing smooth scrolling like they always use to, now they are scrolling me up and down the links on a web page. For example, if I were to be on youtube it would first want to scroll me down the left side links before taking me through each and every video link, when the page goes to load in more videos than it wants to go back and scroll me down the left side links again. It acts like it is taking me through the html code, line by line, instead of scrolling me smoothly down the webpage. The only way I can scroll smoothly down the webpage is to use the mouse on the scrollbar on the right side. It does this both in normal mode and in Troubleshooting Mode. I have checked and beret scrolling is false as well as beret_shortcut. Use autoscrolling, use smooth scrolling, show scrollbars and always underline links are all clicked on. Always use the cursor keys to navigate within pages is unclicked. I have tried different changes between clicking on and unclicking those options with no change being noticed. How can I get this back to the way it used to run?

Chosen solution

I think, maybe this has taken care of it. I'll see if lasts a while longer before I say yes. I knew I had played around with both(or are they both the same) caret and using cursor keys to navigate. That was this morning while trying to avoid asking this question, but I hadn't did anything with it last night when the problem started. Hence why I say I will give it while and spend a bit more time surfing before I say it has taken care of the problem. It's looking positive, right now.

Ler a resposta no contexto 👍 0

All Replies (11)

more options

What Desktop? X11 or Wayland?

I'm not having this issue with Firefox from Mozilla nor my distro.

Try downloading Firefox from Mozilla, run firefox-bin from the folder and see if you have the same issue. https://www.mozilla.org/en-US/firefox/all/#product-desktop-release


Operating System: openSUSE Tumbleweed 20240410 KDE Plasma Version: 6.0.3 KDE Frameworks Version: 6.0.0 Qt Version: 6.7.0 Kernel Version: 6.8.4-rc1-1-default (64-bit) Graphics Platform: X11 Processors: 16 × AMD Ryzen 7 5825U with Radeon Graphics Memory: 62.1 GiB of RAM Graphics Processor: AMD Radeon Graphics Manufacturer: HP Product Name: HP ProBook 455 15.6 inch G9 Notebook PC

Helpful?

more options

What application am I suppose to use to run the file. When I try to run it, it comes up and asks what application it should use.

After doing a bit of research, thanks for losing me completely, I'm on X11. New talk for me:)

Helpful?

more options

Download, unzip, and run firefox-bin from the folder. After double clicking on the firefox-bin, you may get a pop-up asking to execute. That's all I've seen and then it should run.

Helpful?

more options

nayrdrofwarc said

now they are scrolling me up and down the links on a web page.

Some sites have this behavior for arrow keys like DuckDuckGo. Youtube runs experiments that can result in different behavior for some users.

Does it still happen in a new profile? An easy way to test a new profile is to install Developer Edition and see if it happens there or refresh your existing profile. Make sure you stay signed out of your sync account when testing.

Helpful?

more options

john,

Very strange. I extracted the files, after being dumb first, and then it would run fine. At first it seemed like it was working the way it should. So I reopened the email and came onto the forum and started typing out a reply. When I went to scroll back up, it was back to not working correctly again. Briefly, only very briefly did it work fine after running firefox-bin.

Helpful?

more options

zeroknight,

It's doing this on all websites, even google. It will put a box around the link and it behaves like it is trying to take me through the html code on the website link by link when I go to move up/down the webpage using the arrow keys. It really acts like it is walking me through the html code, link by link.

Helpful?

more options

Is it the same as pressing the Tab key to step through focusable elements? Perhaps an accessibility feature of your distro? Try changing accessibility.force_disabled to 1 in about:config then restart the browser.

Does it still happen with the flatpak package?

Helpful?

more options

It appears to have solved the original problem but created a new one. Now the page up/down doesn't work on most sites until after I click somewhere on the site, hopefully not on a stupid ad. On one site each time I want to page up/down I have to click while on other sites I only have to do it initially. I did just stumble into one site where I could page up/down but not arrow key up/down. For the most part it has taken care of the arrow up/down but it isn't functioning like it always had until last night.

Helpful?

more options

I had updated to 124 a couple of days ago and it wasn't until last night I ran into any issues.

Helpful?

more options

You may have switched on caret browsing. You can toggle caret browsing off/on by pressing F7 (Mac: fn + F7).

  • Settings -> General -> Browsing
    remove checkmark: [ ] "Always use the cursor keys to navigate within pages"

Note that this is a Firefox accessibility feature.

Helpful?

more options

Chosen Solution

I think, maybe this has taken care of it. I'll see if lasts a while longer before I say yes. I knew I had played around with both(or are they both the same) caret and using cursor keys to navigate. That was this morning while trying to avoid asking this question, but I hadn't did anything with it last night when the problem started. Hence why I say I will give it while and spend a bit more time surfing before I say it has taken care of the problem. It's looking positive, right now.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.