Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot access my webcam when I visit representus.com.au. On this site there is Jitsi Meet. I click allow but I get message "Fails to access your camera, unkno

  • 5 replies
  • 1 has this problem
  • 33 views
  • Last reply by Denis

more options

I visit representus.com.au frequently. On this site they use Jitsi Meet. When I login it asks permission to access my webcam, I click allow and then I get the message "Fails to access your camera, cannot use camera for unknown reason. My webcam is a Logitech C920. I have updated the drivers. I have refreshed Firefox 69.0.1 and I have uninstalled Firefox and reinstalled it and this issue persists. The camera works fine on other websites using Firefox and also works fine using Chrome.


I would appreciate any help to rectify this issue

I visit representus.com.au frequently. On this site they use Jitsi Meet. When I login it asks permission to access my webcam, I click allow and then I get the message "Fails to access your camera, cannot use camera for unknown reason. My webcam is a Logitech C920. I have updated the drivers. I have refreshed Firefox 69.0.1 and I have uninstalled Firefox and reinstalled it and this issue persists. The camera works fine on other websites using Firefox and also works fine using Chrome. I would appreciate any help to rectify this issue
Attached screenshots

All Replies (5)

more options

First off here you must go to Windows 10 settings and turn on the WebCam settings to permit other applications or site to be permitted to access the webcam.

https://www.top-password.com/blog/enable-disable-camera-or-webcam-in-windows-10/

more options

Your System Details list shows a lot of extensions.

Did you try Firefox Safe Mode to check whether one of your extensions is causing this issue?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

Hi, thanks for the feedback. I have started Firefox in safe mode, but I still had the issue. Also, all the Windows 10 settings are as suggested in this post. I reset to the default theme, but still the issue persists.

If there are any other suggestion, they would be welcome. Thank you.

more options

There aren't any third-party domains involved or frames used on the page ?

You can also check "Tools -> Page Info -> Permissions".

more options

Hi, thanks for your support. I have attached the permissions and I think they are all okay.