Tutki ja korjaa Firefoxin ongelmia

Useimmat Firefoxin ongelmat voidaan ratkaista tässä artikkelissa kuvattujen ohjeiden avulla. Kokeile ratkaisuja järjestyksessä, alkaen ensimmäisestä ja jatka seuraavaan, kunnes ongelma korjaantuu. Jos näistä ohjeista ei ole apua, tai tarvitset apua näihin ohjeisiin, voit esittää kysymyksen yhteisön tukifoorumilla.

Huomaa: Katso sivulta Firefoxin suositut aiheet onko ongelmaasi jo valmis ratkaisu.

1. Käynnistä tietokoneesi uudelleen

Joskus ongelma ratkeaa yksinkertaisesti tietokoneen uudelleenkäynnistämisellä. Käynnistä sitten Firefox uudelleen.

2. Tyhjennä evästeet ja välimuisti

Useat verkkosivujen laatmiseen liittyvät ongelmat ratkeavat Firefoxin evästeiden ja välimuistin tyhjentämisellä:

  1. Napsauta Firefoxin ikkunan ylälaidassa Firefox-painiketta, mene Sivuhistoria-valikkoon ja valitse Poista historiatietoja....Napsauta valikkopalkissa Työkalut-valikkoa ja valitse Poista historiatietoja....Napsauta Firefox-ikkunan ylälaidan Työkalut-valikkoa ja valitse Poista historiatietoja....
  2. Valitse Poistettava aika:-pudotusvalikosta Kaikki.
  3. Paina nuolta Yksityiskohdat-sanan vieressä avataksesi tyhjennettävien kohteiden listan.
  4. Valitse Evästeet ja Väliaikaistiedot.
  5. Napsauta Poista tiedot.
  1. Napsauta Firefoxin ikkunan ylälaidassa Firefox-painiketta, mene Sivuhistoria-valikkoon ja valitse Poista historiatietoja....Napsauta valikkopalkissa Sivuhistoria-valikkoa ja valitse Poista historiatietoja....Napsauta Firefox-ikkunan ylälaidan Sivuhistoria-valikkoa ja valitse Poista historiatietoja....
  2. Valitse Poistettava aika:-pudotusvalikosta Kaikki.
  3. Paina nuolta Yksityiskohdat-sanan vieressä avataksesi tyhjennettävien kohteiden listan.
  4. Valitse Evästeet ja Väliaikaistiedot.
  5. Napsauta Poista tiedot.
  1. Napsauta valikkopainiketta New Fx Menu , valitse Sivuhistoria ja sitten Poista historiatietoja....
  2. Valitse Poistettava aika:-pudotusvalikosta Kaikki.
  3. Paina nuolta Yksityiskohdat-sanan vieressä avataksesi tyhjennettävien kohteiden listan.
  4. Valitse Evästeet ja Väliaikaistiedot.
  5. Napsauta Poista tiedot.
Lue lisätietoja artikkelista Poista selaus-, haku- ja lataushistoria.

3. Käynnistä Firefox uudelleen vikasietotilassa

Vikasietotila on Firefoxin ongelmien ratkaisuun tarkoitettu erikoistila, jossa muun muassa kaikkien laajennuksien käyttö ja laitteistokiihdytys on estetty ja jossa käytetään oletusteemaa ja työkalupalkkien oletusasetuksia. Käynnistä Firefox vikasietotilaan seuraavasti:

  1. Napsauta Firefox-ikkunan ylälaidan Firefox-painiketta, siirry Ohje-valikkoonAvaa valikkopalkin Ohje-valikkoAvaa Firefox-ikkunan ylälaidan Ohje-valikko ja valitse Käynnistä uudelleen ilman lisäosia.... Firefox käynnistyy vikasietotilassa.
    Huomaa: Firefox käynnistyy vikasietotilaan myös pitämällä Shift pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.pitämällä Option pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.suorittamalla Päätteessä komento: firefox -safe-mode
    Pääte saattaa kysyä myös asennussijaintia (esim. /usr/lib/firefox)
    Napsauta valikkopainiketta New Fx Menu , napsauta sitten ohjepainiketta Help-29 ja valitse Käynnistä uudelleen ilman lisäosia.... Firefox käynnistyy vikasietotilassa.
    Huomaa: Firefox käynnistyy vikasietotilaan myös pitämällä Shift pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.pitämällä Option pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.suorittamalla Päätteessä komento: firefox -safe-mode
    Pääte saattaa kysyä myös asennussijaintia (esim. /usr/lib/firefox)

  1. Tarkista, jatkuuko ongelma vikasietotilassa.

4. Tarkista liitännäiset

Toisinaan Firefoxin liitännäiset (esimerkiksi Adobe Reader, Flash, Java, QuickTime, RealPlayer ja Windows Media Player) voivat aiheuttaa ongelmia, jotka on ratkaistu liitännäisen uusimmassa versiossa. Tarkista ja päivitä käytössä olevat liitännäiset sivulla Liitännäisten tarkistus ja päivitys. Jos jokin liitännäisistäsi on vanhentunut, napsauta sen kohdalla olevaa Päivitä-painiketta ja seuraa ohjeita. Kun olet päivittänyt kaikki liitännäiset, käynnistä Firefox uudelleen:

Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

. Käynnistä Firefox uudelleen. Jos ongelma ei korjaantunut, voit kokeilla aiheuttaako jokin liitännäinen ongelman estämällä niiden käynnistymisen:

  1. Valitse Firefox-ikkunan ylälaidasta Firefox-painikeValitse valikkopalkista TyökalutValitse Firefoxin valikkopalkista Työkalut, ja napsauta sitten valikkoa Lisäosat. Lisäosien hallinta -välilehti aukeaa.

    Napsauta valikkopainiketta New Fx Menu ja valitse Lisäosat. Lisäosien hallinta -välilehti avautuu.

  2. Valitse Lisäosien hallinta -välilehdellä Liitännäiset -paneeli.
  3. Napsauta luettelosta liitännäistä ja napsauta sitten painiketta Poista käytöstä. Toista tämä kaikille liitännäisille.
  4. Tarkista jatkuuko ongelma, kun liitännäiset on poistettu käytöstä.
  1. Valitse Firefox-ikkunan ylälaidasta Firefox-painikeValitse valikkopalkista TyökalutValitse Firefoxin valikkopalkista Työkalut, ja napsauta sitten valikkoa Lisäosat. Lisäosien hallinta -välilehti aukeaa.

    Napsauta valikkopainiketta New Fx Menu ja valitse Lisäosat. Lisäosien hallinta -välilehti avautuu.

  2. Valitse Lisäosien hallinta -välilehdellä Liitännäiset -paneeli.
  3. Napsauta luettelosta liitännäistä ja valitse sen alasvetovalikosta vaihtoehto Älä käynnistä koskaan. Toista tämä kaikille liitännäisille.
  4. Tarkista jatkuuko ongelma, kun liitännäiset on poistettu käytöstä.

Jos ongelma poistui liitännäisten käynnistymisen estämisen jälkeen, katso artikkelista Korjaa liitännäisistä johtuvia yleisiä Firefox-ongelmia lisäohjeita, joiden avulla voit selvittää, mikä liitännäisistä mahdollisesti aiheutti ongelman.

5. Asenna Firefox uudelleen

Jotkin ongelmat saattavat johtua Firefoxin ohjelmatiedostoista. Poista Firefoxin asennus kokonaan ja asenna se uudelleen seuraavien ohjeiden avulla.

Huomaa: Nämä ohjeet kannattaa tulostaa tai avata toisella selaimella.
  1. Lataa Firefoxin uusin versio osoitteesta mozilla.org.
  2. Sulje Firefox:

    Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

    Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

  3. Poista Firefoxin asennuskansio, joka on oletusarvoisesti jokin seuraavista:
    • (32-bittinen Windows) C:\Ohjelmatiedostot\Mozilla Firefox
    • (64-bittinen Windows) C:\Ohjelmatiedostot (x86)\Mozilla Firefox
  4. Asenna Firefox uudelleen - katso ohjeet artikkelista Firefoxin asentaminen Windowsille.
  1. Lataa Firefoxin uusin versio osoitteesta mozilla.org.
  2. Sulje Firefox:

    Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

    Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

  3. Poista Firefoxin asennus avaamalla Finderissa Ohjelmat-kansio ja raahaamalla Firefox Roskakoriin.
  4. Asenna Firefox uudelleen - katso ohjeet artikkelista Firefoxin asentaminen Macille.
  1. Lataa Firefoxin uusin versio osoitteesta mozilla.org.
  2. Sulje Firefox:

    Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

    Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

  3. Poista Firefoxin asennus - Jos Firefox on asennettu pakkauksenhallintaohjelmalla, tulee se myös poistaa sillä. Lisätietoja saat artikkelista Firefoxin asentaminen Linuxille. Jos Firefox on ladattu ja asennettu Firefoxin lataussivulta, voit poistaa asennuksen poistamalla kansion firefox kotihakemistostasi.
  4. Asenna Firefox uudelleen - katso ohjeet artikkelista Firefoxin asentaminen Linuxille.

Käynnistä Firefox uudelleen ja kokeile, poistuiko ongelma. Jos ongelmaa ei enää esiinny, voit asentaa uudelleen lisäosat ja teemat, jotka eivät aiheuttaneet ongelmaa (kohdassa 3). Jos ongelma ei korjaantunut, jatka seuraavaan kohtaan.

6. Nollaa Firefox

Firefoxin nollaaminen saattaa ratkaista useita ongelmia palauttamalla Firefoxin sen oletusasetuksiin, ilman tärkeiden tietojesi katoamista.

Huomaa: Kun käytät nollaustoimintoa, kirjanmerkkisi, selaushistoriasi, avoimet välilehtesi, ikkunasi, salasanasi, evästeesi ja lomakkeiden automaattisen täytön tiedot tallennetaan. Laajennuksesi ja teemasi poistetaan ja asetuksiin tekemäsi muutokset palautetaan oletusasetuksiin.Kun käytät nollaustoimintoa, kirjanmerkkisi, selaushistoriasi, salasanasi, evästeesi ja lomakkeiden automaattisen täytön tiedot tallennetaan. Laajennuksesi ja teemasi poistetaan, eikä avoimia välilehtiä, ikkunoita ja välilehtiryhmiä tallenneta. Lisäksi asetuksiin tekemäsi muutokset palautetaan oletusasetuksiin. Katso lisätietoja artikkelista Firefoxin nollaaminen – korjaa helposti monet ongelmat
n varalta. Tässä on muutamia hyödyllisiä haittaohjelmien poistotyökaluja:

  1. Napsauta Firefox-ikkunan yläosassa Ohje-valikkoa ja valitse Tietoja ongelmatilanteisiin.Napsauta Firefox-ikkunan yläosassa Firefox-painiketta, siirry Ohje-alavalikkoon ja valitse Tietoja ongelmatilanteisiin.Napsauta valikkopalkissa Ohje-valikkoa ja valitse Tietoja ongelmatilanteisiin.
    Reset Firefox 1 - WinXP Troubleshooting info - win Troubleshooting info - mac Troubleshooting info - lin
    Jos et pysty käyttämään Ohje-valikkoa, avaa Tietoja ongelmatilanteiden ratkaisuun -sivu kirjoittamalla osoitepalkkiin about:support ja painamalla Enter.
  2. Napsauta Nollaa Firefox-painiketta Tietoja ongelmatilanteiden ratkaisuun -sivun oikeassa yläkulmassa.
    Reset Firefox 2 - WinXP Reset Firefox - Win - 1 Reset Firefox - Mac - 1 Reset Firefox - Lin - 1
  3. Vahvista nollaaminen napsauttamalla Nollaa Firefox-painiketta avautuvassa varmistusikkunassa.Vahvista nollaaminen napsauttamalla Nollaa Firefox-painiketta alas liukuvassa varmistuskehotteessa.
  4. Firefox sulkeutuu ja nollataan. Kun nollaus on suoritettu, ikkunassa luetellaan tiedot, jotka on tuotu. Napsauta painiketta Valmis ja Firefox aukeaa.Firefox sulkeutuu ja nollataan. Kun nollaus on suoritettu, ikkunassa luetellaan tiedot, jotka on tuotu. Napsauta painiketta Valmis ja Firefox aukeaa.
  1. Napsauta ensin valikkopainiketta New Fx Menu ja sitten Ohje-painiketta Help-29 .
  2. Valitse Ohje-valikosta Tietoja ongelmatilanteisiin.
    Jos et pysty käyttämään Ohje-valikkoa, avaa Tietoja ongelmatilanteiden ratkaisuun -sivu kirjoittamalla osoitepalkkiin about:support ja painamalla Enter.
  3. Napsauta Nollaa Firefox…-painiketta Tietoja ongelmatilanteiden ratkaisuun -sivun oikeassa yläkulmassa.
    Reset 29 Win Reset 29 Mac Reset 29 Lin
  4. Vahvista nollaaminen napsauttamalla Nollaa Firefox-painiketta avautuvassa varmistusikkunassa.
  5. Firefox sulkeutuu ja nollataan. Kun nollaus on suoritettu, ikkunassa luetellaan tiedot, jotka on tuotu. Napsauta painiketta Valmis ja Firefox aukeaa.

1. Käynnistä tietokoneesi uudelleen

Joskus ongelma ratkeaa yksinkertaisesti tietokoneen uudelleenkäynnistämisellä. Käynnistä sitten Firefox uudelleen.

2. Tyhjennä evästeet ja välimuisti

Useat verkkosivujen laatmiseen liittyvät ongelmat ratkeavat Firefoxin evästeiden ja välimuistin tyhjentämisellä:

  1. Napsauta Firefoxin ikkunan ylälaidassa Firefox-painiketta, mene Sivuhistoria-valikkoon ja valitse Poista historiatietoja....Napsauta valikkopalkissa Työkalut-valikkoa ja valitse Poista historiatietoja....Napsauta Firefox-ikkunan ylälaidan Työkalut-valikkoa ja valitse Poista historiatietoja....
  2. Valitse Poistettava aika:-pudotusvalikosta Kaikki.
  3. Paina nuolta Yksityiskohdat-sanan vieressä avataksesi tyhjennettävien kohteiden listan.
  4. Valitse Evästeet ja Väliaikaistiedot.
  5. Napsauta Poista tiedot.
  1. Napsauta Firefoxin ikkunan ylälaidassa Firefox-painiketta, mene Sivuhistoria-valikkoon ja valitse Poista historiatietoja....Napsauta valikkopalkissa Sivuhistoria-valikkoa ja valitse Poista historiatietoja....Napsauta Firefox-ikkunan ylälaidan Sivuhistoria-valikkoa ja valitse Poista historiatietoja....
  2. Valitse Poistettava aika:-pudotusvalikosta Kaikki.
  3. Paina nuolta Yksityiskohdat-sanan vieressä avataksesi tyhjennettävien kohteiden listan.
  4. Valitse Evästeet ja Väliaikaistiedot.
  5. Napsauta Poista tiedot.
  1. Napsauta valikkopainiketta New Fx Menu , valitse Sivuhistoria ja sitten Poista historiatietoja....
  2. Valitse Poistettava aika:-pudotusvalikosta Kaikki.
  3. Paina nuolta Yksityiskohdat-sanan vieressä avataksesi tyhjennettävien kohteiden listan.
  4. Valitse Evästeet ja Väliaikaistiedot.
  5. Napsauta Poista tiedot.
Lue lisätietoja artikkelista Poista selaus-, haku- ja lataushistoria.

3. Käynnistä Firefox uudelleen vikasietotilassa

Vikasietotila on Firefoxin ongelmien ratkaisuun tarkoitettu erikoistila, jossa muun muassa kaikkien laajennuksien käyttö ja laitteistokiihdytys on estetty ja jossa käytetään oletusteemaa ja työkalupalkkien oletusasetuksia. Käynnistä Firefox vikasietotilaan seuraavasti:

  1. Napsauta Firefox-ikkunan ylälaidan Firefox-painiketta, siirry Ohje-valikkoonAvaa valikkopalkin Ohje-valikkoAvaa Firefox-ikkunan ylälaidan Ohje-valikko ja valitse Käynnistä uudelleen ilman lisäosia.... Firefox käynnistyy vikasietotilassa.
    Huomaa: Firefox käynnistyy vikasietotilaan myös pitämällä Shift pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.pitämällä Option pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.suorittamalla Päätteessä komento: firefox -safe-mode
    Pääte saattaa kysyä myös asennussijaintia (esim. /usr/lib/firefox)
    Napsauta valikkopainiketta New Fx Menu , napsauta sitten ohjepainiketta Help-29 ja valitse Käynnistä uudelleen ilman lisäosia.... Firefox käynnistyy vikasietotilassa.
    Huomaa: Firefox käynnistyy vikasietotilaan myös pitämällä Shift pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.pitämällä Option pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.suorittamalla Päätteessä komento: firefox -safe-mode
    Pääte saattaa kysyä myös asennussijaintia (esim. /usr/lib/firefox)

  1. Tarkista, jatkuuko ongelma vikasietotilassa.

4. Tarkista liitännäiset

Toisinaan Firefoxin liitännäiset (esimerkiksi Adobe Reader, Flash, Java, QuickTime, RealPlayer ja Windows Media Player) voivat aiheuttaa ongelmia, jotka on ratkaistu liitännäisen uusimmassa versiossa. Tarkista ja päivitä käytössä olevat liitännäiset sivulla Liitännäisten tarkistus ja päivitys. Jos jokin liitännäisistäsi on vanhentunut, napsauta sen kohdalla olevaa Päivitä-painiketta ja seuraa ohjeita. Kun olet päivittänyt kaikki liitännäiset, käynnistä Firefox uudelleen:

Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

. Käynnistä Firefox uudelleen. Jos ongelma ei korjaantunut, voit kokeilla aiheuttaako jokin liitännäinen ongelman estämällä niiden käynnistymisen:

  1. Valitse Firefox-ikkunan ylälaidasta Firefox-painikeValitse valikkopalkista TyökalutValitse Firefoxin valikkopalkista Työkalut, ja napsauta sitten valikkoa Lisäosat. Lisäosien hallinta -välilehti aukeaa.

    Napsauta valikkopainiketta New Fx Menu ja valitse Lisäosat. Lisäosien hallinta -välilehti avautuu.

  2. Valitse Lisäosien hallinta -välilehdellä Liitännäiset -paneeli.
  3. Napsauta luettelosta liitännäistä ja napsauta sitten painiketta Poista käytöstä. Toista tämä kaikille liitännäisille.
  4. Tarkista jatkuuko ongelma, kun liitännäiset on poistettu käytöstä.

Jos ongelma poistui liitännäisten käynnistymisen estämisen jälkeen, katso artikkelista Korjaa liitännäisistä johtuvia yleisiä Firefox-ongelmia lisäohjeita, joiden avulla voit selvittää, mikä liitännäisistä mahdollisesti aiheutti ongelman.

5. Nollaa Firefoxin asetukset

Jotkin ongelmat voidaan ratkaista nollaamalla Firefoxin asetukset:

  1. Napsauta Firefox-ikkunan ylälaidan Firefox-painiketta, siirry Ohje-valikkoonAvaa valikkopalkin Ohje-valikkoAvaa Firefox-ikkunan ylälaidan Ohje-valikko ja valitse Käynnistä uudelleen ilman lisäosia.... Firefox käynnistyy vikasietotilassa.
    Huomaa: Firefox käynnistyy vikasietotilaan myös pitämällä Shift pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.pitämällä Option pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.suorittamalla Päätteessä komento: firefox -safe-mode
    Pääte saattaa kysyä myös asennussijaintia (esim. /usr/lib/firefox)
    Napsauta valikkopainiketta New Fx Menu , napsauta sitten ohjepainiketta Help-29 ja valitse Käynnistä uudelleen ilman lisäosia.... Firefox käynnistyy vikasietotilassa.
    Huomaa: Firefox käynnistyy vikasietotilaan myös pitämällä Shift pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.pitämällä Option pohjassa Firefoxin käynnistyskuvaketta napsautettaessa.suorittamalla Päätteessä komento: firefox -safe-mode
    Pääte saattaa kysyä myös asennussijaintia (esim. /usr/lib/firefox)
  2. Valitse Firefox Vikasietotila-ikkunassa vaihtoehto Palauta kaikki asetukset Firefoxin oletusarvoihin.
  3. Tallenna muutokset napsauttamalla Toteuta muutokset ja käynnistä uudelleen-painiketta.

6. Asenna Firefox uudelleen

Jotkin ongelmat saattavat johtua Firefoxin ohjelmatiedostoista. Poista Firefoxin asennus kokonaan ja asenna se uudelleen seuraavien ohjeiden avulla.

Huomaa: Nämä ohjeet kannattaa tulostaa tai avata toisella selaimella.
  1. Lataa Firefoxin uusin versio osoitteesta mozilla.org.
  2. Sulje Firefox:

    Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

    Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

  3. Poista Firefoxin asennuskansio, joka on oletusarvoisesti jokin seuraavista:
    • (32-bittinen Windows) C:\Ohjelmatiedostot\Mozilla Firefox
    • (64-bittinen Windows) C:\Ohjelmatiedostot (x86)\Mozilla Firefox
  4. Asenna Firefox uudelleen - katso ohjeet artikkelista Firefoxin asentaminen Windowsille.
  1. Lataa Firefoxin uusin versio osoitteesta mozilla.org.
  2. Sulje Firefox:

    Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

    Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

  3. Poista Firefoxin asennus avaamalla Finderissa Ohjelmat-kansio ja raahaamalla Firefox Roskakoriin.
  4. Asenna Firefox uudelleen - katso ohjeet artikkelista Firefoxin asentaminen Macille.
  1. Lataa Firefoxin uusin versio osoitteesta mozilla.org.
  2. Sulje Firefox:

    Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

    Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

  3. Poista Firefoxin asennus - Jos Firefox on asennettu pakkauksenhallintaohjelmalla, tulee se myös poistaa sillä. Lisätietoja saat artikkelista Firefoxin asentaminen Linuxille. Jos Firefox on ladattu ja asennettu Firefoxin lataussivulta, voit poistaa asennuksen poistamalla kansion firefox kotihakemistostasi.
  4. Asenna Firefox uudelleen - katso ohjeet artikkelista Firefoxin asentaminen Linuxille.

Käynnistä Firefox uudelleen ja kokeile, poistuiko ongelma. Jos ongelmaa ei enää esiinny, voit asentaa uudelleen lisäosat ja teemat, jotka eivät aiheuttaneet ongelmaa (kohdassa 3). Jos ongelma ei korjaantunut, jatka seuraavaan kohtaan.

7. Tee uusi profiili

Virheellinen profiili saattaa aiheutta monenlaisia ongelmia Firefoxissa. Tarkista aiheuttaako profiilisi ongelmia luomalla uusi profiili. Jos uuden profiilin luominen ratkaisee ongelman, voit kopioida tietosi (kirjanmerkit, tallennetut salasanat jne.) uuteen profiiliin.

  1. Käynnistä Profiilien hallinta -työkalu seuraamalla artikkelin Luo ja poista Firefoxin profiileja profiilien hallinnalla ohjeita ja luo uusi profiili.
    Kun luot uuden profiilin , älä poista vanhaa profiilia. Jos poistat vanhan profiilin, menetät kaikki kirjanmerkkisi, historiatietosi, salasanasi ja asetuksesi.
  2. Kun olet luonut uuden profiilin, valitse se Profiilien hallinnassa ja napsauta Käynnistä Firefox.

Kokeile, jatkuuko ongelma myös uudella profiililla. Jos ongelma on poistunut, voit kopioida henkilökohtaiset tietosi uuteen profiiliin. Katso lisätietoja artikkelista Tärkeiden tietojen palauttaminen vanhasta profiilista.

Muita ratkaisuja

Jos olet kokeillut kaikkia näitä vaiheita, eikä ongelma ole poistunut, voi vika olla muissa ohjelmissa tai laitteistossa.

Tämä osio ei sisällä vaiheittaisia ohjeita. Lisätietoja näistä ratkaisuista saat niiden yhteydessä kerrotusta dokumentaatiosta.

Tarkista mahdolliset ristiriidat tietoturvaohjelmistosi kanssa

Jotkin tietoturvaohjelmat (esimerkiksi virustorjunta-, vakoiluntorjunta- ja palomuuriohjelmat) voivat aiheuttaa ongelmia Firefoxille esimerkiksi estämällä sitä avaamasta verkkosivuja tai kaatamalla sen. Usein tällaisen ohjelman asetuksista voidaan poistaa Firefox luotettujen tai sallittujen ohjelmien listalta. Kun ohjelma seuraavan kerran havaitsee Firefoxin, pitäisi kaiken toimia jälleen. Jos ohjelmasi on luetteloitu artikkelissa Configure firewalls so that Firefox can access the Internet voit seuraamalla artikkelin ohjeita säätää ohjelmasi asetukset.

Tarkista järjestelmäsi virusten ja vakoiluohjelmien varalta

Järjestelmä tulisi säännöllisesti tarkistaa virusten, vakoiluohjelmien tai muiden haittaohjelmien varalta. Alla on muutamia hyödyllisiä työkaluja:

Jos tarvitset enemmän apua haittaohjelmien poistamiseen, katso artikkelia Haittaohjelmien aiheuttamien Firefox-ongelmien ongelmanratkaisu.

Tarkista kovalevy ja RAM-muisti virheiden varalta

Ongelmat tietokoneesi kovalevyn tai RAM-muistin kanssa saattavat estää Firefoxia käynnistymästä tai kaataa sen toistuvasti. Tässä muutamia työkaluja tai ohjeita kovalevyn ja muistin tarkistamiseen:



Perustuu mozillaZinen informaatioon Standard diagnostic - Firefox (mozillaZine KB)



Jaa tämä artikkeli: http://mzl.la/NYkV1X

Oliko tästä artikkelista apua? Odota hetki...

Nämä mahtavat henkilöt auttoivat kirjoittamaan tämän artikkelin: joukku, jjuslin. Sinäkin voit auttaa - lue lisää.