Korjaa liitännäisistä johtuvia yleisiä Firefox-ongelmia

Jotkin Firefoxin ongelmista aiheutuvat liitännäisistä (esimerkiksi Flash tai Java). Tässä artikkelissa kerrotaan kuinka selvität, onko jokin liitännäisistä syynä ongelmaan ja annetaan ohjeet ongelman ratkaisemiseksi.

Liitännäisten aiheuttamia yleisiä ongelmia ovat esimerkiksi:

Tässä artikkelissa kuvataan liitännäisten ongelmanratkaisu. Jos sinulla on ongelmia laajennusten tai teemojen kanssa, katso ohjeita artikkelista Korjaa laajennuksista, teemoista ja laitteistokiihdytyksestä johtuvia yleisiä Firefox-ongelmia. Yleistä tietoa liitännäisistä saat artikkelista Käytä liitännäisiä pelaamiseen, äänen ja videon toistamiseen ja muuhun.

Selvitä, aiheuttaako liitännäinen ongelman

Voit poistaa liitännäisiä käytöstä Firefoxin ollessa käynnissä. Jos epäilet jonkin tietyn liitännäisen aiheuttavan ongelman, poista se ensin käytöstä ja tarkista, jatkuuko ongelma. Jos et tiedä tai ole varma, mikä liitännäinen pitäisi poistaa käytöstä, seuraa näitä ohjeita:

  1. Valitse Firefox-ikkunan ylälaidasta Firefox-painikeValitse valikkopalkista TyökalutValitse Firefoxin valikkopalkista Työkalut, ja napsauta sitten valikkoa Lisäosat. Lisäosien hallinta -välilehti aukeaa.

    Napsauta valikkopainiketta New Fx Menu ja valitse Lisäosat. Lisäosien hallinta -välilehti avautuu.

  2. Valitse Lisäosien hallinta -välilehdellä Liitännäiset -paneeli.Valitse Lisäosien hallinta -välilehdellä Liitännäiset -paneeli.
  3. Valitse liitännäinen luettelosta ja napsauta sen Poista käytöstä-painiketta. Toista tämä luettelon jokaiselle liitännäiselle, kunnes ne on kaikki poistettu käytöstä. Liitännäisten käytöstä poistaminen ei edellytä Firefoxin uudelleen käynnistystä.
  4. Testaa, jatkuuko ongelma. Jos ongelma on poistunut, siirry takaisin Lisäosien hallintaan ja ota liitännäiset käyttöön yksi kerrallaan napsauttamalla Ota käyttöön-painiketta, kunnes löydät liitännäisen, joka aiheuttaa ongelman.
  1. Valitse Firefox-ikkunan ylälaidasta Firefox-painikeValitse valikkopalkista TyökalutValitse Firefoxin valikkopalkista Työkalut, ja napsauta sitten valikkoa Lisäosat. Lisäosien hallinta -välilehti aukeaa.

    Napsauta valikkopainiketta New Fx Menu ja valitse Lisäosat. Lisäosien hallinta -välilehti avautuu.

  2. Valitse Lisäosien hallinta -välilehdellä Liitännäiset -paneeli.Valitse Lisäosien hallinta -välilehdellä Liitännäiset -paneeli.
  3. Valitse liitännäinen luettelosta ja valitse sen alasvetovalikosta vaihtoehto Älä käynnistä koskaan. Toista tämä luettelon jokaiselle liitännäiselle, kunnes ne on kaikki poistettu käytöstä. Liitännäisten käytöstä poistaminen ei edellytä Firefoxin uudelleen käynnistystä.
  4. Testaa, jatkuuko ongelma. Jos ongelma on poistunut, siirry takaisin Lisäosien hallintaan ja ota liitännäiset käyttöön yksi kerrallaan valitsemalla niiden alasvetovalikoista vaihtoehto Käynnistä aina, kunnes löydät liitännäisen, joka aiheuttaa ongelman.

Jos löysit liitännäisen, joka aiheuttaa ongelman, jatka seuraamalla tämän artikkelin ohjeita.

Liitännäisen päivittäminen tai uudelleen asentaminen

Monet liitännäisestä johtuvat ongelmat voidaan ratkaista päivittämällä liitännäinen sen uusimpaan versioon. Voit tarkistaa, ovatko asennetut liitännäiset ajan tasalla Mozillan liitännäisten tarkistus- ja päivityssivulla.

Jos liitännäisen päivittäminen tai uudelleenasennus ei ratkaise ongelmaa, voit antaa sen olla poissa käytöstä.

Liitännäisen asennuksen poistaminen käsin

Jos et voi käyttää liitännäisen poisto-ohjelmaa, voit poistaa sen käsin:

  1. Kirjoita osoitepalkkiin about:config ja paina Enteriä.

    • About:config-sivun varoitus "Tämä sivu on ladattu ja vaarallinen!" voi avautua. Napsauta Lupaan olla varovainen ja varsinainen about:config-sivu aukeaa.
  2. Etsi asetus: plugin.expose_full_path.
  3. Kaksoisnapsauta luettelossa asetusta plugin.expose_full_path , jolloin sen arvoksi tulee true.
  4. Kirjoita osoitepalkkiin about:plugins ja paina EnterReturn jolloin Tietoja liitännäisistä -sivu aukeaa.
  5. Jokaisen liitännäisen kohdalla on lueteltu sen tiedostonimi ("Tiedosto") ja tiedoston sijainti ("Polku"). Siirry Windows Resurssienhallinnan avullaSiirry sen liitännäisen kansioon ("Polku"), jonka haluat poistaa.
  6. Nimeä liitännäinen ("Tiedosto") uudelleen lisäämällä sen tiedostonimen eteen X-kirjain (esimerkiksi tiedostosta npswf32 tulee Xnpswf32).
  7. Siirry välilehteen about:config ja muuta asetuksen plugin.expose_full_path arvo takaisin arvoon false kaksoisnapsauttamalla sitä luettelossa. Tämä varmistaa, että liitännäise3n polkua ei kerrota verkkosivuille.

Liitännäinen on nyt poistettu.

Jos et voi käyttää liitännäisen poisto-ohjelmaa, voit poistaa sen käsin:

  1. Kirjoita osoitepalkkiin about:plugins ja paina EnterReturn jolloin Tietoja liitännäisistä -sivu aukeaa.
  2. Jokaisen liitännäisen kohdalla on lueteltu sen tiedostonimi ("Tiedosto") ja liitännäisen nimi. Etsi Firefoxin profiilikansiosta tiedosto pluginreg.dat ja tarkastele sen sisältöä jollain tekstieditorilla. Tiedostossa luetellaan jokaisen liitännäisen sijainti. Siirry Windows Resurssienhallinnan avullaSiirry sen liitännäisen kansioon ("Polku"), jonka haluat poistaa.
  3. Nimeä liitännäinen ("Tiedosto") uudelleen lisäämällä sen tiedostonimen eteen X-kirjain (esimerkiksi tiedostosta npswf32 tulee Xnpswf32).

Liitännäinen on nyt poistettu.

Jos et voi käyttää liitännäisen poisto-ohjelmaa, voit poistaa sen käsin:

  1. Kirjoita osoitepalkkiin about:plugins ja paina EnterReturn jolloin Tietoja liitännäisistä -sivu aukeaa.
  2. Jokaisen liitännäisen kohdalla on lueteltu sen tiedostonimi ("Tiedosto") ja tiedoston sijainti ("Polku"). Siirry Windows Resurssienhallinnan avullaSiirry sen liitännäisen kansioon ("Polku"), jonka haluat poistaa.
  3. Nimeä liitännäinen ("Tiedosto") uudelleen lisäämällä sen tiedostonimen eteen X-kirjain (esimerkiksi tiedostosta npswf32 tulee Xnpswf32).

Liitännäinen on nyt poistettu.

Liitännäisten tietokannan uudelleenalustaminen

Saattaa olla, että et pysty joko asentamaan tai uudelleenasentamaan jotain liitännäistä. Liitännäisten tietokannan uudelleenalustaminen saattaa ratkaista ongelman:

  1. Avaa profiilikansiosi:

    Napsauta Firefox-ikkunan ylälaidan Firefox -painiketta ja mene Ohje-valikkoonNapsauta valikkopalkissa Ohje-valikkoaNapsauta Firefox-ikkunan ylälaidassa Ohje-valikkoa ja valitse Tietoja ongelmatilanteisiin. Tietoja ongelmatilanteiden ratkaisuun -välilehti avautuu. Napsauta valikkopainiketta New Fx Menu , napsauta sitten ohjekuvaketta Help-29 ja valitse Tietoja ongelmatilanteisiin. Tietoja ongelmatilanteiden ratkaisuun -välilehti avautuu.

  2. Napsauta Ohjelman perustiedot -osiossa Avaa kansioAvaa FinderissaAvaa kansio. Profiilitiedostosikansiosi sisältävä ikkuna avautuu.
  3. Huomaa: Ellet pysty avaamaan tai käyttämään Firefoxia, seuraa näitä ohjeita.

  4. Paina Firefox-ikkunan ylälaidasta Firefox-painiketta ja napsauta LopetaValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse LopetaValitse valikkopalkista Firefox-valikko ja napsauta Lopeta FirefoxValitse Firefox-ikkunan ylälaidasta Tiedosto-valikko ja valitse Lopeta

    Napsauta valikkopainiketta New Fx Menu ja napsauta sitten LopetaLopeta Close 29

  5. Poista tiedosto pluginreg.dat.
  6. Käynnistä Firefox
  7. Kirjoita osoitepalkkiin about:plugins ja paina EnterReturn, jolloin Tietoja liitännäisistä -sivu aukeaa.



Jaa tämä artikkeli: http://mzl.la/NYtGci

Oliko tästä artikkelista apua? Odota hetki...

Nämä mahtavat henkilöt auttoivat kirjoittamaan tämän artikkelin: jjuslin. Sinäkin voit auttaa - lue lisää.