Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox crashes with certain websites in Ubuntu

  • 3 replies
  • 9 have this problem
  • 4220 views
  • Last reply by reves

more options

I have not used my PC for three weeks and today I tried to log in to my Amazon account, but every time I tried to do the login it crashes, I also found it to crash in other websites like Reddit and the AMD Support Site. It is Firefox 58.0.1 64-bit in Ubuntu 16.04. I tried refreshing firefox and nothing, it also removed all extensions leaving only the default plug-ins: OpenH264 Video Codec provided by Cisco Systems, Inc & Shockwave Flash. If I disable them manually the websites will still crash. The only way Firefox will work normally is if I restart it in Safe Mode. I also tried installed the new 59 64-bit Beta version, but is causing the same problems.

The latest submitted crash reports are:

bp-5f7cae12-c429-4dd7-b794-8e4cf0180210 bp-8b31fc05-ede6-4d6c-8cd9-10efc0180210 bp-dd409298-45fb-43bb-8fa5-a02d00180210

Thanks for your help!

Modified by reves

Chosen solution

Hi there, I did try to disable the hardware acceleration without success. Later I found here that by disabling WebGL FF 58 would stop crashing.

So I disable it by setting webgl.disabled to true and that fixed the problem, for now. My PC has version 17.40 installed, I know there is a newer (17.50) version but as in the post said, it does not fix the problem. I hope AMD releases new AMD GPU Pro drivers.

Read this answer in context 👍 2

All Replies (3)

more options

I downgraded to version 57.0.4 (64-bit) and seems to work again, as a temporary solution.

more options

That are problems with the AMD display driver (amdgpu_dri.so).

You can try to disable hardware acceleration in Firefox.

Close and restart Firefox after modifying the setting to make the change effective.

You can check if there is an update for your graphics display driver and check for hardware acceleration related issues.

more options

Chosen Solution

Hi there, I did try to disable the hardware acceleration without success. Later I found here that by disabling WebGL FF 58 would stop crashing.

So I disable it by setting webgl.disabled to true and that fixed the problem, for now. My PC has version 17.40 installed, I know there is a newer (17.50) version but as in the post said, it does not fix the problem. I hope AMD releases new AMD GPU Pro drivers.