Resolver problemas con plugins como Flash o Java para solucionar incidencias comunes de Firefox

Si tienes problemas con páginas que usan plugins (como Flash, Java, etc...) para mostrar contenido, puede que necesites comprobar si un plugin es el causante del problema.

Entre los problemas más comunes que pueden ocasionar los plugins se incluyen:

Este artículo describe cómo solucionar problemas con los plugins. Si tienes un problema con una extensión o con un tema, puedes ver Resolución de incidencias relacionadas con extensiones, temas y aceleración de hardware para solucionar problemas comunes de Firefox. Para más información sobre los plugins, puedes ver Usar plugins para reproducir audio, video, juegos y mucho más.

Determinar si un plugin es la causa del problema

Puedes deshabilitar plugins de forma selectiva mientras Firefox se está ejecutando. Si sospechas de un determinado plugin, deshabilítalo primero, e intenta reproducir el problema. Si no sabes qué plugin deshabilitar:

  1. En la parte superior de la ventana de Firefox, haz clic en el botón FirefoxEn la barra de menú, haz clic en HerramientasEn la parte superior de la ventana de Firefox, haz clic en el Herramientas y selecciona Complementos. Se abrirá la pestaña del Administrador de Complementos.Haz clic en el botón Menú New Fx Menu y elige Complementos. Se abrirá la pestaña del Administrador de Complementos.

  2. En la pestaña del Administrador de complementos, selecciona el panel Plugins.En la pestaña del Administrador de complementos, selecciona el panel Plugins.
  3. Selecciona el plugin de la lista y haz clic sobre su botón de Desactivar. Repite este paso por cada uno de los plugins de la lista hasta que todos estén desactivados. No es necesario que reinicies Firefox para que los cambios tengan efecto.
  4. Haz pruebas para ver si el problema se repite. Si esto no ocurre, vuelve al administrador de complementos y vuelve a habilitar los plugins uno a uno con su botón de Activar hasta que encuentres cuál es plugin causante del problema.
  1. En la parte superior de la ventana de Firefox, haz clic en el botón FirefoxEn la barra de menú, haz clic en HerramientasEn la parte superior de la ventana de Firefox, haz clic en el Herramientas y selecciona Complementos. Se abrirá la pestaña del Administrador de Complementos.Haz clic en el botón Menú New Fx Menu y elige Complementos. Se abrirá la pestaña del Administrador de Complementos.

  2. En la pestaña del Administrador de complementos, selecciona el panel Plugins.En la pestaña del Administrador de complementos, selecciona el panel Plugins.
  3. Selecciona el plugin de la lista y haz clic sobre su botón de No activar nunca. Repite este paso por cada uno de los plugins de la lista hasta que todos estén desactivados. No es necesario que reinicies Firefox para que los cambios tengan efecto.
  4. Haz pruebas para ver si el problema se repite. Si esto no ocurre, vuelve al administrador de complementos y vuelve a habilitar los plugins uno a uno con su botón de Activar siempre en el menú desplegable hasta que encuentres cuál es plugin causante del problema.

Si al deshabilitar un plugin se soluciona el problema, sigue los pasos que se indican en este artículo.

Actualizar o reinstalar tus plugins

Muchos de los problemas con los plugins pueden resolverse actualizando a la ultima versión del plugin. Para comprobar si tus plugins instalados están desactualizados, visita la página de comprobación y actualizaciones de plugins de Mozilla.

Si actualizar a la nueva versión del plugin o reinstalarlo por completo no soluciona el problema, puedes dejarlo deshabilitado.

Desinstalar manualmente un plugin

Si no puedes usar un programa de desinstalación para eliminar un plugin, puedes eliminarlo manualmente:

  1. En la barra de direcciones, escribe about:config y pulsa IntroRetorno.

    • El aviso de about:config "¡Zona hostil para manazas!" o "¡Esto puede cancelar su garantía!" puede aparecer. Haz clic en ¡Tendré cuidado, lo prometo! o ¡Seré cuidadoso, lo prometo!, para continuar.
  2. Busca la preferencia: plugin.expose_full_path.
  3. Haz doble clic sobre la preferencia en la lista plugin.expose_full_path para cambiar el valor a true.
  4. Escribe about:plugins en la barra de direcciones y presiona EnterReturn para que aparezca la página "Acerca de los plugins".
  5. Cada una de las entradas en la página Acerca de los plugins tendrá una entrada "File name:" seguida por una ruta. Usa el Explorador de Windows para dirigirte Navegar a la carpeta mostrada por en la información del plugin que quieres eliminar.
  6. Renombra el archivo añadiendo una X al principio del nombre de ese archivo (Por ejemplo, cambia npswf32 por Xnpswf32).
  7. Haz doble clic en la preferencia plugin.expose_full_path en la lista de la página about:config para volver a cambiar el valor a false para evitar exponer la ruta del plugin a los sitios web.

El plugin será eliminado.

Si no puedes usar un programa de desinstalación para eliminar un plugin, puedes eliminarlo manualmente:

  1. Escribe about:plugins en la barra de direcciones para que aparezca la página "Acerca de los plugins".
  2. Cada una de las entradas que aparecen en la página "Acerca de los plugins" tendrá el Nombre del archivo: seguido del nombre del plugin.

Tendrás que buscar en los contenidos del archivo pluginreg.dat de tu carpeta de perfil de Firefox para encontrar dónde se encuentra cada plugin. Puedes abrir el archivo "pluginreg.dat" con un procesador de textos para ver su contenido. Utiliza Windows Explorer para navegar Navegar por la carpeta que mostrará el plugin que quieres eliminar.

  1. Renombra el archivo añadiendo una X al principio del nombre de ese archivo (Por ejemplo, cambia npswf32 por Xnpswf32).

Se eliminará el plugin.

Si no puedes usar un programa de desinstalación para eliminar un plugin, puedes eliminarlo manualmente:

  1. Escribe about:plugins en la barra de direcciones y presiona la tecla EnterReturn para que aparezca la página "Acerca de los plugins".
  2. Cada una de las entradas que aparecen en la página "Acerca de los plugins" tendrá el Nombre del archivo: seguido del nombre del plugin.

Se eliminará el plugin.

Reinicializar la base de datos de plugins

En algunos casos, puede que no puedas instalar o reinstalar un plugin. Reinicializar la base de datos de plugins puede que solucione este problema:

  1. Abre tu carpeta de perfil de usuario:

    En la parte superior de la ventana de Firefox, haz clic en el botón Firefox, desplázate hasta el menú AyudaEn la barra de menús, haz clic en el menú AyudaEn la parte superior de la ventana de Firefox, haz clic en el menú Ayuda y selecciona Información para solucionar problemas. Se abrirá la ventana de Información para solucionar problemas.

  2. Debajo de Configuración básica de la aplicación, haz clic en el botón Mostrar carpetaMostrar en FinderAbrir directorio. Se abrirá la ventana con los archivosla carpeta de tu perfil.
  3. Nota: Si te resulta imposible abrir o utilizar Firefox, sigue las instrucciones que se muestran en Buscar tu perfil sin necesidad de abrir Firefox.

  4. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, elige el menú Archivo y selecciona SalirEn la barra de menú, selecciona Firefox y a continuación Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón Menú New Fx Menu y a continuación en SalirQuitar Close 29

  5. Borrar el archivo pluginreg.dat.
  6. Abre Firefox.
  7. En la barra de dirección teclea about:plugins y presiona la tecla EnterReturn para que aparezca la lista de plugins instalados en Firefox.



Comparte este artículo: http://mzl.la/NYtGci

¿Te resultó útil este artículo? Espera por favor...

Esta gente maravillosa ayudó a escribir este artículo: willyaranda, Breaking_Pitt, inma_610, avelper. Tú también puedes ayudar, descubre cómo hacerlo.