Marcadores y botones de las barras de herramientas no funcionan después de actualizar

Este artículo ya no se actualiza, por lo que su contenido puede estar obsoleto.

Firefox almacena tus marcadores y el historial de navegación en una base de datos llamada (places.sqlite), que se encuentra ubicada en la carpeta Perfiles. Si esta base de datos se encuentra dañada o si Firefox no puede acceder al archivo por cualquier otro motivo, muchas de las funciones de Firefox no se ejecutarán correctamente. Entre los síntomas que indican que Firefox no está funcionando correctamente pueden encontrarse la desaparición de los marcadores, que estos mismos no se guarden correctamente, que el historial de navegación no se guarde correctamente y que los botones "Ir a la página anterior" o "Ir a la página siguiente" no funcionen. Si estás sufriendo alguno de estos problemas, prueba las soluciones que se muestran a continuación.


Salir de otros programas.

Puede que una sesión anterior de Firefox no se cerrase correctamente o que otro programa intente acceder a la base de datos places.sqlite de Firefox, bloqueando dicho archivo. Sal de Firefox y de cualquier otro programa que sospeches que pueda interferir durante su navegación por la red (o reinicia tu equipo) y vuelve a ejecutar Firefox.

Salir por completo de Firefox.

  1. Haz clic en el menú Archivo en Firefox y selecciona Salir.
  2. Haz clic con el botón derecho del ratón en un lugar vacío de la barra de herramientas de Windows y selecciona Administrador de tareas (o presiona Ctrl+Shift+Esc).

    notron360sucks-taksmanager.png

  3. Selecciona la pestaña de Procesos.
  4. Selecciona la entrada firefox.exe en la lista de procesos, y haz clic en el botón Finalizar proceso y posteriormente en el botón en el cuadro de dialogo "Alerta administrador de Tareas" que Windows te muestra. (Si no existe una entrada "firefox.exe" en la lista de procesos, puedes omitir este paso.)

    TaskMgrWarning.PNG

    En caso de que encuentres múltiples entradas en la lista de procesos, repite este paso por cada proceso "firefox.exe" listado.
  5. Inicia Firefox normalmente.
Nota: La solución anterior te permitirá ejecutar Firefox para que funcione correctamente si has tenido problemas con el cierre de la sesión anterior, hasta que encuentres una solución mejor a tu problema.

Comprobar extensiones incompatibles

  1. En la parte superior de la ventana de Firefox, haz clic en el menú Herramientas y selecciona Complementos/Agregados. Aparecerá la ventana de Complementos/Agregados.
  2. En la ventana de Complementos/Agregados, selecciona el panel Extensiones para ver las extensiones instaladas.
  3. Busca estas extensiones, que se conocen que son problemáticas:
    • Freecorder
    • Piclens
    • Skype extension
    • Any toolbar extension basada en la plataforma Conduit toolbar
    • Google Toolbar
    • FoxyTunes
  1. Deshabilita cada extensión que tengas instalada de la lista mostrada anteriormente.
    1. Haz clic en el nombre de la extensión que quieres deshabilitar.
    2. Para deshabilitar la extensión, haz clic sobre el botón Deshabilitar.
    3. Repite estos pasos por cada extensión que tengas de las extensiones que se muestran en el punto 3.
  2. Después de que hayas deshabilitado las extensiones, sal de Firefox completamente y cierra todos los procesos firefox.exe, como se explica más arriba en este documento.
  3. Inicia Firefox normalmente.
  4. Cierra Firefox otra vez; haz clic en el menú Archivo y seleccione {PATH()}Salir{PATH()}.
  5. Inicia Firefox otra vez para ver si se ha resuelto el problema.

Para obtener más información sobre la resolución de problemas con las extensiones, mira Resolución de incidencias relacionadas con extensiones, temas y aceleración de hardware para solucionar problemas comunes de Firefox.

Si tienes Norton 360 instalado.

Un componente que se instala con el software Norton 360 puede provocar problemas con los marcadores y con el historial de navegación después de instalar o actualizar a Firefox 3. Puede que Firefox no se cierre completamente cuando este componente de Norton 360 está habilitado. Si experimentas estos problemas, actualiza primero Norton 360, para ver si esto resuelve el problema:

Actualizar Norton 360

Symantec ha lanzado recientemente un parche para Norton 360 que debería solucionar este problema para algunos usuarios. Actualiza Norton 360 siguiendo los pasos que se indican a continuación:

  1. Inicia Norton 360
  2. Haz clic en Tareas & Configuración o Tareas.
  3. Haz clic en Buscar actualizaciones.
  4. Haz clic en Cerrar cuando LiveUpdate finalice de instalar las actualizaciones.
  5. Ejecuta de nuevo LiveUpdate hasta que veas el mensaje que indica que no hay más descargas disponibles.
  6. Puede que necesites reiniciar tu equipo para completar determinadas actualizaciones.

Si los marcadores, el historial de navegación y los botones de la barra de tareas están funcionando correctamente, ya has terminado. Si todavía estás experimentando problemas comprobar y desactualizar extensiones incompatibles (mira más arriba).

Como alternativa, puedes desactivar la proteción Anti-Phising en la configuración de Norton y reiniciar el equipo

Otra opción es seguir las instrucciones que se muestran a continuación para eliminar manualmente el componente de Norton 360 de Firefox.

Eliminar el componente de Norton 360 de Firefox.

Si deshabilitar las extensiones no ha funcionado o si necesita utilizar extensiones que no son compatibles con Norton 360, necesitarás eliminar el componente que Norton 360 ha añadido a Firefox.

  1. Sal de Firefox completamente y cierra cualquier proceso de firefox.exe, como se explica más arriba.
  2. Abre Mi PC o el Explorador de Windows.
  3. Ve a la carpeta C:\Archivos de programa\Mozilla Firefox\Components.
  4. Borra (o renombra) el archivo coFFPlgn.dll que se encuentra en esta carpeta.
    • Si el archivo no se borra, puede que se deba a que no has terminado todos los procesos de "firefox.exe".
  1. Ejecuta Firefox y verifique que los marcadores y las barras de herramientas funcionan correctamente.
    • Observa que Norton en determinadas ocasiones puede reemplazar este archivo cuando renicies tu equipo, por lo que puede ser necesario repetir este paso cada vez que renicies el equipo. Otra opción es deshabilitar la protección Anti-phising en las opciones de configuración de Norton, como se mencionó anteriormente.

Si estos pasos no solucionan el problema, intenta segurr los procedimientos que se indican en el artículo Evita que Norton 360 elimine marcadores de Firefox.


La base de datos de ubicaciones

También puedes solucionar este problema forzando a Firefox a que reconstruya la base de datos de ubicaciones, tal y como se muestra a continuación:

  1. (Opcional) Exporta sus marcadores a un archivo HTML llamado bookmarks.html (mira Exportar marcadores de Firefox a un archivo HTML para transferir o hacer una copia de tus marcadores para instrucciones detalladas) y guárdalo en bookmarks.html en la carpeta Perfiles. Si ya existe un archivo llamado bookmarks.html, reemplázalo por el nuevo archivo que ha creado.
  2. En la parte superior de la ventana de Firefox, haz clic en el botón Firefox y selecciona SalirEn la parte superior de la ventana de Firefox, elige el menú Archivo y selecciona SalirEn la barra de menú, selecciona Firefox y a continuación Salir de FirefoxEn la parte superior de la ventana de Firefox, haz clic en el menú Archivo y selecciona Salir.

    Haz clic en el botón Menú New Fx Menu y a continuación en SalirQuitar Close 29

  3. Abre la carpeta Profiles de Firefox y borra (o renombra) el archivo places.sqlite, y si existe, borra también el archivo places.sqlite-journal.
  4. (Opcional) Si quieres que Firefox importe automáticamente tus marcadores desde un archivo bookmarks.html existente en la carpeta Perfiles, en vez de un backup de un archivo JSON, abre la carpeta bookmarkbackups y elimina todo el contenido o mueve los archivos bookmarks-(date).json a otra ubicación.
  5. Probablemente también sea una buena idea borrar (o renombrar) el archivo localstore.rdf para eliminar las referencias a la base de datos de ubicaciones antigua toolbar customizations.

Firefox creará un nuevo archivo places.sqlite y automáticamente importará la copia de seguridad más reciente de tus marcadores. Si no hay una copia de seguridad de los marcadores en formato JSON, Firefox automáticamente importará tus marcadores desde el archivo bookmarks.html, si existe, que se encuentra en la carpeta Perfiles.

Esta gente maravillosa ayudó a escribir este artículo: willyaranda. Tú también puedes ayudar, descubre cómo hacerlo.