Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

smooth scrolling is not working as it should work?

  • 9 replies
  • 26 have this problem
  • Last reply by cor-el

more options

Smooth scrolling is not working as it should, it's very clumsy and irregular with track pad while it is little bit good with mouse.

i am using Asus with Intel HD 3000 and Nvidia GEforce.

Smooth scrolling is not working as it should, it's very clumsy and irregular with track pad while it is little bit good with mouse. i am using Asus with Intel HD 3000 and Nvidia GEforce.

All Replies (9)

more options


Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back to us!

Thank you.

more options


I did this but doesn't solve my problem. still irregular.

more options

The "more system details" link in this question shows User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/31.0.1650.63 Safari/537.36 with no other information.

To help us help find the correct solution to your problem, we need some information about your Firefox version, extensions, preferences, and other details, which you can furnish by opening Firefox and following these steps:

  1. Click the Firefox button at the top left, then go over to the Help submenu and click on Troubleshooting Information. A new tab containing your troubleshooting information should open.
  2. At the top of the Troubleshooting Information page, click the button that says "Copy text to clipboard".
  3. Now, go back to your forum post and click inside the reply box. Press Ctrl+V to paste all the information you copied into the forum post.

Thanks in advance. See the article Use the Troubleshooting Information page to help fix Firefox issues for details about the contents of the Troubleshooting Information page.

more options

Ok i am pasting here as per description

Application Basics

Name: Firefox
Version: 25.0.1
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0


Name: Adblock Plus
Version: 2.4
Enabled: true
ID: {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

Name: iReader
Version: 1.0.7
Enabled: true

Name: YouTube Video and Audio Downloader
Version: 0.3.2
Enabled: true
ID: feca4b87-3be4-43da-a1b1-137c24220968@jetpack

Name: Youtube Video and Mp3 Downloader (Stable)
Version: 2.3
Enabled: true
ID: {09e4684b-dcac-4608-8b7d-58bef11fc323}

Name: Yet Another Smooth Scrolling
Version: 3.1.7
Enabled: false
ID: yetanothersmoothscrolling@kataho

Important Modified Preferences

accessibility.typeaheadfind.flashBar: 0
browser.cache.disk.capacity: 358400
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.disk.smart_size_cached_value: 358400
browser.display.use_document_fonts: 0
browser.places.smartBookmarksVersion: 4
browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
browser.startup.homepage_override.buildID: 20131112160018
browser.startup.homepage_override.mstone: 25.0.1
dom.mozApps.used: true
extensions.lastAppVersion: 25.0.1
font.default.x-western: sans-serif
font.internaluseonly.changed: false Arial Lucida Grande
gfx.color_management.display_profile: C:\Windows\System32\spool\drivers\color
gfx.color_management.enablev4: true
gfx.color_management.mode: 1
gfx.direct3d.last_used_feature_level_idx: 0
network.cookie.prefsMigrated: true
places.database.lastMaintenance: 1386411029
places.history.expiration.transient_current_max_pages: 104858
plugin.disable_full_page_plugin_for_types: application/pdf
plugin.importedState: true 0
print.printer_doPDF_v7.print_bgcolor: false
print.printer_doPDF_v7.print_bgimages: false
print.printer_doPDF_v7.print_downloadfonts: false
print.printer_doPDF_v7.print_duplex: 0
print.printer_doPDF_v7.print_edge_bottom: 0
print.printer_doPDF_v7.print_edge_left: 0
print.printer_doPDF_v7.print_edge_right: 0
print.printer_doPDF_v7.print_edge_top: 0
print.printer_doPDF_v7.print_evenpages: true
print.printer_doPDF_v7.print_footerleft: &PT
print.printer_doPDF_v7.print_footerright: &D
print.printer_doPDF_v7.print_headerleft: &T
print.printer_doPDF_v7.print_headerright: &U
print.printer_doPDF_v7.print_in_color: true
print.printer_doPDF_v7.print_margin_bottom: 0.5
print.printer_doPDF_v7.print_margin_left: 0.5
print.printer_doPDF_v7.print_margin_right: 0.5
print.printer_doPDF_v7.print_margin_top: 0.5
print.printer_doPDF_v7.print_oddpages: true
print.printer_doPDF_v7.print_orientation: 0
print.printer_doPDF_v7.print_page_delay: 50
print.printer_doPDF_v7.print_paper_data: 1
print.printer_doPDF_v7.print_paper_height: 11.00
print.printer_doPDF_v7.print_paper_size_type: 0
print.printer_doPDF_v7.print_paper_size_unit: 0
print.printer_doPDF_v7.print_paper_width: 8.50
print.printer_doPDF_v7.print_resolution: 0
print.printer_doPDF_v7.print_reversed: false
print.printer_doPDF_v7.print_scaling: 1.00
print.printer_doPDF_v7.print_shrink_to_fit: true
print.printer_doPDF_v7.print_to_file: false
print.printer_doPDF_v7.print_unwriteable_margin_bottom: 0
print.printer_doPDF_v7.print_unwriteable_margin_left: 0
print.printer_doPDF_v7.print_unwriteable_margin_right: 0
print.printer_doPDF_v7.print_unwriteable_margin_top: 0
privacy.sanitize.migrateFx3Prefs: true
storage.vacuum.last.index: 1
storage.vacuum.last.places.sqlite: 1385308014


Adapter Description: Intel(R) HD Graphics 3000
Adapter Description (GPU #2): NVIDIA GeForce 610M
Adapter Drivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
Adapter Drivers (GPU #2): nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Adapter RAM: Unknown
Adapter RAM (GPU #2): 2048
ClearType Parameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
Device ID: 0x0116
Device ID (GPU #2): 0x1058
Direct2D Enabled: true
DirectWrite Enabled: true (6.2.9200.16571)
Driver Date: 2-14-2012
Driver Date (GPU #2): 11-11-2013
Driver Version:
Driver Version (GPU #2):
GPU #2 Active: false
GPU Accelerated Windows: 1/1 Direct3D 10
Vendor ID: 0x8086
Vendor ID (GPU #2): 0x10de
WebGL Renderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 3000 Direct3D9Ex vs_3_0 ps_3_0)
windowLayerManagerRemote: false
AzureCanvasBackend: direct2d
AzureContentBackend: direct2d
AzureFallbackCanvasBackend: cairo
AzureSkiaAccelerated: 0


Incremental GC: true


Activated: false
Prevent Accessibility: 0

Library Versions

Expected minimum version: 4.10.2
Version in use: 4.10.2

Expected minimum version: 3.15.3 Basic ECC
Version in use: 3.15.3 Basic ECC

Expected minimum version: 3.15.3 Basic ECC
Version in use: 3.15.3 Basic ECC

Expected minimum version: 3.15.3 Basic ECC
Version in use: 3.15.3 Basic ECC

Expected minimum version: 3.15.3
Version in use: 3.15.3

Modified by cor-el

more options

In your list of extensions, I see:

Name: Yet Another Smooth Scrolling 
Version: 3.1.7 
Enabled: false 
ID: yetanothersmoothscrolling@kataho 

You have this extension disabled, did you realize that? If you want to re-enable it, go to the Firefox Add-ons Extensions list. If you turned it off because you had problems with it, you'll have to contact the developer. The extension page at

Your Firefox "smooth scrolling" setting is located in the Options window - Advanced panel under the General Tab. This preference is already turned on , by default.

Here is what the Advanced panel - Accessibility, browsing, network, updates, and other advanced settings in Firefox article says about smooth scrolling:

Use smooth scrolling: Smooth scrolling can be very useful if you read a lot of long pages. Normally, when you press Page Down, the view jumps directly down one page. With smooth scrolling, it slides down smoothly, so you can see how much it scrolls. This makes it easier to resume reading from where you were before.
more options

smooth scrolling extension was solution someone told here to solve problem so installed but it didn't work out properly. so i disable it.

and i think setting is default as usual of my FF.

more options

I earlier version of FF it was working fine but in this version it's not working. and i saw different post a lot of people have same problem like me.

more options

It might help if you could describer the scrolling problem better and include links to webpages, if possible, where you see the problem the worst. I found these bugs you can look through, to see if any are similar to your issue.

Bug 802478 - Smooth scrolling causes plugins to bounce while scrolling

Bug 850562 - Regression in smooth scrolling between Firefox 19 and 20 (This bug causes a 'rippling' effect to the text, also described as a 'tearing' effect where the top and bottom parts of the page seem to be out of sync)

I also found Bug 878189 - HWA & Smooth Scrolling causes page flickers while scrolling (Note: Disabling hardware acceleration stops the flicker in this bug; so does turning OFF smooth scrolling)

more options

Try to increase the value of the general.smoothScroll.mouseWheel.durationMaxMS pref on the about:config page a higher value like 1000 to see if that makes a difference with smooth scrolling enabled.