X
Tap here to go to the mobile version of the site.

Support Forum

Firefox crashes

Posted

Hello, please help me with my crash. Any assistance will be greatly appreciated as this is happening to me 3 to 4 times a week.

When I have multiple youtube videos open 8 to 12 windows some do not load (no play button appears and it is blank), When I refresh the window sometimes the play button appears. Then when I try to play a video it freezes and I hear audio but no video plays and when video does play it is very jumpy, like it is pausing every second, then the system crashes. I tried turning OFF hardware acceleration but it still does it and crashes.

I checked for software updates from apple (driver updates, upper left apple logo check for updates) and all my plug-ins are up to date. I only have Default browser helper, sharepoint browser plugin, Quicktime, Shockwave flash and shockwave flash for director

Here is what the crash report generated: libsystem_platform.dylib@0x53a7

Here is the ID of my crash: bp-9c650a67-184b-4d83-9635-02c812131205 Signature libsystem_platform.dylib@0x53a7 More Reports Search UUID 9c650a67-184b-4d83-9635-02c812131205 Date Processed 2013-12-05 17:48:02.679272 Uptime 78043 Last Crash 78048 seconds before submission Install Age 1721889 since version was first installed. Install Time 2013-11-15 19:29:43 Product Firefox Version 25.0.1 Build ID 20131112160018 Release Channel release OS Mac OS X OS Version 10.9.0 13A603 Build Architecture x86 Build Architecture Info family 6 model 42 stepping 7 | 4 Crash Reason EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE Crash Address 0x0 User Comments App Notes

AdapterVendorID: 0x1002, AdapterDeviceID: 0x6740WebGL? GL Context? GL Context+ WebGL+

Processor Notes sp-processor07_phx1_mozilla_com.5051:2012; HybridCrashProcessor EMCheckCompatibility

True

Winsock LSP

Adapter Vendor ID

0x1002

Adapter Device ID

0x6740

Hello, please help me with my crash. Any assistance will be greatly appreciated as this is happening to me 3 to 4 times a week. When I have multiple youtube videos open 8 to 12 windows some do not load (no play button appears and it is blank), When I refresh the window sometimes the play button appears. Then when I try to play a video it freezes and I hear audio but no video plays and when video does play it is very jumpy, like it is pausing every second, then the system crashes. I tried turning OFF hardware acceleration but it still does it and crashes. I checked for software updates from apple (driver updates, upper left apple logo check for updates) and all my plug-ins are up to date. I only have Default browser helper, sharepoint browser plugin, Quicktime, Shockwave flash and shockwave flash for director Here is what the crash report generated: libsystem_platform.dylib@0x53a7 Here is the ID of my crash: bp-9c650a67-184b-4d83-9635-02c812131205 Signature libsystem_platform.dylib@0x53a7 More Reports Search UUID 9c650a67-184b-4d83-9635-02c812131205 Date Processed 2013-12-05 17:48:02.679272 Uptime 78043 Last Crash 78048 seconds before submission Install Age 1721889 since version was first installed. Install Time 2013-11-15 19:29:43 Product Firefox Version 25.0.1 Build ID 20131112160018 Release Channel release OS Mac OS X OS Version 10.9.0 13A603 Build Architecture x86 Build Architecture Info family 6 model 42 stepping 7 | 4 Crash Reason EXC_BAD_ACCESS / KERN_PROTECTION_FAILURE Crash Address 0x0 User Comments App Notes AdapterVendorID: 0x1002, AdapterDeviceID: 0x6740WebGL? GL Context? GL Context+ WebGL+ Processor Notes sp-processor07_phx1_mozilla_com.5051:2012; HybridCrashProcessor EMCheckCompatibility True Winsock LSP Adapter Vendor ID 0x1002 Adapter Device ID 0x6740

Chosen solution

Does the crashing occur on any specific site or just when too many Flash videos are open at once?
How much RAM and CPU does your computer have?

If you have a low amount of CPU or RAM on your system, you may experience crashing when viewing multiple Flash items.


Please try updating to the most recent version of Firefox (26.0). Your issue may have been patched by our team of developers.

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Adobe Shockwave for Director Netscape plug-in, version 12.0.6
  • Shockwave Flash 11.9 r900
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Provides information about the default web browser

Application

  • Firefox 25.0.1
  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.9; rv:25.0) Gecko/20100101 Firefox/25.0
  • Support URL: https://support.mozilla.org/1/firefox/25.0.1/Darwin/en-US/

Extensions

  • Troubleshooter 1.1a (troubleshooter@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription:
  • adapterDeviceID: 0x6740
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'quartz', u'AzureSkiaAccelerated': 0}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 6770M OpenGL Engine
  • windowLayerManagerRemote: False
  • windowLayerManagerType: Basic

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.sessionstore.upgradeBackup.latestBuildID: 20131112160018
  • browser.startup.homepage: www.Google.com
  • browser.startup.homepage_override.buildID: 20131112160018
  • browser.startup.homepage_override.mstone: 25.0.1
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 25.0.1
  • font.internaluseonly.changed: False
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • layers.acceleration.disabled: True
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1386265748
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1385423076

Misc

  • User JS: No
  • Accessibility: No
Wesley Branton
  • Top 25 Contributor
180 solutions 2262 answers

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See this article for more information on using the Flash plugin in Firefox).

To disable hardware acceleration in Flash Player:

  1. Go to this Adobe Flash Player Help page.
  2. Right-click on the Flash Player logo on that page.
  3. Click on Settings in the context menu. The Adobe Flash Player Settings screen will open.
  4. Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel.

    fpSettings1.PNG
  5. Remove the check mark from Enable hardware acceleration.
  6. Click Close to close the Adobe Flash Player Settings Window.
  7. Restart Firefox.

This Flash Player Help - Display Settings page has more information on Flash Player hardware acceleration, if you're interested.

Does this solve the problem? Let us know.

Some problems with Flash video playback can be resolved by disabling hardware acceleration in your Flash Player settings. (See [[Flash Plugin - Keep it up to date and troubleshoot problems|this article]] for more information on using the Flash plugin in Firefox). To disable hardware acceleration in Flash Player: #Go to this [http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues Adobe Flash Player Help page]. #Right-click on the Flash Player logo on that page. #Click on '''Settings''' in the context menu. The Adobe Flash Player Settings screen will open. # Click on the icon at the bottom-left of the Adobe Flash Player Settings window to open the Display panel. <br/> <br/>[[Image:fpSettings1.PNG]] <br/> # Remove the check mark from '''Enable hardware acceleration'''. # Click '''Close''' to close the Adobe Flash Player Settings Window. # Restart Firefox. This [http://www.macromedia.com/support/documentation/en/flashplayer/help/help01.html Flash Player Help - Display Settings page] has more information on Flash Player hardware acceleration, if you're interested. Does this solve the problem? Let us know.

Question owner

Thank you for the reply ComputerWhiz, I clicked on Adobe Flash player via the website and found that I had already deselected Enable hardware acceleration. So it has been off while these crashes are occurring.

Thank you

Thank you for the reply ComputerWhiz, I clicked on Adobe Flash player via the website and found that I had already deselected Enable hardware acceleration. So it has been off while these crashes are occurring. Thank you
Wesley Branton
  • Top 25 Contributor
180 solutions 2262 answers

Helpful Reply

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches.

You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.).

Then perform these steps:

  • Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options.
  • In the Firefox options window click the Advanced tab, then select "General".
  • In the settings list, you should find the Use hardware acceleration when available checkbox. Uncheck this checkbox.
  • Now, restart Firefox and see if the problems persist.

Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles:

Did this fix your problems? Please report back soon.

Try disabling graphics hardware acceleration. Since this feature was added to Firefox, it has gradually improved, but there still are a few glitches. You might need to restart Firefox in order for this to take effect, so save all work first (e.g., mail you are composing, online documents you're editing, etc.). Then perform these steps: *Click the orange Firefox button at the top left, then select the "Options" button, or, if there is no Firefox button at the top, go to Tools > Options. *In the Firefox options window click the ''Advanced'' tab, then select "General". *In the settings list, you should find the ''Use hardware acceleration when available'' checkbox. Uncheck this checkbox. *Now, restart Firefox and see if the problems persist. Additionally, please check for updates for your graphics driver by following the steps mentioned in the following Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Did this fix your problems? Please report back soon.
Wesley Branton
  • Top 25 Contributor
180 solutions 2262 answers

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • On Windows you can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac you can open Firefox 4.0+ in Safe Mode by holding the option key while starting Firefox.
  • On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

FirefoxSafeMode

Once you get the pop-up, just select "'Start in Safe Mode" Safe Mode Fx 15 - Win

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Please report back soon.

'''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * On Windows you can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * On Mac you can open Firefox 4.0+ in Safe Mode by holding the '''option''' key while starting Firefox. * On Linux you can open Firefox 4.0+ in Safe Mode by quitting Firefox and then going to your Terminal and running: firefox -safe-mode (you may need to specify the Firefox installation path e.g. /usr/lib/firefox) * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. [[Image:FirefoxSafeMode|width=520]] ''Once you get the pop-up, just select "'Start in Safe Mode"'' [[Image:Safe Mode Fx 15 - Win]] '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Please report back soon.

Question owner

Ok I tried it in safe mode and it still crashed. Today it submitted this:

ID: c1dae764-a4f8-4e1d-96dc-a89842131210 Signature: EMPTY: no crashing thread identified; ERROR_NO_THREAD_LIST

I have hardware acceleration disabled and on Adobe flash player I also have hardware acceleration off. It seems to crash when I have multiple videos up but not playing. Not sure what is happening but it is occurring daily. Videos often also freeze until I clear the history. History is cleared every time I close firefox so at most I only have 18 hours of browsing history prior to the crash, usually less.

Any suggestions?

Ok I tried it in safe mode and it still crashed. Today it submitted this: ID: c1dae764-a4f8-4e1d-96dc-a89842131210 Signature: EMPTY: no crashing thread identified; ERROR_NO_THREAD_LIST I have hardware acceleration disabled and on Adobe flash player I also have hardware acceleration off. It seems to crash when I have multiple videos up but not playing. Not sure what is happening but it is occurring daily. Videos often also freeze until I clear the history. History is cleared every time I close firefox so at most I only have 18 hours of browsing history prior to the crash, usually less. Any suggestions?
Wesley Branton
  • Top 25 Contributor
180 solutions 2262 answers

Chosen Solution

Does the crashing occur on any specific site or just when too many Flash videos are open at once?
How much RAM and CPU does your computer have?

If you have a low amount of CPU or RAM on your system, you may experience crashing when viewing multiple Flash items.


Please try updating to the most recent version of Firefox (26.0). Your issue may have been patched by our team of developers.

Does the crashing occur on any specific site or just when too many Flash videos are open at once?<br> How much RAM and CPU does your computer have? If you have a low amount of CPU or RAM on your system, you may experience crashing when viewing multiple Flash items. ---------- Please try updating to the most recent version of Firefox (26.0). Your issue may have been patched by our team of developers.