X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Your new secure content feature in the subject bar blocks my reCAPTCHA on my site's login page. That page is SSL encrypted and nothing should block reCAPTCHA.

Posted

After the latest update of your browser, the reCAPTCHA (a Google product now) gets blocked. There is no way to safe-list it because anytime the page reloads, the reCAPTCHA is blocked again. This reCAPTCHA uses an API and an Iframe but it is directly from Google. This is a terrible feature for someone who owns a web site as well as for an end-user who cannot figure out why they are not able to log-in.

PS: I also have the NoScript add-on, however, this should have nothing to do with the aforementioned issue. Running Win 7 with the latest version of Firefox. Please help!

Chosen solution

Is this an option for you:

In order to avoid getting browser warnings when you use reCAPTCHA on an SSL site, you should replace http://www.google.com/recaptcha/api with https://www.google.com/recaptcha/api when you request a challenge.

Source: reCAPTCHA: Tips and Guidelines - reCAPTCHA — Google Developers

Read this answer in context 2

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • VLC media player Web Plugin 2.0.0-rc
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Zeon PDF Plugin For Mozilla
  • Office Authorization plug-in for NPAPI browsers
  • CANON iMAGE GATEWAY Mycamera Plugin

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

jscher2000
  • Top 10 Contributor
2345 solutions 20793 answers

Chosen Solution

Is this an option for you:

In order to avoid getting browser warnings when you use reCAPTCHA on an SSL site, you should replace http://www.google.com/recaptcha/api with https://www.google.com/recaptcha/api when you request a challenge.

Source: reCAPTCHA: Tips and Guidelines - reCAPTCHA — Google Developers

Question owner

The following was defined in the reCAPTCHA includes/functions/recaptchalib.php file

define("RECAPTCHA_API_SERVER", "http://www.google.com/recaptcha/api"); define("RECAPTCHA_API_SECURE_SERVER", "https://www.google.com/recaptcha/api");

I added the "s" to http in RECAPTCHA_API_SERVER and everything works great now. Thank you for your prompt response and for resolving this issue.