X
Tap here to go to the mobile version of the site.

Support Forum

The address bar defaults to google even though I modified it for bing

Posted

Some months ago I used about:config to have the address bar default to Bing search. Yesterday it started defaulting to Google.

The thing is, when I re-enter about:config, the keyword.url is still set to Bing. Any idea what's up and how I can get Bing back?

Some months ago I used about:config to have the address bar default to Bing search. Yesterday it started defaulting to Google. The thing is, when I re-enter about:config, the keyword.url is still set to Bing. Any idea what's up and how I can get Bing back?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.8 r800
  • Google Update
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • SiteAdvisor
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.7
  • McAfee MSC FF plugin DLL
  • McAfee Virtual Technician plugin
  • NPWLPG
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 23.0.1
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20100101 Firefox/23.0
  • Support URL: http://support.mozilla.org/1/firefox/23.0.1/WINNT/en-US/

Extensions

  • feedly 16.0.528 (feedly@devhd)
  • McAfee SiteAdvisor 3.6.2 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92})
  • Norton Identity Safe Toolbar 2013.4.2.2 ({F04D2D30-776C-4d02-8627-8E4385ECA58D})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Adobe Acrobat - Create PDF 1.2 (web2pdfextension@web2pdf.adobedotcom) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics Family
  • adapterDescription2:
  • adapterDeviceID: 0x0102
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16571
  • driverDate: 1-27-2011
  • driverDate2:
  • driverVersion: 8.15.10.2291
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics Family)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: https://mail.google.com/mail/u/0/?shva=1#inbox
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • browser.tabs.warnOnClose: False
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://www.bing.com/search?q=
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1376848844
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • privacy.sanitize.migrateFx3Prefs: True
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1376498075

Misc

  • User JS: No
  • Accessibility: No
cor-el
  • Top 10 Contributor
  • Moderator
17413 solutions 157295 answers

Starting with Firefox 23 the keyword.URL pref is no longer supported and it is no longer possible to specify the search engine for the location bar that way.
The search engine that is used in the location bar is the search engine that is selected in the search Bar on the Navigation Toolbar.
You can disable automatic searching via the location bar by setting keyword.enabled to false and use a (one letter) keyword search to use a specific search engine instead to search via the location bar.
Another possibility is to disable keyword search (keyword.enable = false) and use a (one letter) keyword search for searching via the location bar.
You can set a keyword for an installed search engine via Manage Search Engines (click the search engines icon on the search bar).
That also allows to switch easily between search engines when searching via the location bar and you also do not have a problem with one word searches.

See also:

Starting with Firefox 23 the keyword.URL pref is no longer supported and it is no longer possible to specify the search engine for the location bar that way.<br /> The search engine that is used in the location bar is the search engine that is selected in the search Bar on the Navigation Toolbar.<br /> You can disable automatic searching via the location bar by setting keyword.enabled to false and use a (one letter) keyword search to use a specific search engine instead to search via the location bar.<br /> Another possibility is to disable keyword search (keyword.enable = false) and use a (one letter) keyword search for searching via the location bar.<br /> You can set a keyword for an installed search engine via Manage Search Engines (click the search engines icon on the search bar).<br /> That also allows to switch easily between search engines when searching via the location bar and you also do not have a problem with one word searches.<br /> See also: * Keyword Search: https://addons.mozilla.org/firefox/addon/keyword-search/ * keyword.URL Hack!: https://addons.mozilla.org/firefox/addon/keywordurl-hack/