X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox Takes Ages To Start Up

Posted

I don't know why this is happening but for some reason Firefox now takes a very very long time to start up. Once it's running it seems fine. The only changes I have made were installing AVG 2013 (which i have removed to see if it makes any difference because I don' tlike these programmes running all the time), and updating Java plugins,. There is an issue with the Java Deployment Toolkit, whatever that is, but it's not set to be 'always activate'. That java update is the only thing I can think of. This is very frustrating because I like to have it running when i load up my pc.

Additional System Details

Installed Plug-ins

  • npsitesafety
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.4.2.14502
  • Shockwave Flash 11.8 r800
  • Google Update
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • 5.1.20513.0
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Amazon MP3 Downloader Plugin 1.0.17
  • Unity Player 2.6.1f3
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Npdsplay dll
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Windows Multimedia Services DRM Store Plug-In

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:23.0) Gecko/20100101 Firefox/23.0

More Information

Waka_Flocka_Flame
  • Top 25 Contributor
528 solutions 5041 answers

Helpful Reply

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Question owner

It seems to be only when the computer starts up. But there's nothing else running other than comodo firewall and windows stuff.

cor-el
  • Top 10 Contributor
  • Moderator
10738 solutions 96605 answers

Helpful Reply

It is possible that your security software (firewall, anti-virus) blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See: