Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After the update of firefox 23, whenever I click back button doesn't reload the page.

more options

Before the update everything was working fine, but yesterday after the update I noticed that whenever I open a page and after that I hit back button, it doesn't reload the page like before. It's annoying, because I use forum and sometimes is confusing when I open a thread and after that it still says that "new thing", the only way to remove it is to reload the page from the refresh button.

Before the update everything was working fine, but yesterday after the update I noticed that whenever I open a page and after that I hit back button, it doesn't reload the page like before. It's annoying, because I use forum and sometimes is confusing when I open a thread and after that it still says that "new thing", the only way to remove it is to reload the page from the refresh button.

All Replies (20)

more options

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

You can also check for problems with the places.sqlite database file in the Firefox profile folder.

Modified by cor-el

more options

I tried everything above and still doesn't want to work. Even I reinstalled Firefox and still nothing.. :(

more options

Create a new profile as a test to check if your current profile is causing the problems.

See "Creating a profile":

If the new profile works then you can transfer some files from an existing profile to the new profile, but be careful not to copy corrupted files.

more options

Didn't work.

more options

Hi Nikolay, Firefox tries to honor the directions of the site about caching pages and how soon they need to be reloaded. I don't know whether you are seeing something new in Firefox or it's a coincidence. Can you give a URL for the page that doesn't reload when you go Back to it?

more options

It's not only one page that doesn't work, yesterday I tried all sites and this problem occurs. I have searched for this problem here and other sites and tried almost everything and doesn't work.

more options

You did try a new profile without making any modifications or installing or enabling extensions?

Boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

Modified by cor-el

more options

Hi Nikolay.N, can you try the following form, just fill in anything and submit, then go back. The form specifies that it should not be cached, so it should reload and clear all fields. Do the fields clear?

more options

Yes, they do.

more options

Hi Nikolay, thanks for testing. Pages that do not reload probably instruct Firefox to cache them. While you could disable caching, this probably would slow down most of your browsing.

In a quick search, I didn't see a way to block individual sites from being cached. I think Ctrl+r is your best workaround for updating the page until someone finds a better solution.

more options

@cor-el: Yes, I made a new profile without any modification and still this problem occurs. For some reason I couldn't connect to Internet through Save mode, still I was in Save mode networing.

@jscher2000: I have disabled caching from "about:config" and still this occurs.

Thanks to everyone's help. I really appreciate it. It's not a big problem, but I kinda got used to that and now it's really uncomfortable.

Modified by N.Nikolay

more options
more options

Yes, I checked that before making this thread. Nothing worked.

more options

I am having this same problem and I'm running Windows 7 and FireFox 24.0 I've tried all the suggestions and it's still NOT working.

Any other thoughts to get this working?

more options

Hi Vicki10, just to clarify, there is another reload problem going around, where going back to Google results displays a blank page. Are you having that problem, or the original problem in this thread that Firefox display an older page instead of refreshing it?

If it's the Google problem, please see: When I go back to Google search results page, it takes me to a blank Google screen.

If it's the "old information" problem, this usually is caused by the site's instructions to Firefox to cache the page for a certain period of time, and Firefox's own tenacious back-forward caching. If you want to post a URL, a volunteer can take a look at the page and see whether it appears to be behaving normally by not reloading, or whether it is supposed to be reloading on every visit. If you want to try to override caching, did the setting in this post (browser.cache.check_doc_frequency=1) change anything?

more options

I am having the original problem in this thread of Firefox displaying an older page when I press the Back button instead of refreshing it.

I did change the browser.cache.check_doc_frequency=1! Didn't help at all.

I am NOT seeing the Google problem at all.

When the page isn't refreshing with the Back button, I'm usually on a Forum reading new posts. I read the post and then hit Back and it doesn't reload/refresh letting me know I've already read the post(s).

Here's the URL from one Forum I read daily:

I'd be really interested in knowing the outcome once they've visited that Forum. Thank you!

more options

Hi Vicki10, Firefox is keeping that page (e.g., PSAS News) in its "fast back-forward cache" even though according to the disk cache the page is already expired. You can see this by viewing Firefox Web Console.

When viewing a forum index page, press Ctrl+Shift+k to open the Web console. Click the CSS button to turn off style warnings, and click Clear. Then click a link to a post. You should see numerous lines showing Firefox loading that page and various part of it.

After that finishes, click Clear again. Then use the Back button to return to the index. If yours works like mine, there's nothing happening in the console. Firefox is not reloading the page or any part of it.

To force a reload, you can take advantage of a proprietary Firefox behavior: when you go "back" to a cached page Firefox will look for a script associated with the PageShow event, and run it. By adding a reload into a PageShow script, you can force Firefox to reload the page.

This trick can be performed manually or using a userscript.

Manual Method: Web Console

This is not practical, but is a proof of concept. Select and copy the following script (it's all one line):

window.addEventListener('pageshow', function(){window.location.reload()}, false);

While viewing the forum index page with the Web Console open, paste that script next to the caret (>), and press Enter. This will inject a PageShow script into the page.

Then repeat the earlier test: click to a forum thread, clear the console, click the Back button. This time, the console should show Firefox retrieving the page from the server.

Now, how can this be made convenient to use?

Automated Method: Userscript

There are two Firefox extension that allow you to run userscripts for any pages you like. These scripts can make the kind of change demonstrated in the proof of concept, and way, way more. Personally I use the Greasemonkey extension, but some people prefer the Scriptish extension. After installing whichever one you prefer, you can install a userscript which will inject the PageShow script into that forum list every time you visit it.

Note: the site currently seems to have no administration of script quality or safety, so be very choosy when installing scripts, check reviews with a skeptical eye, and avoid any scripts that show in the install dialog that they run on Facebook or other unexpected sites.

I realize that's a bit more than most people will want to do, but it seems to be the most convenient solution available at the moment.

more options

WoW! I just added Greasemonkey and it is showing the PSAS url. There haven't been any new posts, so can't tell if it's working or not.

Another forum I visit daily is an IP Board Forum. Do you happen to know what I should have after the URL to get it to work? I tried adding just the URL to the script copying the remmed out line that had the PSAS url on it. Is that how I'm supposed to edit the script or do I have to do something more?

I have never added an add on before so it's all new to me.

You're GREAT with all the help you've given so far. THANK YOU! Vicki

more options

Hi Vicki, you either can edit the script or you can add the URL to the list of user includes using the Options button. For example, let's say you wanted the script to run on this URL:

and all the other various forums on the site which have similar URLs. You could add this new pattern to the user includes:*

as illustrated in the attached screen shot.

Edit: The advantage of using the user includes feature that is when the script is updated, you won't lose your changes.

Modified by jscher2000 - Support Volunteer

more options

Okay, I've got Greasemonkey showing that I have an installed script on the two Forums I visit the most. No one has posted anything yet, so I'm not positive it's working correctly, but you certainly did help me get this installed and running!

It really makes sense to use the "user Includes" too. I'll go change that instead of the script.

I can hardly wait for someone to post something to be positive this is working correctly.



  1. 1
  2. 2
  3. 3