X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Ever since my Firefox updated my YouTube videos are all playing low quality be default.

Posted

I don't know why this has happened but ever since my Firefox upgraded all YouTube videos have been playing super low quality by default. When I first installed Firefox months ago this wasn't a problem. Everything played HD by default. But every time Firefox upgrades itself the videos go down in quality. And especially since the OS upgrade everything is playing super low quality by default. How do I get them to just play HD by default again?

Thanks so much for your time and help!

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0

More Information

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8020 answers

Helpful Reply

I am not sure this is a widely reported fault (I will look later). Probably coincidence. I would suggest as a first attempt to cure this you clear cookies for the YouTube site.

Presumably you are able to manually set the resolution where High Definition is available on YouTube video. As I understand it you are saying the problem is it defaults to Lo Resolution,not that HD will not play,

Also I wonder if you are using and seeing HTML5 or FlashPlayer videos. (LastI checked HTML5 was a bet option on YouTube site))


Notes to self

Question owner

Yes, you are correct: Videos are defaulting to low res, but if manually set HD will play (but in the beginning, my videos used to default to HD). HOWEVER, HD takes FOREVER to load and will often freeze when playing. This never happened when I first installed Firefox either. HD played easily and smoothly.

I use Adobe Flash player to view YouTube videos.

I cleared all the cookies like you suggested (thanks for posting links to that too :) and it seems to have improved things a little, but the videos still don't look or default to HD. They are still noticeably fuzzy :/

Thanks for your response!

jscher2000
  • Top 10 Contributor
2366 solutions 20923 answers

Could you try Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?


This is some standard guidance that addresses the most common issues with Flash -- perhaps it will help here?

(1) Disable hardware graphics acceleration in Firefox and in Flash

(A) In Firefox, un-check the box here and restart:

orange Firefox button (or Tools menu) > Options > Advanced > General > "Use hardware acceleration when available"

(B) In Flash, see this support article from Adobe: http://helpx.adobe.com/flash-player/kb/video-playback-issues.html#main_Solve_video_playback_issues

(2) Disable protected mode (Win Vista & Win 7 & Win 8)

See this support article from Adobe under the heading "Last Resort": Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?

John99
  • Top 25 Contributor
  • Moderator
622 solutions 8020 answers

Thanks Jeff, I neglected to follow up on this one.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96771 answers

Try to clear the Flash local storage and settings.

  • Windows Control Panel > Flash Player > Storage: Local Storage Settings
    • Remove a specific domain: Local Storage Settings by site
    • Remove all domains: Delete All and Delete Data

Flash Website Storage Settings panel:

Global Storage Settings Panel: