X
Tap here to go to the mobile version of the site.

Support Forum

I get this message on the new Firefox v22 -Error: Illegal operation on WrappedNative prototype object

Posted

Every time I go to a website other than mozilla support I get the following -Error: Illegal operation on WrappedNative prototype object

I have updated Java on my Windows 8 machine. I have not gone to 8.1 yet. On the older version of Firefox -(I used it an hour ago) this message did not appear.

What do I need to do>

Every time I go to a website other than mozilla support I get the following -Error: Illegal operation on WrappedNative prototype object I have updated Java on my Windows 8 machine. I have not gone to 8.1 yet. On the older version of Firefox -(I used it an hour ago) this message did not appear. What do I need to do>

Chosen solution

I had the same message and disabled the You tube downloader video 1.3 and it went away. Hope it helps kathelee@gmail.com

Read this answer in context 7

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Picasa plugin
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • McAfee MSC FF plugin DLL
  • 5.1.20125.0
  • SiteAdvisor
  • Coupons, Inc. Coupon Printer Plugin
  • NPWLPG
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers

Application

  • Firefox 22.0
  • User Agent: Mozilla/5.0 (Windows NT 6.2; WOW64; rv:22.0) Gecko/20100101 Firefox/22.0
  • Support URL: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Extensions

  • Advanced SystemCare Surfing Protection 1.0 (ascsurfingprotection@iobit.com)
  • IObit Apps Toolbar 7.2 (iobitapps@mybrowserbar.com)
  • McAfee ScriptScan for Firefox 15.1.0 ({D19CA586-DD6C-4a0a-96F8-14644F340D60})
  • McAfee SiteAdvisor 3.6.0 ({4ED1F68A-5463-4931-9384-8FFF5ED91D92})
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Web2PDF converter 1.12 ({e8f509f0-b677-11de-8a39-0800200c9a66})
  • Youtube Downloader Videos 1.3 ({a3a5c777-f583-4fef-9380-ab4add1bc2a5})

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics
  • adapterDescription2:
  • adapterDeviceID: 0x0152
  • adapterDeviceID2:
  • adapterDrivers: igdumd64 igd10umd64 igd10umd64 igdumd32 igd10umd32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2200 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 50
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.16433
  • driverDate: 9-2-2012
  • driverDate2:
  • driverVersion: 9.17.10.2849
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics)
  • windowLayerManagerType: Direct3D 10

Modified Preferences

  • accessibility.typeaheadfind: True
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.memory.capacity: 65536
  • browser.display.show_image_placeholders: True
  • browser.places.smartBookmarksVersion: 4
  • browser.search.param.yahoo-fr: chr-greentree_ff&ilc=12&type=198484
  • browser.startup.homepage: about:home
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.urlbar.autocomplete.enabled: True
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: True
  • gfx.direct3d.last_used_feature_level_idx: 0
  • gfx.direct3d.prefer_10_1: True
  • keyword.URL: http://search.yahoo.com/search?fr=greentree_ff1&ei=utf-8&ilc=12&type=198484&p=
  • network.cookie.prefsMigrated: True
  • network.http.max-connections: 48
  • network.http.max-connections-per-server: 16
  • network.http.max-persistent-connections-per-proxy: 16
  • network.http.max-persistent-connections-per-server: 8
  • network.http.pipelining.maxrequests: 8
  • network.http.request.max-start-delay: 0
  • places.database.lastMaintenance: 1372361637
  • places.history.expiration.transient_current_max_pages: 104008
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.expose_full_path: True
  • plugin.importedState: True
  • plugin.state.java: 0
  • plugin.state.npdeployjava: 0
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1370181395

Misc

  • User JS: Yes
  • Accessibility: No
philipp
  • Top 10 Contributor
  • Moderator
2813 solutions 13083 answers

hello, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe one of your addons is not working nicely with the new firefox version...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

hello, can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe one of your addons is not working nicely with the new firefox version... [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]
mauxuam 0 solutions 2 answers

disabled all add-ons and problem stop... now will start to add them back one by one :)

disabled all add-ons and problem stop... now will start to add them back one by one :)
jscher2000
  • Top 10 Contributor
2985 solutions 27723 answers
In another thread someone said CloudMagic can cause this error. [https://support.mozilla.org/en-US/questions/963014 I just upgraded to FireFox 22.0, and now I get a Javascript error (Error: Illegal operation on WrappedNative prototype object). What can I do?]
mauxuam 0 solutions 2 answers

I had the same issue and I fixed it...so far.

Firefox 22 MacBook i7 - Mac OS X 10.8.4 Java 7 Update 25

I disabled all the add Ons and re enabled them one by one.

The ones causing that problem where all related to google : 1 - Google Search by Image / 2 - Search By Image (by Google) / 3 - DeeperWeb - Boost and Customize Google Search

I disabled them and the problem disappear. this is the collection of installed Add Ons without problems so far :

https://addons.mozilla.org/en-US/firefox/collections/mauxuam/addtested-ok-with-firefox-22/
I had the same issue and I fixed it...so far. Firefox 22 MacBook i7 - Mac OS X 10.8.4 Java 7 Update 25 I disabled all the add Ons and re enabled them one by one. The ones causing that problem where all related to google : 1 - Google Search by Image / 2 - Search By Image (by Google) / 3 - DeeperWeb - Boost and Customize Google Search I disabled them and the problem disappear. this is the collection of installed Add Ons without problems so far : https://addons.mozilla.org/en-US/firefox/collections/mauxuam/addtested-ok-with-firefox-22/
jmcox11 0 solutions 5 answers

I am receiving Error: Illegal operation on WrappedNative prototype object frequently with all add-ons disabled. Have trashed Java applet. No help.

Macbook Pro Mountain Lion.

Any help appreciated.

I am receiving Error: Illegal operation on WrappedNative prototype object frequently with all add-ons disabled. Have trashed Java applet. No help. Macbook Pro Mountain Lion. Any help appreciated.
lisagu 0 solutions 4 answers

I disabled fbphototheaterkiller and it fixed the problem with: "Error: Illegal operation on WrappedNative prototype object". these annoying error messages on Mozilla Firefox are now gone! Hurrey!!!!

I disabled fbphototheaterkiller and it fixed the problem with: "Error: Illegal operation on WrappedNative prototype object". these annoying error messages on Mozilla Firefox are now gone! Hurrey!!!!
prepa 0 solutions 1 answers

I disabled youtube downloader video 1.2 add-ons and it fixed the problem with: "Error: Illegal operation on WrappedNative prototype object".

I disabled youtube downloader video 1.2 add-ons and it fixed the problem with: "Error: Illegal operation on WrappedNative prototype object".
jmcox11 0 solutions 5 answers

This is a follow up.

I have disabled all add-ons. The error message continues.

I hope Firefox is going to fix this issue soon, as it makes using the browser very difficult.

This is a follow up. I have disabled all add-ons. The error message continues. I hope Firefox is going to fix this issue soon, as it makes using the browser very difficult.
jscher2000
  • Top 10 Contributor
2985 solutions 27723 answers

Hi jmcox11, just to make sure, when you disabled all add-ons, did you visit all 3 of these tabs:

Tools menu > Add-ons > Extensions category (most relevant)
Tools menu > Add-ons > Appearance category (sometimes relevant)
Tools menu > Add-ons > Plugins category (possibly relevant)

Hi jmcox11, just to make sure, when you disabled all add-ons, did you visit all 3 of these tabs: Tools menu > Add-ons > Extensions category (''most relevant'')<br> Tools menu > Add-ons > Appearance category (''sometimes relevant'')<br> Tools menu > Add-ons > Plugins category (''possibly relevant'')
jmcox11 0 solutions 5 answers

Thanks for the suggestion. I followed it and still receive the error message. I have every add on in all three section disabled. It appears to me that the updated Firefox has a "bug." I'm sure the "wizards" are working on it until they have it fixed I have had to use Safari as my primary browser. Not my preferred choice.

Thanks for the suggestion. I followed it and still receive the error message. I have every add on in all three section disabled. It appears to me that the updated Firefox has a "bug." I'm sure the "wizards" are working on it until they have it fixed I have had to use Safari as my primary browser. Not my preferred choice.
jscher2000
  • Top 10 Contributor
2985 solutions 27723 answers

Hi jmcox11, Firefox 22 changed or removed some methods used by add-ons. This was intentional and unlikely to change in the future.

Where do you get the error now that all your extensions are disabled?

Hi jmcox11, Firefox 22 changed or removed some methods used by add-ons. This was intentional and unlikely to change in the future. Where do you get the error now that all your extensions are disabled?
jmcox11 0 solutions 5 answers

Helpful Reply

Every web page change cause 1 to 6 error messages. If this was an intentional action then the unintended consequences out weigh the benefits. I would gladly go back to the previous version and forget the update. Firefox has been my primary browser for years, now I wonder if it can be in the future.

Every web page change cause 1 to 6 error messages. If this was an intentional action then the unintended consequences out weigh the benefits. I would gladly go back to the previous version and forget the update. Firefox has been my primary browser for years, now I wonder if it can be in the future.
jscher2000
  • Top 10 Contributor
2985 solutions 27723 answers

Hi jmcox11, are the errors displayed as pop-up messages, and/or in the page itself, and/or in the Error Console (Tools menu > Web Developer > Error Console)?

If they are displayed in the error console, check the URI listed for the error and see whether it is generated by a script from the web or on your computer. Hopefully this will help in tracking down the source of the no-longer-supported command.

Hi jmcox11, are the errors displayed as pop-up messages, and/or in the page itself, and/or in the Error Console (Tools menu > Web Developer > Error Console)? If they are displayed in the error console, check the URI listed for the error and see whether it is generated by a script from the web or on your computer. Hopefully this will help in tracking down the source of the no-longer-supported command.
philipp
  • Top 10 Contributor
  • Moderator
2813 solutions 13083 answers

please try to reset firefox and see if this can address the issue...

please try to [[Reset Firefox – easily fix most problems|reset firefox]] and see if this can address the issue...
jmcox11 0 solutions 5 answers

Thank you for the help! The reset of Firefox appears to have solved the problem with all add-ons disabled.

I very much appreciate the help.

Thank you for the help! The reset of Firefox appears to have solved the problem with all add-ons disabled. I very much appreciate the help.
kathelee 1 solutions 1 answers

Chosen Solution

I had the same message and disabled the You tube downloader video 1.3 and it went away. Hope it helps kathelee@gmail.com

I had the same message and disabled the You tube downloader video 1.3 and it went away. Hope it helps kathelee@gmail.com
blackbearlover 0 solutions 1 answers

Helpful Reply

F.B. Purity was cause in my case, went to F.B. Purity website and got updated version and all is well

F.B. Purity was cause in my case, went to F.B. Purity website and got updated version and all is well
fabian_baeza 0 solutions 1 answers

Hi, I followed the advice of some of you, I disabled a gmail/google (integrated gmail 2.8.0) related add-on and problem solved. Thanks a a lot! Fabian

Hi, I followed the advice of some of you, I disabled a gmail/google (integrated gmail 2.8.0) related add-on and problem solved. Thanks a a lot! Fabian

Modified by fabian_baeza

migas62 0 solutions 1 answers

The best you have to do is: disable add-ons and extensions, restart the browser and enable add-ons / extensions one by one and check to see when the problem apears. Sooner or later you will discover which add-on/extension is causing the problem.

The best you have to do is: '''disable add-ons and extensions''', '''restart the browser''' and '''enable add-ons / extensions one by one '''and '''check to see when the problem apears'''. Sooner or later you will discover which add-on/extension is causing the problem.

Modified by migas62

Tiinav 0 solutions 2 answers

I get too this message :(, I disabled add-ons, but this is not help

I get too this message :(, I disabled add-ons, but this is not help

Modified by Tiinav