Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Problem with https

  • 2 replies
  • 4 have this problem
  • 876 views
  • Last reply by doctorized

more options

I used Firefox for a long time with no problems. I never played with the internal settings (from about:config). One day, with version 21, I found out that every time I do a image search in Google, I could see only 15 to 20 pics correctly and all the others appeared as grey boxes. I deleted cookies and cache but nothing changed. I tried to find a solution and in a Mozilla’s forum was said to reset Firefox from “Troubleshooting Information” menu. I did it and the problem disappeared. Then, another, worse problem, appeared. All sites were tried to get opened with https in front and in all cases Firefox was telling me that the connection is untrusted and can’t confirm that my connection is secure. I was selecting “I understand the risks” and the site was appeared but it was altered, it hadn’t the look that it should have. I did a google search to find a solution. Nothing really helpful came up. In your forum I found a setting, “browser.urlbar.autoFill” that should be turned to false. I did it and the problem was fixed is some pages. Now I can open google and some other pages with no problem but some others, like yahoo mail, that require secure connection (https) cannot get accessed. I tried to uninstall Firefox using Revo Uninstaller, to be sure that all data will be deleted. I reinstalled Firefox but the problem still exists. I uninstalled Firefox again and downloaded and installed version 22 beta 3 of Firefox with the same luck. So, what’s wrong? What should I do?

Chosen solution

Check out why the site is untrusted (click "Technical Details to expand that section) and if this is caused by a missing intermediate certificate then see if you can install this intermediate certificate from another source.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab".

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

  • ESET setup -> advanced setup -> extend web and email tree -> SSL
  • SSL protocol: Do not scan SSL protocol
Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

Check out why the site is untrusted (click "Technical Details to expand that section) and if this is caused by a missing intermediate certificate then see if you can install this intermediate certificate from another source.

You can retrieve the certificate and check details like who issued certificates and expiration dates of certificates.

  • Click the link at the bottom of the error page: "I Understand the Risks"

Let Firefox retrieve the certificate: "Add Exception" -> "Get Certificate".

  • Click the "View..." button and inspect the certificate and check who is the issuer.

You can see more Details like intermediate certificates that are used in the Details pane.

If "I Understand the Risks" is missing then this page may be opened in an (i)frame and in that case try the right-click context menu and use "This Frame: Open Frame in New Tab".

Some firewalls monitor secure (https) connections and send their own certificate instead of the website's certificate.

  • ESET setup -> advanced setup -> extend web and email tree -> SSL
  • SSL protocol: Do not scan SSL protocol
more options

ESET was the problem. Thank you cor-el!!