X
Tap here to go to the mobile version of the site.

Support Forum

how to restore all history

Posted

I accidentally deleted history by clicking on DELETE ALL HISTORY. can i get it back ?

I accidentally deleted history by clicking on DELETE ALL HISTORY. can i get it back ?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.7 r700
  • Adobe PDF Plug-In For Firefox and Netscape 11.0.03
  • Next Generation Java Plug-in 10.21.2 for Mozilla browsers
  • McAfee MSS+ NPAPI Plugin
  • 5.1.20125.0
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • CANON iMAGE GATEWAY Album Plugin Utility Module for IJ

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

jscher2000
  • Top 10 Contributor
8758 solutions 71663 answers

Just right now this happened? It depends on whether Firefox has made the change to the database file by now, or there is a delay.

If you open your active settings folder (AKA Firefox profile folder) you can try copy out the places.sqlite database to a safe place right now before anything further happens:

Help > Troubleshooting Information > "Show Folder" button

Just right now this happened? It depends on whether Firefox has made the change to the database file by now, or there is a delay. If you open your active settings folder (AKA Firefox profile folder) you can try copy out the places.sqlite database to a safe place right now before anything further happens: Help > Troubleshooting Information > "Show Folder" button
jscher2000
  • Top 10 Contributor
8758 solutions 71663 answers

Helpful Reply

Let's say hypothetically that you were able to rescue a "good" (pre-delete) history database. Let's hold that thought and do something else first.

Keep your profile folder open, exit Firefox, then wait for the files to be updated. Right-click the places.sqlite file > Properties > Previous Versions tab. Windows 7 should display the last shadow copy, perhaps created when you last did Windows updates and Windows created a restore point. I suggest restoring the last known database and then creating a separate backup copy.

Finally, you can try copying the first places.sqlite database back to your profile folder, start Firefox, and see what's there. If that's not good, you can try the second copy you made and see how far that gets you.

If you create a lot of bookmarks, and the restored shadow copy is not up-to-date, you can use the bookmark restore feature to catch it up. That feature is described in this article: Restore bookmarks from backup or move them to another computer.

Let us know the results.

Let's say hypothetically that you were able to rescue a "good" (pre-delete) history database. Let's hold that thought and do something else first. Keep your profile folder open, exit Firefox, then wait for the files to be updated. Right-click the places.sqlite file > Properties > Previous Versions tab. Windows 7 should display the last shadow copy, perhaps created when you last did Windows updates and Windows created a restore point. I suggest restoring the last known database and then creating a separate backup copy. Finally, you can try copying the first places.sqlite database back to your profile folder, start Firefox, and see what's there. If that's not good, you can try the second copy you made and see how far that gets you. If you create a lot of bookmarks, and the restored shadow copy is not up-to-date, you can use the bookmark restore feature to catch it up. That feature is described in this article: [[Restore bookmarks from backup or move them to another computer]]. Let us know the results.

Question owner

do i go to the firefox box , click on that, then the dropdown box will appear, next should i scroll down and click on "web developer" to get to profile  ??? IS THIS HOW I DO IT  ??

do i go to the firefox box , click on that, then the dropdown box will appear, next should i scroll down and click on "web developer" to get to profile ??? IS THIS HOW I DO IT ??
jscher2000
  • Top 10 Contributor
8758 solutions 71663 answers

The Help menu is available in two places depending on whether you use the Menu Bar or the compact menus. To open your profile folder:

orange Firefox button > Help > Troubleshooting Information > "Show Folder" button

Tools menu > Help > Troubleshooting Information > "Show Folder" button

The "Web Developer" tools are not needed for that.

The Help menu is available in two places depending on whether you use the Menu Bar or the compact menus. To open your profile folder: orange Firefox button > Help > Troubleshooting Information > "Show Folder" button Tools menu > Help > Troubleshooting Information > "Show Folder" button The "Web Developer" tools are not needed for that.