X
Tap here to go to the mobile version of the site.

Support Forum

After upgrade to 10.6, font in text boxes is italic.

Posted

I recently upgraded two Macbooks from Leopard (10.5) to Snow Leopard (10.6). With just one of the laptops, now when I type in text boxes (not the ones that seem to specify a font in their style), like the body of an email in Outlook Web Access or the body of a message using a web form, the font is in italics. The other laptop is fine. Note that this doesn't happen in Safari or Chrome, only Firefox. I started with Firefox 16 and moved to 18 - that did not solve the problem (so I didn't bother with an uninstall since 18 was a clean install). I opened up my version 12 and the problem wasn't there, so it is only with later versions.

Also - this is not where everything is italics, like in other posts. It is only in text boxes.

I have tried resetting my font settings in Firefox, replacing the Arial font on the laptop with the one from the other laptop, and clearing the font cache. I installed the fontinfo addon, and it shows the same font used as the other laptop - nothing weird.

What can I do to make Firefox act correctly like it does on the other laptop?

Thanks.

I recently upgraded two Macbooks from Leopard (10.5) to Snow Leopard (10.6). With just one of the laptops, now when I type in text boxes (not the ones that seem to specify a font in their style), like the body of an email in Outlook Web Access or the body of a message using a web form, the font is in italics. The other laptop is fine. Note that this doesn't happen in Safari or Chrome, only Firefox. I started with Firefox 16 and moved to 18 - that did not solve the problem (so I didn't bother with an uninstall since 18 was a clean install). I opened up my version 12 and the problem wasn't there, so it is only with later versions. Also - this is not where everything is italics, like in other posts. It is only in text boxes. I have tried resetting my font settings in Firefox, replacing the Arial font on the laptop with the one from the other laptop, and clearing the font cache. I installed the fontinfo addon, and it shows the same font used as the other laptop - nothing weird. What can I do to make Firefox act correctly like it does on the other laptop? Thanks.

Additional System Details

Installed Plug-ins

  • Version 3.19.1.13088
  • Google Talk Plugin Video Accelerator version:0.1.44.28
  • Office Live Update v1.0
  • Shockwave Flash 10.3 r183
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • Coupons Inc., Coupon Printing FireFox Plugin
  • 5.1.10411.0
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • npmnqmp 071706000001
  • Plug-in for Starfield utilities
  • DivX Web Player version 2.0.0.263
  • Yahoo! Installer Plug-in provides application installation support

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:12.0) Gecko/20100101 Firefox/12.0

More Information

{"libraryVersions": {"NSSSMIME": {"minVersion": "3.14.1.0 Basic ECC", "version": "3.14.1.0 Basic ECC"}, "NSSUTIL": {"minVersion": "3.14.1.0", "version": "3.14.1.0"}, "NSS": {"minVersion": "3.14.1.0 Basic ECC", "version": "3.14.1.0 Basic ECC"}, "NSSSSL": {"minVersion": "3.14.1.0 Basic ECC", "version": "3.14.1.0 Basic ECC"}, "NSPR": {"minVersion": "4.9.4", "version": "4.9.4"}}, "javaScript": {"incrementalGCEnabled": true}, "accessibility": {"forceDisabled": 0, "isActive": false}, "application": {"userAgent": "Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:18.0) Gecko/20100101 Firefox/18.0", "supportURL": "http://support.mozilla.org/1/firefox/18.0/Darwin/en-US/", "version": "18.0", "name": "Firefox"}, "modifiedPreferences": {"browser.places.smartBookmarksVersion": 4, "network.cookie.prefsMigrated": true, "gfx.blacklist.webgl.msaa": 4, "print.print_unwriteable_margin_left": 13, "print.print_command": "", "print.print_unwriteable_margin_bottom": 50, "browser.places.importBookmarksHTML": false, "print.print_in_color": true, "places.last_vacuum": 1335409760, "print.print_shrink_to_fit": true, "font.size.variable.x-western": 15, "accessibility.typeaheadfind.flashBar": 0, "print.print_downloadfonts": false, "print.print_unwriteable_margin_top": 7, "browser.startup.homepage_override.mstone": "18.0", "print.print_oddpages": true, "browser.tabs.warnOnClose": false, "print.print_paper_data": 0, "browser.places.migratePostDataAnnotations": false, "print.print_margin_top": "0.5", "browser.tabs.onTop": false, "print.print_orientation": 0, "print.print_margin_right": "0.5", "browser.startup.homepage": "http://my.yahoo.com/", "privacy.sanitize.migrateFx3Prefs": true, "browser.places.importDefaults": false, "print.print_paper_height": " 11.00", "security.warn_viewing_mixed": false, "browser.places.leftPaneFolderId": -1, "print.print_scaling": " 1.00", "print.print_evenpages": true, "print.print_paper_size_type": 1, "browser.cache.disk.smart_size.first_run": false, "keyword.URL": "http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q=", "extensions.lastAppVersion": "18.0", "browser.history_expire_days.mirror": 180, "print.print_margin_left": "0.5", "browser.zoom.full": false, "browser.cache.disk.smart_size.use_old_max": false, "print.print_printer": "", "print.print_paper_width": " 8.50", "font.name.serif.x-western": "Arial", "print.print_pagedelay": 500, "print.print_unwriteable_margin_right": 13, "browser.cache.disk.capacity": 358400, "browser.startup.homepage_override.buildID": "20130104151948", "print.print_bgimages": false, "print.print_reversed": false, "font.name.sans-serif.x-western": "Arial", "print.print_margin_bottom": "0.5", "places.history.expiration.transient_current_max_pages": 53688, "dom.mozApps.used": true, "print.print_paper_size_unit": 0, "browser.cache.disk.smart_size_cached_value": 358400, "print.print_to_file": false, "places.database.lastMaintenance": 1367816944, "print.print_bgcolor": false, "browser.places.updateRecentTagsUri": false}, "extensions": [{"version": "2.2.4", "name": "Adblock Plus", "isActive": true, "id": "{d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}"}, {"version": "4.9.15", "name": "DownloadHelper", "isActive": true, "id": "{b9db16a4-6edc-47ec-a1f4-b86292ed211d}"}, {"version": "1.5.5.4", "name": "FlashGot", "isActive": true, "id": "{19503e42-ca3c-4c27-b1e2-9cdb2170ee34}"}, {"version": "0.2", "name": "Font Information", "isActive": true, "id": "{70ded480-0a45-4099-84d1-65aa1cb1575e}"}, {"version": "1.0.3.3", "name": "GMarks", "isActive": true, "id": "{A64F9D1E-FA5E-11DA-A187-6B94C2ED2B83}"}, {"version": "1.8.5", "name": "Google Docs Viewer", "isActive": true, "id": "adonis.cuhk@gmail.com"}, {"version": "1.2", "name": "oldbar", "isActive": true, "id": "{46868735-c3fa-47ce-8ce7-cce51a66aceb}"}, {"version": "0.8.1", "name": "PDF Viewer", "isActive": true, "id": "uriloader@pdf.js"}, {"version": "0.9", "name": "Print/Print Preview", "isActive": true, "id": "{19EB90DC-A456-458b-8AAC-616D91AAFCE1}"}, {"version": "2013.02.16.23", "name": "Status-4-Evar", "isActive": true, "id": "status4evar@caligonstudios.com"}, {"version": "1.1a", "name": "Troubleshooter", "isActive": true, "id": "troubleshooter@mozilla.org"}, {"version": "0.1.3", "name": "Bookmark Toolbar Icons", "isActive": false, "id": "bookmarktoolbaricons@myk.melez"}, {"version": "1.1.3", "name": "Firefox PDF Plugin for Mac OS X", "isActive": false, "id": "colesbury@gmail.com"}, {"version": "0.6.4.3", "name": "Gmail Notifier", "isActive": false, "id": "{44d0a1b4-9c90-4f86-ac92-8680b5d6549e}"}], "graphics": {"info": {"AzureContentBackend": "none", "AzureCanvasBackend": "quartz", "AzureFallbackCanvasBackend": "none"}, "driverVersion": "", "driverDate": "", "numAcceleratedWindows": 1, "windowLayerManagerType": "OpenGL", "adapterVendorID": "0x8086", "webglRenderer": "Intel Inc. -- Intel GMA X3100 OpenGL Engine", "adapterDrivers": "", "adapterDeviceID": "0x2a02", "numTotalWindows": 1, "adapterDescription": "", "adapterRAM": ""}}

iamjayakumars 489 solutions 5951 answers
Create a new profile as a test to check if your current profile is causing the problems. See "Creating a profile": *https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles *http://kb.mozillazine.org/Standard_diagnostic_-_Firefox#Profile_issues Profile Backup and Restore *http://kb.mozillazine.org/Profile_backup *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *http://kb.mozillazine.org/Transferring_data_to_a_new_profile_-_Firefox
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157453 answers

You can do a check for corrupted and duplicate fonts and other font issues:

You can do a check for corrupted and duplicate fonts and other font issues: *http://www.thexlab.com/faqs/multipleappsquit.html - Font Book 2.0 Help: Checking for damaged fonts *http://www.creativetechs.com/iq/garbled_fonts_troubleshooting_guide.html

Question owner

Thanks. I already had done the corrupt and dupe fonts check and it didn't work. I will try the second profile later on.

Thanks. I already had done the corrupt and dupe fonts check and it didn't work. I will try the second profile later on.

Question owner

Hi. I one-upped the second profile and actually created a second Mac profile that would create a new Firefox profile. With v18, the font is still italic; with v12 it is not. So it isn't a corrupt profile - Mac or Firefox.

Hi. I one-upped the second profile and actually created a second Mac profile that would create a new Firefox profile. With v18, the font is still italic; with v12 it is not. So it isn't a corrupt profile - Mac or Firefox.
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157453 answers

You can do a font test to see if you can identify corrupted font(s).

Is there a proportional font used or a fixed (mono-space) font?

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Firefox > Preferences > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"
You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1 Is there a proportional font used or a fixed (mono-space) font? You can try different default fonts and temporarily disable website fonts to test the selected default font. *Firefox > Preferences > Content : Fonts & Colors > Advanced *[ ] "Allow pages to choose their own fonts, instead of my selections above"

Question owner

Thanks. Like I said above, I had already checked for corrupt and dupe fonts. That already tried different fonts as the default font and Allow pages is checked (but I tried with it unchecked too). No luck.

Thanks. Like I said above, I had already checked for corrupt and dupe fonts. That already tried different fonts as the default font and Allow pages is checked (but I tried with it unchecked too). No luck.
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157453 answers

This is likely a problem with the font that is used for the check-boxes, but it may not be easy to find out which font is used.

You can try to right-click in such a text area and open the built-in inspector (Inspect Element). Tick the box in the right pane that show the style rules to show the "Browser styles" and scroll down to the font-family to check which fonts are specified. You can also check the other font properties.

This is likely a problem with the font that is used for the check-boxes, but it may not be easy to find out which font is used. You can try to right-click in such a text area and open the built-in inspector (Inspect Element). Tick the box in the right pane that show the style rules to show the "Browser styles" and scroll down to the font-family to check which fonts are specified. You can also check the other font properties. *https://developer.mozilla.org/en/Web/CSS/font-family

Question owner

So, using OWA, I inspected every level of element from text form to table and found no code about any fonts at all on the style tab or anywhere. There were only specifications on width and color. One thing I did notice is that the field that has the problem is coded as <textarea> and the ones that do not are <input>

When looking at Chase Bank's comment form, there are some text specifications (one of which is crossed out). Regardless of whether I check or uncheck the boxes, my font stays italic. The fonts in the inspector are Arial, Sans serif - no mention of style or italic at all.

So, I don't think this is where the problem is or where it can be diagnosed.

If this was a computer font problem, wouldn't I have it with other browsers or even with Firefox 12? What does version 16 and later do different than 12 with font?

So, using OWA, I inspected every level of element from text form to table and found no code about any fonts at all on the style tab or anywhere. There were only specifications on width and color. One thing I did notice is that the field that has the problem is coded as <textarea> and the ones that do not are <input> When looking at Chase Bank's comment form, there are some text specifications (one of which is crossed out). Regardless of whether I check or uncheck the boxes, my font stays italic. The fonts in the inspector are Arial, Sans serif - no mention of style or italic at all. So, I don't think this is where the problem is or where it can be diagnosed. If this was a computer font problem, wouldn't I have it with other browsers or even with Firefox 12? What does version 16 and later do different than 12 with font?
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157453 answers

Did you place a check-mark to select "Browser styles" like I wrote above?

Otherwise you only see style rules that the website applies and not style rules that Firefox uses by default.

Did you place a check-mark to select "Browser styles" like I wrote above? Otherwise you only see style rules that the website applies and not style rules that Firefox uses by default.

Question owner

I did not see anything like that - a check box for browser styles specifically. On the far right, you could choose to see styles at every level of table code. In the results box, you could check and uncheck the fonts, if they were present.

I did not see anything like that - a check box for browser styles specifically. On the far right, you could choose to see styles at every level of table code. In the results box, you could check and uncheck the fonts, if they were present.

Question owner

Like right now, I just did the inspector on this page in FF on a different computer than the one having problems. The Inspector bar opens at the bottom. On the far right is Style. Then in the sidebar are the Rules or Computed. There is nothing for Browser anywhere.

Like right now, I just did the inspector on this page in FF on a different computer than the one having problems. The Inspector bar opens at the bottom. On the far right is Style. Then in the sidebar are the Rules or Computed. There is nothing for Browser anywhere.
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157453 answers

Which Firefox version are you using?

Did you already update to the current Firefox 21 release?

You should see this "Browser styles" check box in the "Computed" tab of the Style panel.

Which Firefox version are you using? Did you already update to the current Firefox 21 release? You should see this "Browser styles" check box in the "Computed" tab of the Style panel.

Question owner

No, I went up from 16 to 18, but have not gone any higher since the problem should not be there (it isn't there on the other laptop that has Snow Leopard). I also have learned never to update FF to quickly because they always release the next version before they have ironed out the bugs.

If the Browser Styles is supposed to be in the Computed, then not only is it not there, nothing at all is there for the Outlook form that I have been inspecting since it is a completely generic text box.

No, I went up from 16 to 18, but have not gone any higher since the problem should not be there (it isn't there on the other laptop that has Snow Leopard). I also have learned never to update FF to quickly because they always release the next version before they have ironed out the bugs. If the Browser Styles is supposed to be in the Computed, then not only is it not there, nothing at all is there for the Outlook form that I have been inspecting since it is a completely generic text box.

Question owner

Hi. I just looked at FF21 on a work PC (not Mac), and it has that checkbox. My PC has v16 and it does not have that box, but you can uncheck "user styles." I will compare that to the Macs at home and see if I get the same style choices that I am seeing on the PC version of FF.

Hi. I just looked at FF21 on a work PC (not Mac), and it has that checkbox. My PC has v16 and it does not have that box, but you can uncheck "user styles." I will compare that to the Macs at home and see if I get the same style choices that I am seeing on the PC version of FF.

Question owner

Ok, so I am back onto this issue. I have narrowed it down to some sort of change that FF made between the latest version of 12 (which is fine) and the first version of 13 (which shows italics). So, what changed? What does 13 and up do to the fonts that doesn't happen in earlier versions?

And nothing looks odd with the user styles.

And removing FF from the computer and reinstalling doesn't help either.

Ok, so I am back onto this issue. I have narrowed it down to some sort of change that FF made between the latest version of 12 (which is fine) and the first version of 13 (which shows italics). So, what changed? What does 13 and up do to the fonts that doesn't happen in earlier versions? And nothing looks odd with the user styles. And removing FF from the computer and reinstalling doesn't help either.
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157453 answers

You can use this extension to see which fonts are used for text that is selected (right-click: "Show fonts in selection").

You can do a font test to see if you can identify corrupted font(s).

You can use this extension to see which fonts are used for text that is selected (right-click: "Show fonts in selection"). *fontinfo: https://addons.mozilla.org/firefox/addon/fontinfo/ You can do a font test to see if you can identify corrupted font(s). *http://browserspy.dk/fonts-flash.php?detail=1

Question owner

Thanks.

I had already done a corruption check at the beginning but I used your link again. I don't see anything corrupt. And if a font was corrupt, it would also be corrupt in FF 12.

I also tried the add-on, but it won't work with a text box. After I type in the box (and it shows up as italics), I can select it and right-click, but that option isn't there. I can use the add-on for text embedded in the page though.

Again, what is different between FF12 and earlier and FF13 and later in how it handles fonts in text boxes? Do I need to use bugzilla at this point since I want an answer from mozilla?

Thanks. I had already done a corruption check at the beginning but I used your link again. I don't see anything corrupt. And if a font was corrupt, it would also be corrupt in FF 12. I also tried the add-on, but it won't work with a text box. After I type in the box (and it shows up as italics), I can select it and right-click, but that option isn't there. I can use the add-on for text embedded in the page though. Again, what is different between FF12 and earlier and FF13 and later in how it handles fonts in text boxes? Do I need to use bugzilla at this point since I want an answer from mozilla?
cor-el
  • Top 10 Contributor
  • Moderator
17424 solutions 157453 answers

You can use the built-in Inspector (Firefox/Tools > Web Developer;Ctrl+Shift+I) to see which fonts are used.

You can use the built-in Inspector (Firefox/Tools > Web Developer;Ctrl+Shift+I) to see which fonts are used.

Question owner

Hi. If you read above, that was already suggested, and I already tried that. There were no fonts indicated for the text blocks that are showing as italics. All my default fonts are the same as on other computers that do not have this problem since upgrading to 10.6.8. I even replaced the fonts on this computer with copies from another in case that would help.

Hi. If you read above, that was already suggested, and I already tried that. There were no fonts indicated for the text blocks that are showing as italics. All my default fonts are the same as on other computers that do not have this problem since upgrading to 10.6.8. I even replaced the fonts on this computer with copies from another in case that would help.

Question owner

Just moved my last Leopard Mac to Snow and this one has the same problem with italics text in standard text boxes. So out of three, two have this problem. Deleting all instances of Firefox and reinstalling does not solve the problem. There are no instances of corrupt fonts. It is very bothersome though. What is wrong with the newer versions of Firefox? (The old ones do not have this issue).

Just moved my last Leopard Mac to Snow and this one has the same problem with italics text in standard text boxes. So out of three, two have this problem. Deleting all instances of Firefox and reinstalling does not solve the problem. There are no instances of corrupt fonts. It is very bothersome though. What is wrong with the newer versions of Firefox? (The old ones do not have this issue).