Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

My PC crashes whenever and only, when I am in a Firefox window. I have tried just about every version, including 20.0.1. The only stable version is 3.6.28.

  • 62 replies
  • 95 have this problem
  • Last reply by runfrodorun

more options

The PC hangs completely, no keyboard or mouse response. The system is very stable and never crashes when not using firefox. The only version which works without crashing the PC is 3.6.28, but this has a few rendering problems and some websites don't display properly. I have turned on crash reporting, but it never produces a report. I have done a firefox reset, but makes no difference. The system never stays up for more than 10 minutes. I have turned off hardware acceleration. What do you need from me to help identify the cause?

All Replies (20)

more options

We're sorry to hear that Firefox is crashing. In order to assist you better, please follow the steps below to provide us crash ID's to help us learn more about your crash.

  1. Enter about:crashes in the address bar (that's where you enter your website URL) and press Enter. You should now see a list of submitted crash reports.
  2. Copy the 5 most recent crash ID's that you see in the crash report window and paste them into your response here.

Thank you for your cooperation!

More information and further troubleshooting steps can be found in the Troubleshoot Firefox crashes (closing or quitting unexpectedly) article.

more options

I think the PC crashes before FF has a chance to produce a report. Here is the result of 'about:crashes' :- 'No crash reports have been submitted.'

more options

Certain Firefox problems can be solved by performing a Clean reinstall. This means you remove Firefox program files and then reinstall Firefox. Please follow these steps:

Note: You might want to print these steps or view them in another browser.

  1. Download the latest Desktop version of Firefox from and save the setup file to your computer.
  2. After the download finishes, close all Firefox windows (click Exit from the Firefox or File menu).
  3. Delete the Firefox installation folder, which is located in one of these locations, by default:
    • Windows:
      • C:\Program Files\Mozilla Firefox
      • C:\Program Files (x86)\Mozilla Firefox
    • Mac: Delete Firefox from the Applications folder.
    • Linux: If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.
  4. Now, go ahead and reinstall Firefox:
    1. Double-click the downloaded installation file and go through the steps of the installation wizard.
    2. Once the wizard is finished, choose to directly open Firefox after clicking the Finish button.

Please report back to see if this helped you!

more options

Hello rnewfie, try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) and check firefox again.

(If works in Windows Safe mode then you have a problem with other software, like security software or maybe a system driver, that is running on your computer).

thank you

more options

Have just done a clean install of 20.0.1 exactly as per the instructions above. I didn't uninstall first as that was not mentioned. It crashed after about 15 minutes, which is better than normal!, but it is still flakey. I am now testing in safe mode - I will report back.

more options

Did Firefox generate a crash report this time when it crashed?

more options

No, sorry. Still testing in safe mode - No problems after 20 odd minutes.

more options
more options

Current status :- No crash reports ever created.

The only way firefox runs for more than around 10 minutes is to run in safe mode. Based on that, I have been looking at the graphics side of the system, so I have done the following :- 1) BIOS modes changed, various options. 2) Disabled all graphics hardware acceleration in Windows. 3) Disabled BIOS graphics hardware acceleration. 4) Changed adapter driver from MSI RX9250 to Radeon 9250. 5) Installed Catalyst drivers with 'crash-guard' enabled. 6) Disabled hardware acceleration in firefox. 7) Disabled webgl in firefox.

I am currently still in safe mode and no problems - Why does safe mode fix this, bearing in mind that the problem doesn't now seem to be graphics related?

more options

See 'current status' above, but additionally, I have installed a different video driver and based on some reports of 'suspect memory', I have run a full memory diagnostic, which passed perfectly. I have also run FF in 'safe mode', which still crashes and both disabled and uninstalled Adblock Plus. Why is it that the only stable of FF was 3.6.28 which was only released just a year ago? Why is FF now in release 20? 17 releases in just over a year! It would appear that the developers have lost control of this product.

more options

Have you tried using a Fresh profile? Profile Manager - Create, remove or switch Firefox profiles

more options

I tried using a new profile a few days ago - no difference. Basically, ANY version from 4.0 upwards only runs without crashing my PC for 15 minutes max. I have gone back to 3.6.28 and have been using it off and on all day - not one problem. What significantly changed after 3.6.28 to make this product unuseable?

more options

And if you disable graphics acceleration it doesn't stop the crashing?

more options

Why does safe mode fix this, bearing in mind that the problem doesn't now seem to be graphics related?

According to the MozillaZine Safe Mode article:

  • Safe Mode temporarily affects the following:

All extensions are disabled.
The default theme is used, without a persona.
The Just-in-time (JIT) JavaScript compiler is disabled.
The userChrome.css and userContent.css files are ignored.
The default toolbar layout is used.
Hardware acceleration is disabled.

  • Safe Mode has no effect on the following:

The status of plugins is not affected.
Custom preferences are not affected.

more options

Correct. I have had hardware acceleration turned off throughout testing.

more options

'Safe Mode temporarily affects the following:
All extensions are disabled. I have no extensions installed anyway.
The default theme is used, without a persona. Not sure what effect that has.
The Just-in-time (JIT) JavaScript compiler is disabled. Not sure what effect that has.
The userChrome.css and userContent.css files are ignored. Not sure what effect that has.
The default toolbar layout is used. I did notice that, but why would that stop it crashing?
Hardware acceleration is disabled. I have that turned off anyway.
I am not sure if it is relevant, but all of the plugins I have installed - Shockwave Flash for example, are all disabled.

added line breaks

Modified by John99

more options

Let's compare Safe Mode and the new profile.

The new profile would have no extensions (unless pushed by an external application), special theme, userChrome.css, userContent.css, or toolbar customizations. So I think we can set those aside. That leaves the JavaScript compiler issue and hardware accelerated graphics as the key changes in Safe Mode.

I think you can manually disable the JIT in about:config by toggling some settings but I haven't found a definitive list.

more options

To be honest, I am not sure exactly what that means, but I uninstalled FF completely, then removed the Documents and Settings\'user'\Application Data\Mozilla folder, then did a clean install of FF 20. Turned off Acceleration. Result - It crashes between 10 and 15 minutes of use. I am back on FF 3.6.28 and have been using it with no problems for 2 days now.

more options

Still running 3.6.28. I have also re-installed adblock plus version 2.0.3. No problems all morning.

more options

Looks like this little problem has baffled everyone!

  1. 1
  2. 2
  3. 3
  4. 4