Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how do I change the date format in firefox


I am using firefox on my Samsung tablet and I cannot find anywhere in settings that will allow me to change the date forkmat to the european date setting. Can anyone help me out please?

Additional System Details


  • User Agent: Mozilla/5.0 (Android; Tablet; rv:19.0) Gecko/19.0 Firefox/19.0

More Information

  • Top 10 Contributor
413 solutions 4901 answers

Sorry, Its not Related to Mozilla Support....

Settings > System > Date and Time

Uncheck the

  • "Automatic date and Time"
  • "Automatic time zone"

Change the "select date format"

  • Top 25 Contributor
  • Moderator
247 solutions 1741 answers

Where are you seeing dates inside Firefox? If it is on a website, that is the responsibility of the website developer.

Landis 0 solutions 4 answers

he/she seems to be asking how to change the date format in firefox, not his tablet. firefox usest US date format regardless of system settings which sucks.

eg. bookmark backups are date formatted YYYY-MM-DD and bookmarks 'added' date are MM/DD/YYYY and my, his systems are DD.MM.YYYY.

Firefox refuses to conform to the system's date format.

That's what argusmac was, is asking.


p.s., there is a preference setting for Thunderbird, but doesn't work in firefox. http://kb.mozillazine.org/Date_display_format some say they've gotten it to work by setting prefs in about:config) (local and languages to en_GB instead of 'default' en_US (sometimes en-GB), but it hasn't worked for me in the most important way, the naming of bookmark backup files. From what I can find, Firefox will Only use the UTC date YYYY-MM-DD. I've installed nightly GB and RU versions and the date format for bm backups for instance remain ISO/UTC... sucks. there is an addon that will add time / date to addonbar (bottom bar) that you can format date as you like [ https://addons.mozilla.org/en-US/firefox/addon/statusbardate/ ]

colindavidfoster 0 solutions 1 answers

See this link

Seems to be a shortcoming of the Firefox installer, i.e. the installer should choose the most appropriate language based on your regional settings.

Modified by colindavidfoster