X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

i want to stop ads appearing at the side and bottom all the time, this is a reccent delvelopment and i hate it

Posted

im using firefox 18 on a macbook pro running mountain lion. since the last firefox upgrade i get annoying ads at the side and bottom of the page. these have to be manually turned off by clicking the little x but are so peristent im beginning to use safari instead as they are so annoying, ther must be some way of just stopping this? help!

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Amazon MP3 Downloader Plugin 1.0.17
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • iPhoto6
  • DivX Web Player version 2.1.1.94
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • DivX Content Upload Plug-In: Uploads DivX video in your browser!

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Andrew
  • Top 25 Contributor
  • Moderator
251 solutions 3016 answers

What are the ad's saying? Do you have any add-ons causing this?

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

finitarry 157 solutions 2177 answers

Did you get your version of Firefox from Mozilla? You should really get it from the source, not from a third party. Have you tried using Adblock Plus with a subscription?