X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

How do i get rid permanently of a Tab that opens up to download something for Android Mobile when I open Firefox to use Google?

Posted

When I want to Open Mozilla to use google which is my default search for the WWW I get Mozilla wanting me to Download something. I don't because I don't use Moble or Android. I get angry because I have to click it off and i have filled with the Tabs which i know nothing about and wish I didn't have any because i don't mind just using my Bookmarks and clicking them off when i have finished. Please tell me because this has only happened recently without my permission. Bette

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

meter1060 3 solutions 27 answers

Hi, can you provide more information? Are you seeing a link to download Firefox for android on your start screen for desktop Firefox? If so that's expected behaviour. If you want to not have that show up you could make google.com your homepage, which can easily be done by dragging this link (google) up to the home button (the little house that should be on your top right)

Modified by meter1060

Question owner

Google is my Home Page but it comes up as a Tab at the same time and it says connecting and oit then opens up before google and i have to click it off.

Question owner

I don't use I Pads or phones and mobiles where I want to Download anything from Firefox for such items.

meter1060 3 solutions 27 answers

Helpful Reply

Try going going to options and making sure your homepage just says google.com and also under the heading of when nightly starts make sure it just says show my homepage.

Question owner

I had that all set as you suggested and it makes no difference at all. In fine print at the bottom of the Page it says it is conjunction with Google. They bothe open up as Tabs together. Maybe I should not have a Tabs Bar and see what that does. It is annoying that i have to accept something I don't want and didn't put in. Why doesn't Firefox answer the question themselves.

Cashout 0 solutions 7 answers

Helpful Reply

UPDATE, I SOLVED THIS SAME PROBLEM. INFO WHAT I DID, BELOW. CASHOUT.

I also get this same nagging to download FF for Android. I even watched the video clip hopeing it would remove itself. I've clicked the tab off over 200 times and am also aggravated. I love Mozilla, love Firefox but this is the kind of thing Google is inconsiderate about. PLEASE HELP, give us a way to remove this nagging. It will be appreciated by thousands who read these pages.

Modified by Cashout

Question owner

I think it is because it the latest Version of Firefox and it all goes to a page of Tabs and every thing you do is on there. they say you just go to the tabs instead of the bookmarks. Now I have the Firefox Personas doing the same thing. Sorry but i think we have to grin and bear it and just keep hitting the X. Bette

Question owner

Done all that and no difference. It is the latest version of Firefox. I still would not use Internet Explorer though not safe.

cor-el
  • Top 10 Contributor
  • Moderator
10755 solutions 96800 answers

See these articles for some suggestions:

Try to use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

If you do not keep changes after a restart then see:

Cashout 0 solutions 7 answers

I SOLVED MY PROBLEM with the tools that Cor-el provided above. In my earlier post, after updating to FF 19, my problem was I couldn't keep a "nag" window turned off permanently . Similar to this threads key problem.

The way an info window should work is, it displays itself once then never comes back to nag you once it's been seen. The FF preferences should have avoided opening it ever again. On my new installation, FF wanted to tell me about Android which became a "nag" again and again because Firefox was unable to save the preferences to SHUT IT OFF.         A week before  I had a problem with malware that must have changed my FF preferences to not save.

Cor-el gave me this site above= link text which said one solution is to RESET FF PREFERENCES, which is what I did which solved this problem and several others I was having. The following was re-edited for clarity.

I use XP-Sp3. To reset FF version 19, using XP, I did the following, - -

  1. In FF 19 menu bar, click once on --"HELP".
  2. in the drop down menu click once on--"Restart with add-ons disabled".
  3. a menu window opens--click once on "Restart".
  4. an open in safe mode window opens,-- click once on the "Reset Firefox".
  5. I closed FF and re-opened it which came up on FF start page, no extra nag page. It also cleaned up other issues I was having with FF.

BEWARE, the reset notice said, YOU WILL LOSE BOOKMARKS, & ADD-ON EXTENSIONS, but they auto-back-them-up for you to the desktop. When I restarted FF the bookmarks were auto- reinstalled for me and I just had to install the extensions myself. (it doesn't effect the plugins). I was Leary that I would lose my bookmarks, so, prior to doing anything, I exported a bookmark copy to my documents just in case of a problem. I also wrote down the extensions names for an easy install.

I'm glad I took this approach, it took 10 mins., it fixed other issues, and it was a safe route that didn't take me out of my comfort zone. Thank Cor-el for pointing me in the right direction.

I HOPE THIS HELPS OTHERS. CASHOUT

Modified by Cashout

Question owner

I downloaded that Search reset and I must say I was not sure bout i. I have Windows 7 but anyway it made no difference so I removed it. Now I have another pesty one. I like the Personas but now they are coming on ia a Tab also. I feel like taking Firefox out and reinstalling but honestly i don't know enough about Tabs etc., Bye the way where do i get the Preferences? to look at what goes on there? This is so frustrating.

Cashout 0 solutions 7 answers

Hardybette, I use XP-Sp3. The pathway to the HELP menu might be different, I'm not familiar with Win7. It isn't "search reset" that you click, it's "RESET FIREFOX".

To reset FF useing XP, I did the following, - -

  1. In FF 19 menu bar, click once on --"HELP".
  2. in the drop down menu click once on--"Restart with add-ons disabled".
  3. a menu window opens--click once on "Restart".
  4. an open in safe mode window opens,-- click once on the "Reset Firefox".
  5. I closed FF and re-opened it which came up on FF start page, no extra nag page. It also cleaned up other issues I was having with FF.

BEWARE, the reset notice said, YOU WILL LOSE BOOKMARKS, & ADD-ON EXTENSIONS, but they auto-back-them-up for you to the desktop. When I restarted FF the bookmarks were auto- reinstalled for me and I just had to install the extensions myself. (it doesn't effect the plugins). I was Leary that I would lose my bookmarks, so, prior to doing anything, I exported a bookmark copy to my documents just in case of a problem. I also wrote down the extensions names for an easy install.

I'm glad I took this approach, it took 10 mins., it fixed other issues, and it was a safe route that didn't take me out of my comfort zone. Thank Cor-el for pointing me in the right direction.

I HOPE THIS HELPS OTHERS. CASHOUT

Cashout 0 solutions 7 answers

Hardybette, I use XP-Sp3. The pathway to the HELP menu might be different, I'm not familiar with Win7. It isn't "search reset" that you click, it's "RESET FIREFOX".

To reset FF in XP, I did the following, - - step 1- in FF 19 menu bar, click once on --"HELP". in the drop down menu click once on--"Restart with add-ons disabled" ,

and clicked the RESET button.

step 2- closed FF and re-opened it which came up on FF start page, no extra nag page and cleaned up other issues I was having.