X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

firefox not rendering Google Plus buttons but can mouseover them

Posted

This has been a problem since the 15 release. On Google + pages, all of the html prompts/buttons are invisible. I can mouse over them and get a popup prompt to click, but the actual graphics are missing. Google + and Gmail are the only pages that do this. I have went into Options and allowed web pages to load their own fonts and colors but that did not solve the problem.

As you can see from the graphic below, the buttons/prompts are noted in Chrome with a black dot but in Firefox 18.0.1, they are not. I have to move my mouse slowly in order to find where to click. Please pardon the link to the graphic as I am not seeing how to add a screenshot.

https://docs.google.com/file/d/0B2bdSLJMw_v1ejEtYUV3azJUdFk/edit?usp=sharing

Modified by helios17

Chosen solution

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.image pref should be 1.

Make sure that you haven't enabled a High Contrast theme in the Windows Accessibility settings and that you allow pages to choose their colors in Firefox.

There are also extensions like Adblock Plus (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Java plug-in for NPAPI-based browsers.
  • Shockwave Flash 11.2 r202
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.
  • Gecko Media Player 0.9.9.2Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Top 25 Contributor
  • Administrator
  • Moderator
1166 solutions 6653 answers

Have you tried the steps at Websites look wrong or appear differently than they should

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97036 answers

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

Question owner

My apologies...I did not see a "add image" option on my first post. It is in line or attached

Question owner

Tyler I have, every one of them, and no joy with any of them. That's why I decided to come to people smarter than me.  ;-)

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97036 answers

Chosen Solution

If images are missing then check that you aren't blocking images from some domains.

  • Check the permissions for the domain in the current tab in "Tools > Page Info > Permissions"
  • Check that images are enabled: Tools > Options > Content: [X] Load images automatically
  • Check the exceptions in "Tools > Options > Content: Load Images > Exceptions"
  • Check the "Tools > Page Info > Media" tab for blocked images (scroll through all the images with the cursor Down key).

If an image in the list is grayed and there is a check-mark in the box "Block Images from..." then remove that mark to unblock the images from that domain.

Make sure that you do not block third-party images, the permissions.default.image pref should be 1.

Make sure that you haven't enabled a High Contrast theme in the Windows Accessibility settings and that you allow pages to choose their colors in Firefox.

There are also extensions like Adblock Plus (Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also:

Question owner

cor-el, thank you. Some of this I have done, but others I have not. I will run through this list when I get home this evening and see if I can't get it straighened out. There are several people in my G+ circles complaining about this very same thing, so instead of just blaming an API issue, I checked here first. I will post back as soon as I get all of these things checked/done.

Question owner

Solved.

Under page info, when I opened it under my google+ page, I clicked media and at the bottom was "Block Images from ssl.gstatic.com". That confused me a bit because when I had opened page info earlier on that page it mentioned block images from google/user/somethingorother. At any rate, everything is fixed on both Gmail and Google Plus.

Thanks a bunch. This was driving me nuts.

cor-el
  • Top 10 Contributor
  • Moderator
10783 solutions 97036 answers

Helpful Reply

You're welcome.