X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox not showing page after upgrading from Windows 7 to 8

Posted

Hi all, I have Firefox 18.0.1 installed in Windows 7 system. It was working fine. Yesterday when I have upgraded my OS to Windows 8 pro. Firefox stop working :(. If I try to enter the link in the address bar , there will be refresh and the page will not be loaded and also in Toolbar get resetted also. I tried to uninstall/install firefox. Also Uninstall Mcafee . Also allowed the firefox in the firewall setting. But no success . Please help me if I have missing or need something to make it work.

Initially IE 10 was also not working in Desktop mode and it was working with metro UI IE. Finally found one fix to enable: Enable Enhanced Protection Mode

It's difficult to browse without Firefox.

Chosen solution

I was able to solve the problem, by resetting the windows 8 without affecting files and settings: [Resetting Windows 8 without resetting files]
May be some setting stopping Firefox from accessing the internet.

Waiting for FIrefox to open in MetroUI :)

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; Win64; x64; Trident/6.0; .NET4.0E; .NET4.0C; .NET CLR 2.0.50727; .NET CLR 3.0.30729; .NET CLR 3.5.30729; Media Center PC 6.0; SLCC2)

More Information

iamjayakumars
  • Top 10 Contributor
414 solutions 4905 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

Thanks for reply. I have done reset as you have mentioned , but still it is not working.:(

iamjayakumars
  • Top 10 Contributor
414 solutions 4905 answers

Try the Firefox Safe Mode to see how it works there. The Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open the Firefox 4.0+ Safe Mode by holding the Shift key when you use the Firefox desktop or Start menu shortcut.
  • Or use the Help menu item and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Don't select anything right now, just use "'Start in Safe Mode" To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before using the Firefox shortcut (without the Shift key) to open it again. If it is good in the Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one.

Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Question owner

Hi, I have no addons installed. I started firefox as fresh . But still no success :(. I have also disabled the Use hardware acceleration whenever disabled. But still Firefox is not able to show the webpages.:(

cor-el
  • Top 10 Contributor
  • Moderator
10744 solutions 96671 answers

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.


A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

Question owner

Hi , Thanks for the help. I tried to disable the firewall still same issue. I have remove the Firefox from the firewall application list . Still no success. My system is 64 bit. I have tried to troubleshoot through windows , it saying it is incompatible version. Attaching the screenshot. [ hidden my user name] Is there any way I can check the log why it is not loading the webpages .

Chosen Solution

I was able to solve the problem, by resetting the windows 8 without affecting files and settings: [Resetting Windows 8 without resetting files]
May be some setting stopping Firefox from accessing the internet.

Waiting for FIrefox to open in MetroUI :)

Modified by cor-el