X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how do i stop firefox from going derectly to the website? I want it to go to google.

Posted

Can someone please help. Every time I search it takes me to the website. I want to be able to search and go to google.

Chosen solution

I want to be able to perform web searches right from the address bar. Just type in your search terms and hit Enter. Firefox will take you to the Google search results page. I want to be able to do this.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • Google Update
  • SiteAdvisor
  • iTunes Detector Plug-in
  • RealJukebox Netscape Plugin
  • RealNetworks(tm) RealPlayer Chrome Background Extension Plug-In
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealPlayer Download Plugin
  • Next Generation Java Plug-in 10.9.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.6.636
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.5.635
  • 5.1.10411.0
  • NPWLPG
  • CANON iMAGE GATEWAY Album Plugin Utility Module
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

iamjayakumars
  • Top 10 Contributor
412 solutions 4877 answers

In order to change the default search engine or the order of search engines in the top right search box in Firefox, please perform the following steps:

  1. Move the mouse cursor inside the search box at the top right of the Firefox window and click the down arrow next to the provider's logo.
  2. If you would like to select another search engine, simply pick the engine from the dropdown list.

In order to change the order of the search engines, do this:

  1. From the dropdown list, select Manage Search Engines....
  2. In the upcoming window, you have all your search engines listed. To change the order, simply click one search engine and then select Move up or Move down from the buttons on the right side in order to change the order of the search engines.
iamjayakumars
  • Top 10 Contributor
412 solutions 4877 answers

When you enter a search term in the Firefox location bar and press Enter, Firefox will per default do a "I'm feeling lucky" Google search and redirect you to the first result that matches your search term. This behaviour can be changed by a number of add-ons. If you'd like to restore the previous default behaviour, please follow these steps:

  1. Enter about:config in the Firefox location bar and press Enter.
  2. You should see a warning that making changes to the Firefox configuration can be potentially harmful to Firefox's integrity. Click the I'll be careful, I promise button to continue.
  3. In the Search box at the top, enter keyword as the search term. You should see a few remaining items, one of these is keyword.URL. It should be bold.
  4. Right-click on the keyword.URL setting and select Reset from the dropdown menu.

Now you're done. Please report back if this fixes your problem. Thanks in advance!

You can find more information about the Location bar search feature in the Search the web from the Address Bar article.

Chosen Solution

I want to be able to perform web searches right from the address bar. Just type in your search terms and hit Enter. Firefox will take you to the Google search results page. I want to be able to do this.

iamjayakumars
  • Top 10 Contributor
412 solutions 4877 answers

Check my first answer

GaelicGal 0 solutions 3 answers

Reset is grayed out, probably because its status is default and the value is blank. Since the default is "I'm feeling lucky", that's not what I want. I've never wanted that, and I think it's rude for Firefox to have changed that setting without asking. I want a list of search results, I do NOT want to be brought directly to a page.

I came back to edit this, because I read the document you provided. If someone asks to see a list of results, why don't you just say to change keyword.enabled to false by

1. In the Location bar, type about:config and press Enter.

       The about:config "This might void your warranty!" warning page may 
      appear. Click I'll be careful, I promise!, to continue to the about:config page. 
2.   In the Search field, type keyword.enabled.
3.    Double-click the keyword.enabled preference to set its value to false.

Modified by GaelicGal