X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

The websites can not be shown properly, other applications works fine, including Safari. So this is only Firefox problem.

Posted

3 days ago, Firefox has started to display weirdly. All pages showed diagonally with left side up and right side down. So all the letters are showed on a slant, all images smudged/collapsed. I can not read text and links seem to get out of (original) position.

For example, when I open Gmail and click 'compose' it won't work as the proper link to 'compose' is somewhere else than slanting letters showed 'compose'.

It's hard to explain, I have never had this kind of problem with any applications. Other applications works fine, including Safari works alright. I uninstalled and re-installed Firefox but no good. I still see slanting pages.

I use Mac OS X 10.6

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6; en-us) AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9

More Information

Application Basics
Name
Firefox
Version
18.0.1
User Agent
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:18.0) Gecko/20100101 Firefox/18.0
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Important Modified Preferences
Name
Value
browser.cache.disk.capacity
358400
browser.cache.disk.smart_size_cached_value
276480
browser.cache.disk.smart_size.first_run
false
browser.cache.disk.smart_size.use_old_max
false
browser.places.smartBookmarksVersion
4
browser.startup.homepage_override.buildID
20130116073211
browser.startup.homepage_override.mstone
18.0.1
extensions.lastAppVersion
18.0.1
gfx.blacklist.webgl.msaa
4
network.cookie.prefsMigrated
true
places.history.expiration.transient_current_max_pages
25875
privacy.sanitize.migrateFx3Prefs
true
Graphics
Device ID
0x 407
GPU Accelerated Windows
2/2 OpenGL
Vendor ID
0x10de
WebGL Renderer
NVIDIA Corporation -- NVIDIA GeForce 8600M GT OpenGL Engine
AzureCanvasBackend
quartz
AzureContentBackend
none
AzureFallbackCanvasBackend
none
JavaScript
Incremental GC
true
Accessibility
Activated
false
Prevent Accessibility
0
Library Versions
Expected minimum version
Version in use
NSPR
4.9.4
4.9.4
NSS
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSMIME
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSSSL
3.14.1.0 Basic ECC
3.14.1.0 Basic ECC
NSSUTIL
3.14.1.0
3.14.1.0

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96791 answers

Helpful Reply

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Try to disable hardware acceleration in Firefox.

Modified by cor-el

Helpful Reply

Hi there,

Thank you so much for your post.

I've tried safe mode and seemed it worked with it. So I made disable hardware as you suggested. Now Firefox is working perfectly as before!

Thank you again for your help! I really appreciate it as I had no idea what the problem was.

Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96791 answers

You're welcome.