X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

I cannot add www.google.com/calendar as an exception to the add-on warning preference in Firefox, which is preventing me using google calendar.

Posted

Recently, google calendar will not work properly on Firefox. I cannot create an event with my mouse, click on different parts of the calendar because Firefox is preventing google.com/calendar from creating add-ons. I currently have Firefox set to "warn me when sites attempt to install add-ons." When I remove that setting, google calendar works fine. But, I want that setting to be activated. When I attempt to add www.google.com/calendar as an exception, Firefox simply lists it as www.google.com, which does not allow for google calendar to work and I run into the same problems as before. Right now, the only workaround is to disable the "warn me when sites attempt to install add-ons," which I think is really silly that I'd have to do that just to use google calendar. Any thoughts?????

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.5 r502
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Picasa plugin.

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
10754 solutions 96785 answers

That setting should only have effect if you click a link to install an extension or want to check out a light weight theme (persona) and shouldn't prevent you from clicking links on web pages.

Are you sure that this is not about pop-ups or blocking JavaScript?

You can inspect and manage the permissions for all domains on the about:permissions page.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe mode start window or otherwise make changes.

Question owner

Hey! Thanks for your response. It's certainly possible that this may be about pop-ups or blocking JavaScript, but I know for certain that when I unchceck the "warn me when sites attempt to install add-ons," google calendar works as it should and I can add events directly into the calendar and click on the various buttons for the website. When it's enabled, google calendar does not work. At best, I can sometimes click the create event, but for the most part the page is dead and nothing seems to work.

I tried to follow your instructions about managing permissions and I could not locate www.google.com. There were on two websites listed in my permissions. I'm sure I'm missing something there.

I also tried the safe mode, but when I looked at the extensions I really had no idea what I'm supposed to be looking for or how to know what the problem is. My browser is already set to default appearance.

Sorry if I'm inept.

Modified by whiteyg

Question owner

Okay, I just reset Firefox and left that box checked. It seems to be working fine now. I guess I just needed to clean the cache, cookies, and add-ons etc. Thanks!