X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

Firefox doesn't display content, especially links.

Posted

This is my problem in a screenshot: http://d.pr/i/DjkB The content isn't displayed and especially links. Links are always not there and sometimes text is displayed but all websites are disfunctional because of this.

Here's a link to a screenshot displaying how the same website should look like: http://d.pr/i/ZRvN

Chosen solution

Hi again,

My problem was that since I'm on Linux and didn't install Microsoft fonts after I upgraded to Fedora 17 last year Firefox hasn't worked properly.

I needed to do 'wget http://www.my-guides.net/en/images/stories/fedora12/msttcore-fonts-2.0-3.noarch.rpm' in my terminal and then 'su -c 'rpm -ivh msttcore-fonts-2.0-3.noarch.rpm to install them.

Now I've got Arial, Verdana, Times New Roman, Trebushet MS, and a few others. But not Helvetica. It'd be best to find Helvetica font somewhere to be absolutly safe.

Thank you for your help.

Maybe it would be a good idea to have Firefox fetch fonts from a cdn on the internet if fonts on the website aren't installed on the clients system so that users can enjoy the web better?

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • Java plug-in for NPAPI-based browsers.
  • Google Talk Plugin Video Accelerator version:0.1.44.23
  • Version: 3.10.2.0
  • This plugin provides integration with Gnome Shell for live extension enabling and disabling. It can be used only by extensions.gnome.org
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

{
"application": {
"name": "Firefox",
"version": "18.0",
"userAgent": "Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0",
"supportURL": "http://support.mozilla.org/1/firefox/18.0/Linux/en-US/"
},
"modifiedPreferences": {
"accessibility.typeaheadfind.flashBar": 0,
"browser.cache.disk.capacity": 1048576,
"browser.cache.disk.smart_size.first_run": false,
"browser.cache.disk.smart_size_cached_value": 1048576,
"browser.places.smartBookmarksVersion": 4,
"browser.startup.homepage_override.mstone": "18.0",
"browser.startup.homepage_override.buildID": "20130109132246",
"dom.mozApps.used": true,
"extensions.lastAppVersion": "18.0",
"network.cookie.prefsMigrated": true,
"places.history.expiration.transient_current_max_pages": 104858,
"places.database.lastMaintenance": 1354814978,
"privacy.sanitize.migrateFx3Prefs": true,
"security.warn_viewing_mixed": false,
"security.disable_button.openDeviceManager": false
},
"graphics": {
"numTotalWindows": 1,
"numAcceleratedWindows": 0,
"windowLayerManagerType": "Basic",
"numAcceleratedWindowsMessage": [
"no information"
],
"adapterDescription": "ATI Technologies Inc. -- AMD Radeon HD 6500M/5600/5700 Series",
"adapterVendorID": "ATI Technologies Inc.",
"adapterDeviceID": "AMD Radeon HD 6500M/5600/5700 Series",
"adapterRAM": "",
"adapterDrivers": "",
"driverVersion": "4.2.11931 Compatibility Profile Context",
"driverDate": "",
"webglRenderer": "ATI Technologies Inc. -- AMD Radeon HD 6500M/5600/5700 Series",
"info": {
"AzureCanvasBackend": "cairo",
"AzureFallbackCanvasBackend": "none",
"AzureContentBackend": "none"
}
},
"javaScript": {
"incrementalGCEnabled": true
},
"accessibility": {
"isActive": false,
"forceDisabled": 0
},
"libraryVersions": {
"NSPR": {
"minVersion": "4.9.4",
"version": "4.9.4"
},
"NSS": {
"minVersion": "3.14.1.0",
"version": "3.14.1.0"
},
"NSSUTIL": {
"minVersion": "3.14.1.0",
"version": "3.14.1.0"
},
"NSSSSL": {
"minVersion": "3.14.1.0",
"version": "3.14.1.0"
},
"NSSSMIME": {
"minVersion": "3.14.1.0",
"version": "3.14.1.0"
}
},
"extensions": [
{
"name": "Firebug",
"version": "1.11.1",
"isActive": true,
"id": "firebug@software.joehewitt.com"
},
{
"name": "LiveReload",
"version": "2.0.8",
"isActive": true,
"id": "livereload@livereload.com"
}
]
}

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

It is hard to say what is wrong without having access to that page or at least have a look at the page source.

Did you check the Web Console or the Error Console for errors regarding this?

Does any text get visible if you select that area with the mouse?

Did you make changes to default text and/or background colors that may be causing this?

  • Edit > Preferences > Content : Fonts & Colors > Colors

Question owner

This hasn't anything to do with the website. The screenshot was only to show how websites are being displayed in firefox. This applies to almost all websites I try to visit.

As an example, here are some more screenshots:

Same website with text selected: http://d.pr/i/KPSl

Remi Repository for Fedora: http://d.pr/i/QGtn Same website with text selected: http://d.pr/i/H330

Checked also in Edit > Preferences > Content and didn't find anything unusual there.

Question owner

I also opened the error console and the web console and it was full of errors. How to get the info?

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

You could be having a problem with the font that is used on those pages.

You can use this extension to see which fonts are used for text that is selected (right-click context menu: Show fonts in selection).

You can do a font test to see if you can identify corrupted font(s).

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Edit > Preferences > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

Question owner

Tried adding the add-on and checked the preferences and still no results. Here is a screenshot of the browserspy website.

Thank you.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

What is the current setting of the default font that will be used on web pages that do not specify a font?

Did you try the last suggestion?

You can try different default fonts and temporarily disable website fonts to test the selected default font.

  • Edit > Preferences > Content : Fonts & Colors > Advanced
  • [ ] "Allow pages to choose their own fonts, instead of my selections above"

Question owner

Hi again,

I've unchecked the "Allow pages to choose their own fonts, instead of my selections above" and now all fonts are displayed on every website.

I don't understand what is going on with the fonts. Weather it is a corruption in fonts on my machine or something in the system? Or weather it be Firefox. All fonts are displayed in other browsers without a problem.

Maybe this will fix it self after I update to Fedora 18? I don't remember if it did something when I tried installing additional fonts after I upgraded to Fedora 17 a half a year ago.

The sad thing now is that I can't see the font which the websites use.

cor-el
  • Top 10 Contributor
  • Moderator
10756 solutions 96800 answers

Helpful Reply

Did you manage to find out which font Firefox is using in the case when text doesn't display?

You will have to remove or update that font.
You can also check that font in Fontforge.

Chosen Solution

Hi again,

My problem was that since I'm on Linux and didn't install Microsoft fonts after I upgraded to Fedora 17 last year Firefox hasn't worked properly.

I needed to do 'wget http://www.my-guides.net/en/images/stories/fedora12/msttcore-fonts-2.0-3.noarch.rpm' in my terminal and then 'su -c 'rpm -ivh msttcore-fonts-2.0-3.noarch.rpm to install them.

Now I've got Arial, Verdana, Times New Roman, Trebushet MS, and a few others. But not Helvetica. It'd be best to find Helvetica font somewhere to be absolutly safe.

Thank you for your help.

Maybe it would be a good idea to have Firefox fetch fonts from a cdn on the internet if fonts on the website aren't installed on the clients system so that users can enjoy the web better?