Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to enable 'flex' in FF 18.0?

  • 1 reply
  • 1 has this problem
  • 333 views
  • Last reply by cor-el

more options

In this article: https://developer.mozilla.org/en-US/docs/CSS/Using_CSS_flexible_boxes The authors state that I can enable flexible box support in FF 18.0 through the 'about:config' screen. I just did it but 'display: flex' still doesn't work (and works fine in Chrome).

Is the notation different? Am I doing anything wrong?

Chosen solution

Doesn't seem to be working in Firefox 18 yet, but it does work in Firefox 19 and later.
In Nightly 21.0a1 the pref is enabled by default and in Aurora (I still have 19.0a2) it works after flipping the pref, so the next beta 19.0 should work.

data:text/html;charset=utf-8;base64,PCFET0NUWVBFIGh0bWw+CjxodG1sIGxhbmc9ImVuIj4KICA8aGVhZD4KICAgIDxzdHlsZT4KIAogICAuZmxleAogICB7CiAgICAgIC8qIGJhc2ljIHN0eWxpbmcgKi8KICAgICAgd2lkdGg6IDM1MHB4OwogICAgICBoZWlnaHQ6IDIwMHB4OwogICAgICBib3JkZXI6IDFweCBzb2xpZCAjNTU1OwogICAgICBmb250OiAxNHB4IEFyaWFsOwogCiAgICAgIC8qIGZsZXhib3ggc2V0dXAgKi8KICAgICAgZGlzcGxheTogLXdlYmtpdC1mbGV4OwogICAgICAtd2Via2l0LWZsZXgtZGlyZWN0aW9uOiByb3c7CiAKICAgICAgZGlzcGxheTogZmxleDsKICAgICAgZmxleC1kaXJlY3Rpb246IHJvdzsKICAgfQogCiAgIC5mbGV4ID4gZGl2CiAgIHsKICAgICAgLXdlYmtpdC1mbGV4OiAxIDEgYXV0bzsKICAgICAgZmxleDogMSAxIGF1dG87CiAKICAgICAgd2lkdGg6IDMwcHg7IC8qIFRvIG1ha2UgdGhlIHRyYW5zaXRpb24gd29yayBuaWNlbHkuICAoVHJhbnNpdGlvbnMgdG8vZnJvbQogICAgICAgICAgICAgICAgICAgICAgIndpZHRoOmF1dG8iIGFyZSBidWdneSBpbiBHZWNrbyBhbmQgV2Via2l0LCBhdCBsZWFzdC4KICAgICAgICAgICAgICAgICAgICAgIFNlZSBodHRwOi8vYnVnemlsLmxhLzczMTg4NiBmb3IgbW9yZSBpbmZvLikgKi8KIAogICAgICAtd2Via2l0LXRyYW5zaXRpb246IHdpZHRoIDAuN3MgZWFzZS1vdXQ7CiAgICAgIHRyYW5zaXRpb246IHdpZHRoIDAuN3MgZWFzZS1vdXQ7CiAgIH0KIAogICAvKiBjb2xvcnMgKi8KICAgLmZsZXggPiBkaXY6bnRoLWNoaWxkKDEpeyBiYWNrZ3JvdW5kIDogIzAwOTI0NjsgfQogICAuZmxleCA+IGRpdjpudGgtY2hpbGQoMil7IGJhY2tncm91bmQgOiAjRjFGMkYxOyB9CiAgIC5mbGV4ID4gZGl2Om50aC1jaGlsZCgzKXsgYmFja2dyb3VuZCA6ICNDRTJCMzc7IH0KIAogICAuZmxleCA+IGRpdjpob3ZlcgogICB7CiAgICAgICAgd2lkdGg6IDIwMHB4OwogICB9CiAgICAKICAgPC9zdHlsZT4KICAgICAKIDwvaGVhZD4KIDxib2R5PgogIDxwPkZsZXhib3ggbnVvdm88L3A+CiAgPGRpdiBjbGFzcz0iZmxleCI+CiAgICA8ZGl2PnVubzwvZGl2PgogICAgPGRpdj5kdWU8L2Rpdj4KICAgIDxkaXY+dHJlPC9kaXY+CiAgPC9kaXY+CiA8L2JvZHk+CjwvaHRtbD4=
Read this answer in context 👍 1

All Replies (1)

more options

Chosen Solution

Doesn't seem to be working in Firefox 18 yet, but it does work in Firefox 19 and later.
In Nightly 21.0a1 the pref is enabled by default and in Aurora (I still have 19.0a2) it works after flipping the pref, so the next beta 19.0 should work.

data:text/html;charset=utf-8;base64,PCFET0NUWVBFIGh0bWw+CjxodG1sIGxhbmc9ImVuIj4KICA8aGVhZD4KICAgIDxzdHlsZT4KIAogICAuZmxleAogICB7CiAgICAgIC8qIGJhc2ljIHN0eWxpbmcgKi8KICAgICAgd2lkdGg6IDM1MHB4OwogICAgICBoZWlnaHQ6IDIwMHB4OwogICAgICBib3JkZXI6IDFweCBzb2xpZCAjNTU1OwogICAgICBmb250OiAxNHB4IEFyaWFsOwogCiAgICAgIC8qIGZsZXhib3ggc2V0dXAgKi8KICAgICAgZGlzcGxheTogLXdlYmtpdC1mbGV4OwogICAgICAtd2Via2l0LWZsZXgtZGlyZWN0aW9uOiByb3c7CiAKICAgICAgZGlzcGxheTogZmxleDsKICAgICAgZmxleC1kaXJlY3Rpb246IHJvdzsKICAgfQogCiAgIC5mbGV4ID4gZGl2CiAgIHsKICAgICAgLXdlYmtpdC1mbGV4OiAxIDEgYXV0bzsKICAgICAgZmxleDogMSAxIGF1dG87CiAKICAgICAgd2lkdGg6IDMwcHg7IC8qIFRvIG1ha2UgdGhlIHRyYW5zaXRpb24gd29yayBuaWNlbHkuICAoVHJhbnNpdGlvbnMgdG8vZnJvbQogICAgICAgICAgICAgICAgICAgICAgIndpZHRoOmF1dG8iIGFyZSBidWdneSBpbiBHZWNrbyBhbmQgV2Via2l0LCBhdCBsZWFzdC4KICAgICAgICAgICAgICAgICAgICAgIFNlZSBodHRwOi8vYnVnemlsLmxhLzczMTg4NiBmb3IgbW9yZSBpbmZvLikgKi8KIAogICAgICAtd2Via2l0LXRyYW5zaXRpb246IHdpZHRoIDAuN3MgZWFzZS1vdXQ7CiAgICAgIHRyYW5zaXRpb246IHdpZHRoIDAuN3MgZWFzZS1vdXQ7CiAgIH0KIAogICAvKiBjb2xvcnMgKi8KICAgLmZsZXggPiBkaXY6bnRoLWNoaWxkKDEpeyBiYWNrZ3JvdW5kIDogIzAwOTI0NjsgfQogICAuZmxleCA+IGRpdjpudGgtY2hpbGQoMil7IGJhY2tncm91bmQgOiAjRjFGMkYxOyB9CiAgIC5mbGV4ID4gZGl2Om50aC1jaGlsZCgzKXsgYmFja2dyb3VuZCA6ICNDRTJCMzc7IH0KIAogICAuZmxleCA+IGRpdjpob3ZlcgogICB7CiAgICAgICAgd2lkdGg6IDIwMHB4OwogICB9CiAgICAKICAgPC9zdHlsZT4KICAgICAKIDwvaGVhZD4KIDxib2R5PgogIDxwPkZsZXhib3ggbnVvdm88L3A+CiAgPGRpdiBjbGFzcz0iZmxleCI+CiAgICA8ZGl2PnVubzwvZGl2PgogICAgPGRpdj5kdWU8L2Rpdj4KICAgIDxkaXY+dHJlPC9kaXY+CiAgPC9kaXY+CiA8L2JvZHk+CjwvaHRtbD4=