On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FF is changing the Locale for Web sites (Adobe/McAfee and even FF Support!); how can I fix it to en-US?

  • 3 replies
  • 1 has this problem
  • 6 views
  • Last reply by CarolaT

more options

Dear Sirs,

Here's an issue I have ONLY with FF, and ONLY on this machine:

1. Whenever I am entering SOME Web sites (among which, but not restricted to - Adobe, McAfee, Google [until I forcefully changed its Preferences], and even FF's Support), the Web site assumes that I need it in SPANISH (locale - es)! Here's an example: I type , < http://www.mcafee.com >, and the browser/ Web site switches ON ITS OWN to < http://www.mcafee.com/es/ > !

2. Just to clear things:

  a. I am running an English version of Win8 x64;
  b. The Windows interface language is set to en-US, and the location to Israel;
  c. The FF version is en-US
  d. As already stated, this happens ONLY in FF (IE & Chrome exhibit no such issues).

3. I would appreciate knowing which parm/ setting in FF leads the Web sites to believe that they have to switch to Spanish (and, of course, how to reset it to the correct -- English -- value).

Thanks in advance for your help,

Carola

Dear Sirs, Here's an issue I have ONLY with FF, and ONLY on this machine: 1. Whenever I am entering SOME Web sites (among which, but not restricted to - Adobe, McAfee, Google [until I forcefully changed its Preferences], and even FF's Support), the Web site assumes that I need it in SPANISH (locale - es)! Here's an example: I type , < http://www.mcafee.com >, and the browser/ Web site switches ON ITS OWN to < http://www.mcafee.com/es/ > ! 2. Just to clear things: a. I am running an English version of Win8 x64; b. The Windows interface language is set to en-US, and the location to Israel; c. The FF version is en-US d. As already stated, this happens ONLY in FF (IE & Chrome exhibit no such issues). 3. I would appreciate knowing which parm/ setting in FF leads the Web sites to believe that they have to switch to Spanish (and, of course, how to reset it to the correct -- English -- value). Thanks in advance for your help, Carola

Chosen solution

hello carola, could you check in firefox > options > content > languages if english is set as primary preference?

Settings for web content, pop-ups, fonts, and languages

Read this answer in context 👍 1

All Replies (3)

more options

One more point (to the same): starting FF in SAFE mode doesn't help either!

Also: when I stated that FF Support's Web site switches to Spanish (es), I referred -- of course -- to < https://support.mozilla.org > which switches on its own to < https://support.mozilla.org/es/home >.

Hope this helps.

Thanks again for any helpful info you may provide,

Carola

more options

Chosen Solution

hello carola, could you check in firefox > options > content > languages if english is set as primary preference?

Settings for web content, pop-ups, fonts, and languages

more options

Dear "MadPerson",

Thank you so much for your input.

Actually, it was Spanish that was in the first place (as it was the LAST I added to that set).

I reversed the order of the languages (thus having English in the first place and Spanish in the last), and the trouble went away :)

Who would have thought that THIS order of the languages mattered? The input just asks about which languages are going to be used, as a whole ...

Thanks again,

Carola